Nvidia-Smi shows "No devices were found"

I am having Ubuntu20.04.2 LTS VM with Tesla T4 GPU. I have installed nvidia-drivers using PPA graphics drivers. I have tried installing nvidia-driver-470,418,410. But after reboot, on doing nvidia-smi it shows “no devices were found”. But on doing lspci, I can see tesla T4… Any help would be greatly appreciated.

I have also tried installing the same drivers on ubuntu16.04 but no success. I am guessing OS version is not the issue over here.

Hi @rahulsherwan366
Please note this forum branch is dedicated to CUDA GDB support. You question might be more suitable for (for example): CUDA Setup and Installation - NVIDIA Developer Forums

Thanks for the response. I will change forum branch to cuda setup and installation.

Issue solved. Run as administrator was the issue. While assigning the GPU to the VM, we didn’t have administrator privileges which is why error was occurring. After assigning the GPU using administrative privileges to the VM , nvidia-smi worked fine.