Nvidia-smi: no devices were found

I wanted to install CUDA on a fresh installation of Ubuntu 22.04 using the network deb installer and followed the pre- and post- installation actions in the installation guide.

Nonetheless, I still get “No devices were found” after running nvidia-smi.

I have also tried removing the cuda driver as described in the document and installing it again. However it did not help. I also had the computer tested if the physical GPU is functional (it is).

I know this is a common problem, however I have not found anything that would help, and I would be grateful for advice.

nvidia-bug-report.log (3.5 MB)

NVRM: GPU 0000:01:00.0: RmInitAdapter failed! (0x31:0xffff:2447)
The gpu seems to be broken. Please double check by downgrading to a 470 driver in Software&Updates or installing Windows.
Also, please try reseating it in its slot.

Thank you for reply. Should I reinstall cuda after downgrading?

No. The cuda-toolkit should only be installed when the driver runs correctly, otherwise it would only be additional cruft.