No devices were found

I am using ubuntu 22.04 and i have Quadro m4000 GPU on my system.
You can see it:

➜  ~ lspci | grep -i nvidia
01:00.0 VGA compatible controller: NVIDIA Corporation GM204GL [Quadro M4000] (rev a1)
01:00.1 Audio device: NVIDIA Corporation GM204 High Definition Audio Controller (rev a1)

I use run file for install “”

After installation complete i run nvidia-detector:

➜  ~ nvidia-detector 

Then when i want to run nvidia-smi i get the err:

➜  ~ nvidia-smi 
No devices were found

I remove alll nvidia drivers and again installed the driver but not worked.


-> done.
-> Driver file installation is complete.
-> Running post-install sanity check:
-> done.
-> Post-install sanity check passed.
-> Would you like to run the nvidia-xconfig utility to automatically update your X configuration file so that the NVIDIA X driver will be used when you restart X?  Any pre-existing X configuration file will be backed up. (Answer: No)
-> Installation of the NVIDIA Accelerated Graphics Driver for Linux-x86_64 (version: 515.43.04) is now complete.  Please update your xorg.conf file as appropriate; see the file /usr/share/doc/NVIDIA_GLX-1.0/README.txt for details.

cuda-installer-log :

[INFO]: Driver not installed.
[INFO]: Checking compiler version...
[INFO]: gcc location: /usr/bin/gcc

[INFO]: gcc version: gcc version 11.2.0 (Ubuntu 11.2.0-19ubuntu1) 

[INFO]: Initializing menu
[INFO]: Setup complete
[INFO]: Components to install: 
[INFO]: Driver
[INFO]: 515.43.04
[INFO]: Executing --ui=none --no-questions --accept-license --disable-nouveau --no-cc-version-check --install-libglvnd  2>&1
[INFO]: Finished with code: 0
[INFO]: CUDA Toolkit 11.7

what should i do??

The log report file:
nvidia-bug-report.log (1.3 MB)