nvidia-smi tool and Tesla M2050 Doesn't report temperature value?


I just bought a Tesla M2050 from eBay, and after installing the compute board, I found that the temperature is reported as ‘N/A’ by nvidia-smi tool. Is this normal for the M2050, or did I get a defective card? I thought that the temperature sensor might be defective.

There have been a lot of complaints about the lack of temperature info with the current drivers. It certainly doesn’t work with the GeForce cards anymore, but I don’t recall if the Tesla cards see the same problem.

I wouldn’t worry about it. Probably better to run one of the CUDA memory test applications to make sure the card works.

I actually have the temperature reported for my geforce card. Which is why it is surprising to me. The test cases I tried works, so I’ll probably keep the GPU. Thank you.

What GeForce card do you have? I’m curious if this is a Fermi-only thing.

M2050 doesn’t have a normal temperature sensor that nvidia-smi can access; it’s reserved for OEM usage and available over an SMBus connection.

I have an M2050 and its driving me crazy: how do I get the core temperature? I’ve tried 10 different utilities, none of them work.

On Windows 7, how does one read the M2050 GPU temperature via SMbus? I don’t mind using a command line app.

I have an M2050 running under windows 7 and I use HWInfo64 to report temperature ( I was given the link in an earlier thread). You need to enable the tray icon in the sensors window but it works great. You will probably need additional cooling if you are running this in a normal case ( like me). On a cool day it idles around 63 degrees ( with a PCI fan blowing onto it) and I have never exceeded 80 degrees so far. It works a treat for my purpose - I bought two off ebay!

Hope that helps


Thanks! I spent a couple of days trying to find a method to look at the temperature, I’ll try this out tonight.