NVMe m.2 boot L4T 32.7.2?

We’ve been successfully booting from USB for a while with our L4T 32.7.2-based system; we’d like to move to using NVMe M.2 cards, but have yet to successfully boot from one.

We’re using 8GB RAM Xavier NX boards with 16GB emmc flash, if it matters.

When we flash the Xavier NX to boot from emmc (or USB, for that matter), we use the flash.sh script from L4T 32.7.2 like this:

sudo ./flash.sh jetson-xavier-nx-devkit-emmc mmcblk0p1

…and that writes the file system to internal emmc, and then we can either boot from USB (if installed) or internal eMMC (if it’s not installed). So, to test booting from NVMe, I first tried installing a file system directly on the m.2 flash (as if it were a USB drive, using an adapter). This did not work when installed in the m.2 nvme slot.

So, next I tried flashing the Xavier with the NVMe m.2 card installed like this:

sudo ./flash.sh jetson-xavier-nx-devkit-emmc nvme0n1

This seemed to complete OK. However, when it tried to boot from nvme, it hung for 30 seconds probing NVME(5), and then failed to boot. See the attached boot log:

jetson-boot-log.txt (30.6 KB)

This is using a Seeed Studios A203 version 2 carrier board; has anyone gotten this to work? I am also reaching out to Seeed directly, but wanted to make sure I wasn’t missing anything.

flash.sh cannot flash anything to other driver except emmc or internal sd.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.