Nvurisrc bin fails to connect application after adding rtsp reconnect interval property

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU) P1000
• DeepStream Version v6.1
• JetPack Version (valid for Jetson only) Not Applicable
• TensorRT Version 8.2.5-1+cuda11.4
• NVIDIA GPU Driver Version (valid for G PU only) (NVIDIA-SMI 510.85.02 Driver Version: 510.85.02 CUDA Version: 11.6)
• Issue Type( questions, new requirements, bugs)
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

Hi Team,

After referring deepstream-test3 from python apps, I have implemented the nvurisrcbin as the source bin. I have updated the following properties to run the application using Cuda memory.

  1. uri_decode_bin.set_property("cudadec-memtype", 0)
  2. streammux.set_property("nvbuf-memory-type", int(pyds.NVBUF_MEM_CUDA_DEVICE))

After implementing and changing/adding these two properties to source_bin, I’m able to run the application properly.

After this, I wanted to implement the rtsp-reconnect-interval property in the source bin as mentioned in the plugin gst-inspect, I tried setting the value to 3 sec. Adding this property, I’m not able to connect to stream right after I start the application. If I remove this property application works properly.

Please refer following error messege I got after adding rtsp-reconnect-interval property.

  1. Warning: gst-stream-error-quark: No data from source rtsp:/___________________ since last 3 sec. Trying reconnection (1): gstdsnvurisrcbin.cpp(1232): watch_source_status (): /GstPipeline:pipeline0/GstBin:source-bin-00/GstDsNvUriSrcBin:uri-decode-bin

  2. Warning: gst-resource-error-quark: Could not open resource for reading and writing. (7): gstrtspsrc.c(7871): gst_rtspsrc_retrieve_sdp (): /GstPipeline:pipeline0/GstBin:source-bin-00/GstDsNvUriSrcBin:uri-decode-bin/GstRTSPSrc:src:

Same thing I have observed in deepstream-test3-app, for reference I’m using the source uri as rtsp://____________ as input source.

cmd used for deepstream-test3 :- python3 deepstream_test_3.py -i rtsp://_________________ --no-display

Have you checked with the rtsp source you want to reconnect with? Is it working when the DeepStream app try to connect with it? The log shows that the RTSP server connection fail.

@Fiona.Chen, Thanks for the response
Yes, It is working properly. I have checked stream on VLC & used URIDecodebin with deepstream to test the source. It is working properly. But is giving an error only with nvurisrcbin.

It is observed right after the application start. when the first fps logs get printed.