Object detector yolov3 (deepstream) error

I’m using this repo https://github.com/NVIDIA-AI-IOT/deepstream_reference_apps/tree/master/yolo/samples/objectDetector_YoloV3

I’m running this on Jetson Nano (with JetPack 4.2.1).

$ deepstream-app --version-all
deepstream-app version 4.0
DeepStreamSDK 4.0
CUDA Driver Version: 10.0
CUDA Runtime Version: 10.0
TensorRT Version: 5.0
cuDNN Version: 7.3
Dewarper: not found

I’ve got this error :
$ deepstream-app -c deepstream_app_config_yoloV3.txt
** WARN: <parse_streammux:492>: Unknown key ‘cuda-memory-type’ for group [streammux]
** ERROR: <create_multi_source_bin:653>: Failed to create element ‘src_bin_muxer’
** ERROR: <create_multi_source_bin:715>: create_multi_source_bin failed
** ERROR: <create_pipeline:967>: create_pipeline failed
** ERROR: main:632: Failed to create pipeline
Quitting
App run failed

Any idea how to fix this ??

In the readme located in that folder there is instructions about running 2 scripts before you run.

deepstream-app -c deepstream_app_config_yoloV3.txt.

One sets the Cuda version and I cant remeber what the other on does.(Don’t have access to my nano at the moment)
I had to rum those commands before I could successfully run the examples.

are you talking about these 2 ?? :

cd nvdsinfer_custom_impl_YoloV3 mkdir build && cd build
$ cmake -D DS_SDK_ROOT= -D CMAKE_BUILD_TYPE=Release …

I’ve succefully run this.

I used the example that was download into the nano when I installed Deepstream4

this is the path to readme in nano:
/opt/nvidia/deepstream/deepstream-4.0/sources/objectDetector_Yolo;

#This is what I had to run.
$ export CUDA_VER=10.0
$ make _C nvdsinfer_custom_impl_Yolo

I followed the readme instructions to the letter but still got the error.

I’ve also failed to install https://github.com/NVIDIA-AI-IOT/deepstream_reference_apps/tree/master/yolo#deepstream-yolo-app

see :
https://devtalk.nvidia.com/default/topic/1057929/jetson-nano/deepstream-yolo-app-installation-error/?offset=3#5364979

I don’t have sources folder in /opt/nvidia/deepstream/deepstream-4.0/

this is where I have the installation : /home/jetson-nano/deepstream_reference_apps/yolo/samples/objectDetector_YoloV3/

This is the link to the instruction that I followed to install deepstream4 install.
I used .deb install

https://docs.nvidia.com/metropolis/deepstream/4.0/dev-guide/index.html

I’ve followed the guide but still got the same error

I am out of ammo on this one.

Thx a lot for your reply. This past 2 days, I’ve been looking everywhere to fix this problem but still nothing.

You’re setup on your nano seems to be different than mine. All my deepstream4 stuff is all located in the file: /opt/nvidia/deepstream/deepstream-4.0/ on my nano. Interesting

Hi,

Deepstream sample folder is located at /opt/nvidia/deepstream/deepstream-4.0/.
Thanks.

Same error for, I have used the latest jetpack

:/opt/nvidia/deepstream/deepstream-4.0/bin$ sudo ./deepstream-app -c /home/rssd/deepstream_sdk_v4.0_jetson/samples/configs/deepstream-app/config_infer_primary_nano.txt
** ERROR: <create_multi_source_bin:653>: Failed to create element 'src_bin_muxer'
** ERROR: <create_multi_source_bin:715>: create_multi_source_bin failed
** ERROR: <create_pipeline:967>: create_pipeline failed
** ERROR: <main:632>: Failed to create pipeline
Quitting
App run failed

RaviKiranK, you seem to be using nvinfer plugin config file and not the application config file. Can you try again by using the application config file ? It usually starts with source*…