omxh264dec config skip-frames=1 or 2, pipeline can not work


I run the follow command
gst-launch-1.0 -v filesrc location=/mnt/nfs/15.mp4 ! qtdemux ! queue ! h264parse ! omxh264dec skip-frames=2 ! queue ! fakesink

it will output the follow error message

#0 0xb6d4b3f0 in poll () at …/sysdeps/unix/syscall-template.S:81
#1 0xb6dfa4e6 in ?? () from /lib/arm-linux-gnueabihf/
Spinning. Please run ‘gdb gst-launch-1.0 8746’ to continue debugging, Ctrl-C to quit, or Ctrl-\ to dump core

anyone can help me solve the problems? can we control skip-frames when decode h264 using omxh264dec ?

thanks in advance.

If your goal with skipping frames is to achieve a some lower frame rate, maybe the “videorate” plugin helps you. With that you should be able to define the frame rate you want by duplicating or dropping frames.

Hello, kulve
I want decode only key-frame to reduce decode module usage,and then play key frame, how should I do?


If I use omxh264dec element to decode only key frame, how should I do ?


Can you solved the problem?