ONNXRUNTIME_GPU install or build fails

Tried installed the ONNXRUNTIME_GPU wheel from Jetson Zoo, and get

ERROR: onnxruntime_gpu-1.12.1-cp38-cp38m_aarch64-linux-gnu.whl is not a supported wheel on this platform.

  • Tried using pip
  • Tried using python3 -m pip

Also tried building it following instructions for Jetson (Jetpack 4.6.x), no go, fails compile when it hits
a bunch of invalid narrowing conversion from “char” to “signed char” errors when compiling

/onnxruntime/contrib_ops/cuda/quantization/qordered_ops/qordered_common.cuh
/onnxruntime/contrib_ops/cuda/quantization/qordered_ops/qordered_attention_impl.cu

Any ideas / suggestions / tips or tricks for this ?

Xavier NX 16GB on a Seeed A205 carrier board, running L4T35.1 / JP 5.0.2

Hi @apocnz, what does pip3 --version show for you? Does it report Python 3.8? (that wheel is for Python 3.8)

pip3 --version
pip 20.0.2 from /usr/lib/python3/dist-packages/pip (python 3.8)

Yes, pip3 --version returns

pip 22.2.2 from /usr/local/lib/python3.8/dist-packages/pip (python 3.8)

Figured it out however. I was downloading the wheel and naming it

onnxruntime_gpu-1.12.1-cp38-cp38m-linux_aarch64.whl

Running pip3 debug on the wheel, showed it needed to be named

onnxruntime_gpu-1.12.1-cp38-cp38-linux_aarch64.whl

Installs fine once renamed as above.

OK cool, thanks - glad that you were able to get it installed!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.