Error : torch-1.7.0-cp36-cp36m-linux_aarch64.whl is not a supported wheel on this platform

I install pytorch 1.7 in a virtual environment of Jetson agx xavier jackpack 4.5, but the following error occurs.

My virtual environment is python=3.6.12


Do you download the wheel file from this topic?

If not, could you try the file shared in the above topic?


It is the same as the pytorch installation file I installed.
The message above comes out.

Hi @hojun092912, I notice the version of python3 on your system is 3.6.12, but the default version is 3.6.9 (which is the version I built these PyTorch wheels with). I’m not sure if the minor sub-version of python3 being different makes the wheels incompatible or not.

Can you check if you can install the wheel outside of virtualenv to see if the issue is related to virtualenv or not? Is your python3 version also 3.6.12 outside of virtualenv?

If you can indeed install the wheel outside of virtualenv, you can use --system-site-packages argument to venv to access PyTorch from inside virtualenv. There is also the l4t-pytorch container that comes with PyTorch/torchvision/ect pre-installed.

I just used wheel_inspect package to look into the metadata of the wheel, and don’t see anything about 3.6.9 in there (just abi=cp36m), so I think it should work on 3.6.12 too. Still try it outside of virtualenv to see if that is related to the issue.

Also is this the URL you downloaded for PyTorch 1.7 wheel?

I tried installing it outside the virtual environment, but it failed.
The files I installed are the same as the path I shared above.
I don’t know what the hell is wrong.
Screenshot from 2021-02-25 08-55-18

I tried installing it outside the virtual environment, but it failed.

I just double-checked AGX Xavier with JetPack 4.5 and was able to install this wheel without problems.

Outside of virtualenv, what are your python3 and pip3 versions? Mine are showing Python 3.6.9
and pip3 9.0.1. Interestingly, my gcc also shows 7.5.0, even though yours showed 9.3.0 above.

I’m not familiar with using virtualenv - are you sure you are outside of virtualenv even though your terminal is still showing (base)?

Are you able to use the l4t-pytorch:r32.5.0-pth1.7-py3 container?