Torch is not a supported wheel on TX2

When I tried to install Pytorch on a new TX2 (42.2.2), I get allways the message:
“torch-1.3.0-cp27mu-linux_aarch64.whl is not a supported wheel on this plattform.”
Also when i tried it with the Jetson Inference Github version, I get just a python error:
“ERROR: import torch”
When I tried to build Torch from Source, it can’t import “yaml”.

Now I dont know a other way to install it.

Hi christoph, what is the command you use to install the torch wheel? Can you try the PyTorch 1.1 or 1.2 wheels and see if you get the same problem?

What is the pip version you have? Mine is reported below (9.0.1)
Is it possible that your pip version was upgraded, or python3 got linked to python (instead of python v2.7)?

$ sudo apt-get install python-pip
$ pip --version
pip 9.0.1 from /usr/lib/python2.7/dist-packages (python 2.7)
$ pip install torch-1.3.0-cp27-cp27mu-linux_aarch64.whl


the pythons got mixed up:

pip = python3

looks like now i’ll just use always python3 instant of python as solution