Torch-1.11.0-cp38-cp38-linux_aarch64.whl is not a supported wheel on this platform

hi i used orin nano

The show:

(fastbev) lin@lin-pc:~/Downloads$ pip install torch-1.11.0-cp38-cp38-linux_aarch64.whl
Looking in indexes:
ERROR: torch-1.11.0-cp38-cp38-linux_aarch64.whl is not a supported wheel on this platform.

How should I solve it?


Please try our prebuilt package instead:


Reply from the other PyTorch thread:

I solved it without virtualenv of anaconda.
I have multiple projects that require different environments.
Do U have a solution similar to anaconda?

@904798869 personally I use Docker containers for different environments and haven’t used conda/miniforge/virtualenv on Jetson/aarch64

hello dear friend,i have same trouble,ERROR: torch-1.11.0-cp38-cp38-linux_aarch64.whl is not a supported wheel on this platform.
But i have no more time,i could not chose l4t-pytorch. I try you gave the url , and answer is no.
i have a different thing my openvv :xxx with CUDA : YES . i delete opencv of jetpcak, then compiled and installed opencv using cmake. so its YES.
before i do this, i can do it by pip install torch-1.11.0-xxxx. i have twice reinstall system and no three. what should i do. save me!!! thank you dear friend!!!

The first time is i install torch and torchvision, they are correct version. my jetpack is 5.0.1, but i delete cuda 11.4 and install 11.6 .so i run yolov5 , error is torch is cuda 11.4 and torchvision is 11.6. so i try again and again. i got same answer. i must reinstall system.
Now i cant install torch!!! what hell!!!
you must konw what should i do,so tell me,friend.

man, i want to know how do you.

Hi @1249564878, what does pip3 --version show for you? Are you using conda/miniforge/virtualenv? If so, try disabling them.

Do any of these wheels work for you?

JetPack 5.0.1 was a Developer Preview release, so if you have to re-flash again, I would recommend doing it with the latest JetPack (5.1.1) and install/verify PyTorch before attempting to upgrade CUDA.

pip install torch-1.11.0-cp38-cp38-linux_aarch64.whl without virtualenv. U are successful. ^_^

I suggest burning the image again and then downloading the torch installation package from PyTorch for Jetson. Do not modify the default cuda version

Hi, are there any other solutions besides the Docker solution, which affects performance

Thank u, i have installed all the required environments.But when i run the yolov5-5.0, there’s a problem:(RuntimeError: Detected that PyTorch and torchvision were compiled with different CUDA versions. PyTorch has CUDA Version=11.4 and torchvision has CUDA Version11.6. Please reinstall the torchvision that matches your PyTorch install.)

My jetpack version is 5.0.2 GA,platform is Ubuntu20.04 focal,cuda=11.4.239,cuDNN=,python=3.8.10,pytorch=1.11.0,torchvision=0.12.0,and I installed them following the official tutorial(PyTorch for Jetson).
How can I solve this problem?


I think this happened because you upgraded to CUDA 11.6 prior to compiling torchvision. Try re-linking /usr/local/cuda-11.4 to /usr/local/cuda and recompiling/reinstalling torchvision.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.