OpenCL on 8800GTS 512 (G92) "There are no devices supporting OpenCL..."

Hi all,

I have a problem with starting any OpenCL-program including the programs that I have compiled from original sources. Programs starting and closing with error…

I tried with al the software from nVidia OpenCL page: Driver + SDK + NVIDIA GPU Computing SDK Browser + Profiler.

Configuration: Win7 64bit, 8800GTS 512 (G92), Intel Core2Quad Q6600.

I underdtand, that it is possible, that there is an error somewhere… But most “terrible” thing that the first program from SDK v2.30.908.2200 OpenCL Device Query says that:

.

At the same time I see 8800GTS in all compatibility lists and I understanf that it is foolish situation, because CUDA works perfect and OpenCL - doesn`t work at all.

What’s your driver version?

current driver is: 196.21_desktop_win7_winvista_64bit_english_whql
also tried some other, as for example nvdrivers_OpenCL_2.3_win7_190.89_general.exe from OpenCL section on nvidia.com

Used order of installation is: drivers -> SDK -> Profiler -> unsuccessfull start of OpenCL-program.

With drivers newer than 195 you need SDK 3.0 Beta (or newer)

(Mods, can we please make this info sticky? It must be at least the fifth time I remember writing this)