The program can't start because opencl.dll is missing from your computer

I have a Geforce 210 and windows 10 64bit and I want to run a simple program with opencl.

I installed latest cuda sdk and setup the project following instructions in with a little changes regarding environment variables.

Anyways, the project builds now but at runtime shows error dialog complaining about missing opencl.dll as the topic says. I looked up in the registry HKLM/software/khronos/opencl/vendors and there is an entry with the name C:\Windows\System32\nvopencl.dll. I looked in system32 folder and the file is not there. I searched opencl in system32 folder and three results where found:

opencl.dll in C:\Windows\System32\DriverStore\FileRepository\rdvgwddmdx11.inf_amd64_cedfb27d9d08d0a0
opencl32.dll and opencl64.dll in C:\Windows\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_4e97579e23acb4ca

What is going on and what should I do to run the simple program? The program source is just a couple of lines:


int main()
cl_int err;
cl_uint numPlatforms;

err = clGetPlatformIDs(0, NULL, &numPlatforms);
if (CL_SUCCESS == err)
	printf("\nDetected OpenCL platforms: %d", numPlatforms);
	printf("\nError calling clGetPlatformIDs. Error code: %d", err);

return 0;


I’ve tried to compile above code to build 64bit-app
and succesfully worked. (CUDA 7.5, Visual C++ 2013, Win7-64 & GeForce GT720)

nvcc simple.c opencl.lib

usually, the application should links
c:\Windows\System32\OpenCL.DLL(64bit-app) or
c:\Windows\SyswOW64\OpenCL.DLL(32bit-app) dynamically.