openCL support on linux driver

Hi
Card is n570 GTX. OS is suse 12.2 64 and normal driver functions are all OK
From searches on the net it appears that cuda and openCL support for drivers has been included into the mainstream driver on the versions supplied for 12.2.
Installed within the system packages I can see nvidia-computeG02 and within the file list I can see files libOpenCL etc.
I have tried 3 apps that look for openCL and none find and openCL device, the easiest test I find is an openCL raytrace prog and that does not show my card.
From many other posts I found someone with similar probs getting results from changing the etc/OpenCL/vendors/nvidia.icd file contents to point directly to /usr/lib64/libnvidia-opencl.so.304.60
Still no go.
Anyone any directions,tests, information?
I think this should really just be working and cannot be too much.
All help appreciated.

you’d need to list specific error messages when you run some of the openCL samples after compilation for anyone to be able to sufficiently help.

Try the troubleshooting in:
https://devtalk.nvidia.com/default/topic/522980/using-opencl-on-cuda-5-0/