[SOLVED]OpenCL dev files not working with 343 drivers on Ubuntu 14.04

I recently upgraded my graphics card to a GTX 980. In order to get this to work, I had to install the 343 driver. Since this version is not yet available in the official Ubuntu repo, I installed it from https://developer.nvidia.com/cuda-downloads-geforce-gtx9xx instead. So now I have:

  • Graphics driver
  • CUDA library
  • CUDA dev files
  • OpenCL library
    and they are all working fine. I can build and run CUDA programs, and run OpenCL programs. However, building OpenCL programs is not possible.
    I tried installing the nvidia-opencl-dev package (from the Ubuntu repo), but it insists on installing nvidia-libopencl1-331, and removing nvidia-libopencl1-343. Obviously this is a problem, since the 331 version doesn’t work with the GTX 900 series cards.

So my question is this: Where can I find a version of nvidia-opencl-dev that will work with the 343 version of opencl?

I apologize if this is the wrong forum for this, I could not find a dedicated forum for OpenCL.

does ubuntu have an nvidia-cuda-toolkit like debian does? https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=719833

nvidia-cuda-toolkit did the trick. I see it installed opencl-headers as a dependency, so that might have been all that was needed. In any case, thanks!

glad that solved it. :)