Install Nvidia Opencl package

I’m on a Linux live usb and I’m trying to get the opencl Nvidia package installed.
So I’ve installed all the necessary package: kernel headers, proprietary Nvidia drivers(340.xx) for my GPU(330m),
So now I need to install the Nvidia opencl package but when I issue the command:
Apt-get install nvidia-legacy-340xx-opencl-icd (which is the proper package for my driver) the installation starts, but between all the subpackages implied in the installing process, some is forcing me to install Nvidia driver(that I already have!) and besides the wrong version(352.xx that should be the last available) despite the fact that I’ve selected the opencl package for my specific driver(340-xx).
So I get an alert saying:

“This system has a graphics card which is no longer handled by the Nvidia driver (package nvidia-driver). You may wish to keep the package installed - for instance to drive some other card - but the card with the following chipset won’t be usable:
01:00.0 VGA compatible controller [0300]: Nvidia Corporation gt216M [GeForce GT 330M] [10de:0a29] (rev a2)
The above card requires either the non free legacy Nvidia driver (package nvidia-legacy-340xx-driver) or the free Nouveau driver (package xserver-xorg-video-nouveau).
Use the uodate-glx command to switch between different installed drivers.
Before the Nouveau driver can be used you must remove Nvidia configuration from xorg.c9nf (and xorg.conf.d/).
Install Nvidia driver despite unsupported graphics card?
Yes No”

Any ideas on how to solve this problem and get the opencl package installed, without change driver?

I had this problem too, installing legacy OpenCL also installed current drivers (which broke my system because I have a legacy card). I eventually got it working using the flag --no-install-recommends.

$ sudo apt-get install --no-install-recommends nvidia-legacy-340xx-opencl-icd

I also had to install ocl-icd-opencl-dev which provides before I got my OpenCL application running.

I think it good to report it to Canonical or Debian.