opencv compilation error

i try to compile a code that include opencv function and i get always “fatal error: blabla.hpp: No such file or directory” error. I can compile the same code in my machine and it run without an error. when i try to compile the same code in nvidia tx2 and i also use same Makefile, i get error. I reinstall opencv and the problem still remain.

Not sure if http://www.jetsonhacks.com/2017/04/05/build-opencv-nvidia-jetson-tx2/, included in http://elinux.org/Jetson_TX2, is still valid.

after you write the answer, i did it. It didnt work either. I get the same error

It seems a header file cannot be found on the Jetson.
Do you which version of opencv is installed on your host, and which version is installed on your Jetson ?

Could you precise which header file is not found (blabla.hpp doesn’t help), and how it is included (ex: #include “opencv2/opencv.hpp”) ?

Could you precise how you try to compile ?

If you are using opencv4tegra that is installed in /usr, then compiling with -I/usr/include should be enough for finding the opencv headers.

I solved the problem. I run this script “https://github.com/jetsonhacks/buildOpenCVTX2/blob/master/buildOpenCV.sh”. i forgot to run “make install” command. After the command it works fine. Thanks.