OpenCV4Tegra 2.4.8.2 on Jetson TK1

Hi All,

I’m testing the OpenCV4Tegra package downloaded from https://developer.nvidia.com/jetson-tk1-support on my Jetson TK1. But when I use a webcam as video source, I got these errors :

" HIGHGUI ERROR: V4L/V4L2: VIDIOC_S_CROP "

and also

"Corrupt JPEG data: 1 extraneous bytes before marker 0xd0
Corrupt JPEG data: 2 extraneous bytes before marker 0xd0
Corrupt JPEG data: 1 extraneous bytes before marker 0xd0
Corrupt JPEG data: 1 extraneous bytes before marker 0xd7
… "

Is there anyone has noticed these before and solved it ?

I’m getting the same error on a webcam I connected as well. Still working on a solution. Will let you know if I find something.

Hello,
I was also getting the same error. I just compiled opencv from latest source. Complete guide at http://elinux.org/Jetson/Installing_OpenCV

Since ffmpeg is not available from debian site, I downloaded the ffmpeg source and did ./configure, make , make install, before compiling opencv.

Also my usb 2.0 camera could not capture through usb 3.0 port on TK1. So I had to put micro-to-Full female usb adapter on the TK1 (micro OTG USB port) and then camera to it. It worked fantastic.

Hope this helps

ffmpeg should be configured as : ./configure --enable-shared --disable-static

Also do NOT do “make -j4” for compiling opencv; Just do “make”.

Hope this helps.

Anyone knows if opencv4tegra was compiled with v4l support?

I don’t believe so. AFAIK camera support has to be integrated into the kernel (and isn’t with NVIDIA’s kernel, you’d need to use the Grinch kernel or compile support yourself), it wouldn’t be part of OpenCV. Some folks with USB cameras, I believe, have gotten opencv4tegra working with it after the new kernel was installed, however.

Any progress in resolving this issue without recompiling opencv? Still appear in L4T R21.3 + Grinch 21.3.4 and OpenCV4Tegra 2.4.10.1 with Logitech C510 and C910.

Hi,

Please try to follow the steps given in the following blog to install opencv4tegra 2.4.10 and also the public opencv 2.4.9 with cuda 6.5 accelerations enabled.

You can change between the libraries during linking your application.

http://www.e-consystems.com/blog/camera/?p=1297

Maybe the issue you are facing is solved in one of these libraries. Please post back your reply after testing.