OpenGL GLX crashing with Steam games on GT520 system running Linux Mint 14

I’ve been using Steam to play DOTA 2 on my Linux Mint 14 64bit box with my GT 520 but today it suddenly stopped working. Whenever I try to launch DOTA I get the following message:

OpenGL GLX context is not using direct rendering, which may cause performance problems

and I’m giving the following unhelpful link: https://support.steampowered.com/kb_article.php?ref=9938-EYZB-7457

I’m running the NVIDIA drivers as managed by the Software Sources tool in Mint 14. Worked fine before this. The NVIDIA X Server Tools util says I’m running NVIDIA Driver Version 304.88 and X Server Version 11. The OpenGL/GLX Information tab has the following contents:

GLX Information:
Direct Rendering: Yes
GLX Extensions:
GLX_EXT_visual_info
GLX_EXT_visual_rating
GLX_SGIX_fbconfig
GLX_SGIX_pbuffer
GLX_SGI_video_sync
GLX_SGI_swap_control
GLX_EXT_swap_control
GLX_EXT_swap_control_tear
GLX_EXT_texture_from_pixmap
GLX_ARB_create_context
GLX_ARB_create_context_profile
GLX_EXT_create_context_es2_profile
GLX_ARB_create_context_robustness
GLX_ARB_multisample
GLX_NV_float_buffer
GLX_ARB_fbconfig_float
GLX_EXT_framebuffer_sRGB
GLX_NV_multisample_coverage
GLX_ARB_get_proc_address

.
. Lots of uninteresting GL stuff etc
.

OpenGL Information:
Version: 4.2.0 NVIDIA 304.88

I’m not that familiar with the video card issues on Linux so please let me know what other information may be useful for debugging this, and let me know if you know a solution!

nvidia-settings is a 64-bit application, while the Valve games are all 32-bit. It sounds like something in your system changed that broke the 32-bit version of libGL, for example by replacing it with Mesa’s version, while leaving the 64-bit one alone. I would suggest reinstalling the NVIDIA driver.

Thanks Aaron, would it be better to do it from package tools like Synaptic (as I currently am although the driver in the repo is pretty old) or should I grab the drivers right from NVIDIA and follow the readme? I guess the real question is: do I need to uninstall the packages managed by Synaptic/Apt if I want to install the driver directly as downloaded from NVIDIA?

I ended up installing the nvidia driver directly after purging my system of some of the packages I already had. After some fiddling I got it to work for a few hours but then the system hung up during a game of DOTA and afterwards it booted into a no-driver mode (ie 640x480 res). I tried another reinstall, nvidia-xconfig, etc but no luck. I decided that machine is pretty much a dedicated steam box now anyway so I just wiped it and put 13.10 on it, so I think it’ll be fine now.

If anyone else has this issue here’s a good post that may help you out (too bad I found it a little too late!):