OpenGL rendering on Tesla V100

We have a RHEL server with 2 video cards, an embedded Intel chip running nouveau / Mesa and an NVIDIA Tesla V100.
We ssh to the server from windows workstations using MobaXterm. The workstations have a variety of video cards, some have embedded Intel chips, some have various GeForce cards, and some have ATI Radeon cards.

After installing the NVDIA drivers (460.67), one 3rd party application gives an “Unable to create OpenGL graphics context” error.
We tried following the “Remote Visualization on Server-Class Tesla GPUs” white paper but are still unable to use it.
Our server is configured for headless operation. Last thing we tried was to run
nvidia-xconfig –enable-all-gpus
and we added

Option “ConnectedMonitor” “CRT-0”

in the screen section of all headless gpus in order to create an X11 screen. Still getting the same error.

A custom application that uses the NVIDIA GPU through EGL0 to create images (but does not display them to the user) works fine.

We are unsure where to go from here. Are there any resources to help us debug this behavior?

Modern GPUs don’t have VGA outputs, so CRT-0 isn’t a valid dpy name. If you want a dpy name that’s guaranteed to be valid, recent drivers support using “connector number” names such as Connector-0 for use with options like ConnectedMonitor and UseDisplayDevice.

Can you please run sudo and attach the bug report log from the failing configuration?