[OpenSuse 12.3] Difficulty for activate OpenGL rendering


I am on OpenSuse 12.3 but I had also the same problem with OpenSuse 12.2 before the upgrade.
I am on laptop ASUS 71V with graphical card NVidia 9700M GT.
I can’t use all graphical effects cause OpenGL is not active.

I see this error :

LIBGL_DEBUG=verbose glxinfo | grep rendering

libGL: screen 0 does not appear to be DRI2 capable
libGL: OpenDriver: trying /usr/lib64/dri/updates/tls/swrast_dri.so
libGL error: failed to load driver: swrast
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)

I reinstalled all mesa packages and all nvidia packages but no change.

I tryed many options in my /etc/X11/xorg.conf but no change.

Do you have any idea ?

Problem solved, driver on official depot for opensuse 12.3(driver 310.XXX…) was not the same of the current official driver(313.XXX…).

I just installed the current official driver and all was OK.


I have the same problem. My 9800GT with latest Nvidia drivers have not Direct Render activated (it show it in Nvidia settings windows).

“Direct Rendering No”

What can I do?

Make sure that your applications are picking up the right version of libGL.so.1. You can use “ldd” to tell which libGL is being used. Applications should be using the NVIDIA version and not Mesa.

Hi again

I don’t know how to use “ldd” command and even I try to execute glxinfo as root but that command does not exist. I have installed latest Nvidia oficial drivers for my card.

Any idea?

maybe it does the same, but easier to use: goto a terminal as root and run
nvidia-installer --sanity
it will check now if all files correctly in place / linked

I did you suggestion. Nvidia installer said all installation is fine.

What to do now?

Thank you!


I had the same problem and all i had to do to activate direct rendering was add my user to the video group and after a reboot direct rendering was enabled.

hope this helps.

I’m encountering the same problem with the GeForce GT 630 card on OpenSUSE 12.3. The symptom is that the graphics don’t look good. Fonts in terminal windows are difficult to read due to color bleeding. Looking at glxinfo, I noticed that Direct Rendering is not enabled.

I’ve tried switching cables, no change.

I’ve tried installing the latest driver, NVIDIA-Linux-x86_64-334.21.run. Previously I tried 331.49.

I’ve tried tweaking the xorg.conf, attempting to force DRI on.

As su, when I try # LIBGL_DEBUG=verbose glxinfo | grep rendering it says Direct Rendering is enabled.
I’ve tried nvidia-installer - sanity, no problems here.

If I do a console login as root, and then type startx, Direct Rendering is enabled, but the graphics/fonts still don’t look good. If I try a console login as non-root, the startx command fails.

At a loss at this point as to what to try next.