OptiX Error: 'Failed to load OptiX library


I downloaded the OptiX SDK on Ubuntu 16.04. When trying to run the precompiled samples, I get the following error:

OptiX Error: 'Failed to load OptiX library

Any idea where this is coming from?

What version of optix? What driver?

I got OptiX 6.0.0 and have the 390 Diver installed.

I just tried downloaded OptiX 5 and there the samples work.

Optix 5 and 6 SDKs are very different in how they load the optix lib. Optix 6 loads the optix library from the driver. With optix 5 it is a shared lib delivered with the SDK.

Your driver is out of date, hence failure to load optix driver module. As stated in the system requirements – a 418 driver is required. Let me know if this doesnt fix your issue.

Oh okay, thank you!
I cannot change the driver, because I am using OptiX in a different project, too.
I’m fine with using OptiX 5 for now.

Not sure if this is what you mean, but a 418 driver will work fine for optix 5 or 6 development.


I am having the same issue in Ubuntu 16.04 with the driver 418.

I have tried OptiX versions 5, 6 and 7. Version 5 works fine but 6 and 6 fail with different error messages. In 6 I have the same error show already in the current thread:

OptiX Error: 'Failed to load OptiX library

at rtContextCreate.

And in version 7 an exception is thrown in optixInit:

Caught exception: OPTIX_ERROR_ENTRY_SYMBOL_NOT_FOUND: Optix call 'optixInit()' failed

Do you have any idea what is the reason?
Thank you very much.

As stated in the release notes, optix 6 and 7 have minimum driver requirements. With these versions of optix, the optix library is loaded from the driver (similar to libGL). for 6.5 or 7, a 435.17 or newer driver is needed.

Ok, thank you.


I have similary problem on Ubuntu 18.04 with Driver Version: 440.33.01. When I try to run any SDK example I have got:

OPTIX_ERROR_LIBRARY_NOT_FOUND: Optix call ‘optixInit()’ failed

Note: Ubuntu 18.04 runs in singularity under CentOS 7

Thanks for help.

@milan.jaros, which version of the OptiX SDK are you asking about?



And you’re running OptiX & Ubuntu inside a container, is that right? (I don’t have experience with Centos or Singularity.) Is the 440 Nvidia driver installed in the container, or only in the host system? I believe there are some threads here about getting OptiX to run inside containers that might help. The main thing that needs to happen is that your driver DLLs need to be accessible from inside the container, and the driver needs to work in the container as well, obviously, but getting the driver to work inside a container is not something we can help with in the OptiX forum.


Is there some verbose mode - for getting more info about the error? (build flag, env. variable)


nvidia-smi or CUDA apps work without error.

The first thing to check is the paths to the .so files the SDK sample is trying to load. You can normally do this in *unix using strace, and it will show you all the paths that it tried to use. Assuming that it’s failing to find the OptiX .so files (they have either ‘optix’ or ‘rtcore’ in the names), you can look around on your system to find where those .so files are and see where the OptiX sample is trying to find them.


Thanks it helps (missing some libnv*.so files). Now it works.

I have the same problem.
I use V100 SXM2 with dirver 440.33.01, cuda 10.2 and optix 6.5 on Ubuntu 16.04LTS.

optixHello works well
optixRaycasting told me that “Failed to load OptiX library”

And $ ldd optixRaycasting tells me that every lib is found.

Does V100 SXM2 support optix 6.5?

This is odd because optixHello and optixRaycasting use the exact same code to load the nvidia libraries. Are both of them from the same SDK build? Do you have any symlinks or a relative path in your LD_LIBRARY_PATH which could be causing the difference?

Try running strace on both optixHello and optixRaycasting and see where each of them is looking for the nvoptix library.

Yes, optix 6.5 will work on this card. ldd will not show the issue because the nvoptix and nvidia-rtcore libs are opened dynamically at runtime.