Orin Nano Won’t Install Drivers Jetpack 5.1.2 SdkManager

I’ve been trying to flash my orin nano dev kit with a compatible nvme ssd with sdk manager for 15 days straight, 8-10 hours a day every day and every time I get errors no matter what I do. I flashed and reflashed so many times and it gives me Installation Complete, but when I check the drivers are not installed, how can I install the drivers? I’ve been trying with sdkmanager Jetpack 5.1.2 and it won’t install the drivers. Extra context I’m on ubuntu 20.04 and I also bought an external ssd for temp files and a dummy displayport adaptor. Please help me get this to work.

Are you using the “tools/kernel_flash/l4t_initrd_flash.sh” for command line flash? With external media you need this. There is a README there about this method.

Note that if you get a flash failure, then you should include the flash log. For the GUI there is an export logs button, but anything command line, you’d append this to the end of the command to get the log:
2>&1 | tee log_flash.txt
(there is a space, then “2>&1” to redirect errors, and finally tee to create a log file)

It is hard to say what kind of error since there is no log. Incidentally, if the monitor behind a DisplayPort adapter is HDMI, then it should work since it passes through EDID configuration. If that monitor is VGA, then I would expect failure to boot (but not failure to flash).

Thank you for the reply! I reflashed my orin nano to get you the logs. Also you mentioned using a command for the external ssd, is that for the one connected directly to the orin nano or the one connected to my computer? I have a Sandisk external storage for the temp files and a 990 ssd pro connected underneath the orin nano. The command you mentioned is for manual flashing or can I do that with the sdkmanager as well?
SDKM_logs_JetPack_5.1.2_Linux_for_Jetson_Orin_Nano_modules_2024-03-16_09-01-39.zip (523.4 KB)

That command is for a disk attached to the Orin. There are ways to clone or install disk content on another computer as well. Direct use of SDKM does not really have the options for initrd flash. Did you read the README file in “tools/kernel_flash/” which tells you how to use l4t_initrd_flash.sh on command line? That is the key to external media (on the Jetson) being used as the root filesystem.

Could you please add a link to that and guide me through it?
I’m honestly drained, I’ve spent 210+ hours trying every possible way to do this, I flash with the sdkmanager then try to install the drivers but nothing works. I try nvidia-smi and get “no command found” then 'sudo ubuntu-drivers install and it says “No drivers found for installation”. I tried to manually install versions like 535, 510 etc but all of them get erros and stop. Please guide me through what I should do, I lost so much time on this and I’m so frustrated because this was $500+ and now I’m working everyday on this 14-18 hours a day.

What is the exact “driver” you are talking about here?

You posted a log but what I saw is the log said you already finish the board flash.

nvidia-smi is not in use on Jetson platform. If you want to use CUDA, then you need to install the sdk thing from sdkmanager. But it looks like got installed based on your log too.

Instead of spending another 14 hours, I think you should clarify what kind of drivers you are doing here…

nvidia-smi is incompatible with Jetsons. I think this is why @WayneWWW is asking about which driver.

Please note that Jetsons have an integrated GPU (iGPU) which is directly wired to the memory controller. Desktop PCs use a PCIe based discrete GPU (dGPU), and their drivers are different. nvidia-smi requires PCI bus to work. The versions of applications which directly depend on the iGPU versus dGPU are downloaded via JetPack/SDK Manager. Those you find on the web are for a dGPU.

All of the public drivers with a name format such as 535 and 510 are dGPU drivers.

I was asking because of this error:

~$ sudo dmesg | grep -i nvidia
[ 0.000000] Machine model: NVIDIA Orin Nano Developer Kit
[ 0.002659] DTS File Name: /dvs/git/dirty/git-master_linux/kernel/kernel-5.10/arch/arm64/boot/dts/…/…/…/…/…/…/hardware/nvidia/platform/t23x/p3768/kernel-dts/tegra234-p3767-0003-p3768-0000-a0.dts
[ 0.210875] DMI: Unknown NVIDIA Orin Nano Developer Kit/NVIDIA Orin Nano Developer Kit, BIOS 4.1-33958178 08/01/2023
[ 11.323092] systemd[1]: Starting NVIDIA specific first-boot udev script…
[ 12.695876] input: NVIDIA Jetson Orin NX HDA HDMI/DP,pcm=3 as /devices/platform/3510000.hda/sound/card0/input1
[ 12.696024] input: NVIDIA Jetson Orin NX HDA HDMI/DP,pcm=7 as /devices/platform/3510000.hda/sound/card0/input2
[ 12.696179] input: NVIDIA Jetson Orin NX HDA HDMI/DP,pcm=8 as /devices/platform/3510000.hda/sound/card0/input3
[ 12.696272] input: NVIDIA Jetson Orin NX HDA HDMI/DP,pcm=9 as /devices/platform/3510000.hda/sound/card0/input4
[ 16.987601] nvidia: loading out-of-tree module taints kernel.
[ 16.995527] nvidia: module license ‘NVIDIA’ taints kernel.
[ 17.026330] nvidia: module verification failed: signature and/or required key missing - tainting kernel
[ 17.064283] nvidia-nvlink: Nvlink Core is being initialized, major device number 503
[ 17.072273] The NVIDIA GPU driver for AArch64 has not been qualified on this CPU
[ 17.074276] NVRM: No NVIDIA GPU found.
[ 17.074711] nvidia-nvlink: Unregistered Nvlink Core, major device number 503
[ 17.272789] nvidia-nvlink: Nvlink Core is being initialized, major device number 503
[ 17.279941] The NVIDIA GPU driver for AArch64 has not been qualified on this CPU
[ 17.281958] NVRM: No NVIDIA GPU found.
[ 17.282392] nvidia-nvlink: Unregistered Nvlink Core, major device number 503

Do you know a way to fix this? SdkManager won’t fix it I tried reflashing many times in all different ways. Btw thank you for your patience, this is for a project that’s really important to me.


Are you trying to install something that does not support on Jetson? There is no nvlink here.

Hi, I have the ZED mini camera and I installed Zed Sdk, I’m trying to use it for that, and it does have support on the Jetson. I even installed the one for NVIDIA Jetsons Jetpack 5.1.2 and it mentions the orin nano.
I was wondering because it mentions no nvidia gpu found in the error message I sent you. Do you know what I could do?


I feel the issue here is your installation for some drivers ( I don’t know which one) corrupted the original kernel so nvidia.ko gives you “verification failed: signature and/or required key missing - tainting kernel” and then “NVRM: No NVIDIA GPU found.”

The issue here is not related to how you flash the board. I believe the NVIDIA gpu was able to get detected right after your flash.

The problem here is we really don’t know how many things you are installing on your side. For example, nvidia-nvlink should not be there, but it appears. Now you even mentioned Zed Sdk.

Try not to install everything altogether. Otherwise you just repeat wasting your another 14 hours…

You must remove all of the dGPU software. This will conflict with the iGPU driver. If listing packages via something like “dpkg -l | grep -i 'nv'” fails to list what is from the external packages, then you will probably have to back up any important data and then flash again.

Hi linuxdev,
thank you for the reply, I’m trying to re flash the orin nano and I’m getting this error.

I tried to add the Public Key but it doesn’t work:
rafavaz0@ubuntu:~$ sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 5ACE721D3EFA7C6A
[sudo] password for rafavaz0:
Executing: /tmp/apt-key-gpghome.S8AgzZ4CsG/gpg.1.sh --keyserver keyserver.ubuntu.com --recv-keys 5ACE721D3EFA7C6A
gpg: keyserver receive failed: No data

then I tried searching for that 5ACE721D3EFA7C6A public key on https://keyserver.ubuntu.com/ and it says not found.

Do you know what I could do in this case? Do I get a new public key? Btw thanks for keep working with me to solve this.

Hi @rafavaz0901

Just to clarify. How did you install these things when it was on 3/17? Also, why does it become jetpack5.1.1 now? Why not just keep on using jetpack5.1.2?

You shared us a log at that time and it seems there was no such problem at that time.

But it got apt issue on your host PC now. The host PC should be same machine here. If it is same machine, I don’t expect you would hit such error.

Install what things exactly? I’m going with jetpack 5.1.1 because first I tried so many different solutions and I couldn’t solve the issue with the libGL.so when trying to run software for the Zed camera, second, when it comes to my issue some people had better luck with the 5.1.1 instead of the 5.1.2. I still don’t understand the problem because the camera’s diagnostic doesn’t show errors and the camera’s software is indeed compatible with the orin nano.
It is the same host PC, so just to confirm, that error is on the host PC not on the orin nano’s software right? I’m trying to re flash it to start fresh again but that error won’t let me. Should I just reinstall ubuntu? Because ubuntu’s keyserver doesn’t recognize the key that the warning is showing.

For some context on the previous error I mentioned I was trying to solve
These are the libGL errors I’m talking about:

libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
X Error of failed request: BadValue (integer parameter out of range for operation)
Major opcode of failed request: 149 (GLX)
Minor opcode of failed request: 24 (X_GLXCreateNewContext)
Value in failed request: 0x0
Serial number of failed request: 26
Current serial number in output stream: 27
libpng warning: iCCP: known incorrect sRGB profile
“Errors occurred

then the other is:

libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
** [SVO] Hardware compression (NVENC) not available **
Stack trace (most recent call last):
#20 Object “ZED_Explorer”, at 0x44af87, in
#19 Object “/usr/lib/aarch64-linux-gnu/libc.so.6”, at 0xffff88f44e0f, in __libc_start_main
#18 Object “ZED_Explorer”, at 0x43262f, in
#17 Object “/usr/lib/aarch64-linux-gnu/libQt5Core.so.5”, at 0xffff895bda5b, in QCoreApplication::exec()
#16 Object “/usr/lib/aarch64-linux-gnu/libQt5Core.so.5”, at 0xffff895b53b7, in QEventLoop::exec(QFlagsQEventLoop::ProcessEventsFlag)
#15 Object “/usr/lib/aarch64-linux-gnu/libQt5Core.so.5”, at 0xffff896121cb, in QEventDispatcherGlib::processEvents(QFlagsQEventLoop::ProcessEventsFlag)
#14 Object “/usr/lib/aarch64-linux-gnu/libglib-2.0.so.0”, at 0xffff8630ac5b, in g_main_context_iteration
#13 Object “/usr/lib/aarch64-linux-gnu/libglib-2.0.so.0”, at 0xffff8630abbb, in
#12 Object “/usr/lib/aarch64-linux-gnu/libglib-2.0.so.0”, at 0xffff8630a94b, in g_main_context_dispatch
#11 Object “/usr/lib/aarch64-linux-gnu/libQt5Core.so.5”, at 0xffff89611e37, in
#10 Object “/usr/lib/aarch64-linux-gnu/libQt5Core.so.5”, at 0xffff89611507, in QTimerInfoList::activateTimers()
#9 Object “/usr/lib/aarch64-linux-gnu/libQt5Core.so.5”, at 0xffff895b6c0b, in QCoreApplication::notifyInternal2(QObject*, QEvent*)
#8 Object “/usr/lib/aarch64-linux-gnu/libQt5Widgets.so.5”, at 0xffff8b67ead7, in QApplication::notify(QObject*, QEvent*)
#7 Object “/usr/lib/aarch64-linux-gnu/libQt5Widgets.so.5”, at 0xffff8b6754ab, in QApplicationPrivate::notify_helper(QObject*, QEvent*)
#6 Object “/usr/lib/aarch64-linux-gnu/libQt5Core.so.5”, at 0xffff895e45b7, in QObject::event(QEvent*)
#5 Object “/usr/lib/aarch64-linux-gnu/libQt5Core.so.5”, at 0xffff895f1557, in QTimer::timeout(QTimer::QPrivateSignal)
#4 Object “/usr/lib/aarch64-linux-gnu/libQt5Core.so.5”, at 0xffff895e3bff, in QMetaObject::activate(QObject*, int, int, void**)
#3 Object “ZED_Explorer”, at 0x44b9db, in
#2 Object “ZED_Explorer”, at 0x48de77, in
#1 Object “ZED_Explorer”, at 0x4793b7, in
#0 Object “/usr/lib/aarch64-linux-gnu/libQt5OpenGL.so.5”, at 0xffff8bcd1770, in QGLWidget::qglClearColor(QColor const&) const
Segmentation fault (Address not mapped to object [(nil)])
Segmentation fault (core dumped)


Let me clarify things again.

What I am talking about is it seems your installation for those SDK provided by NVIDIA was fine on Jetpack5.1.2.

Please be aware that I am talking about SDK provided by NVIDIA. This is NVIDIA forum so I can only help on NVIDIA sdk first.

If that thing is working and fine, then don’t need to install sdk from jetpack5.1.1. Just use the jetpack5.1.2.

As for your other problems, I don’t want to discuss technical things right now because your issue here is obviously not there yet. Your problem is your description and purpose are not clear.

For example, tell us what is the exact thing you install and how you reproduce that error.

If you notice you corrupted existing NVIDIA driver, share us the log so that we can confirm.
Please do not just initiate another reflash and another 14 hours working without telling us.

I feel the situation is totally not what you can control. Any further trying will just lead you to another wasting of time.

Hi @WayneWWW,

The reason I was trying to go to Jetpack 5.1.1 was that some people had some errors using Jetpack 5.1.2 with the camera I’m using, even though on their website they are compatible.

To clarify what I’m struggling with, is first that libGL error and swrast error problem which I’m guessing it might be from the orin nano (I am not entirely sure that’s why I’m seeking help from you guys that have knowledge on these things and I truly appreciate the help).
Second is that public key error which I just wanted clarification on whether it is the ubuntu that is corrupted and should be reinstalled or something with the orin nano’s software.


From my point of view, I don’t think you need to downgrade. So the apt-key issue is not something I really care. If you want to install jetpack5.1.1, please file a new topic for that key problem.

For this issue, please use fresh jp5.1.2 or even 5.1.3 and share us how you reproduce your issue.

Hi @linuxdev,
I just had a question about the Jetpack version just out of curiosity, because I tried that code you mentioned dpkg -l | grep -i 'nv' and got everything correct I believe, but I was going through it and saw “nvidia-l4t-cuda 35.4.1-20230801124926” and I also did head -n 1 /etc/nv_tegra_release and got “# R35 (release), REVISION: 4.1, GCID: 33958178, BOARD: t186ref, EABI: aarch64, DATE: Tue Aug 1 19:57:35 UTC 2023”.

I don’t understand why it says 4.1 on both if I had installed 5.1.2 on sdkmanager. Does the revision mean something else and is there any other way I could check to see it clearly stating 5.1.2 or not? If not that’s okay I just wanted to make sure I had everything working correctly and versions matching.