Pairing issue in bluetooth

Hi Team,

I am trying to bring up Bluetooth in UART using CYW43455 module in the custom board with Jetson Nano module.

I have done the following steps:

  1. I did the changes mentioned in this link.

  2. Copied the firmware to /etc/firmware folder.

  3. I did hciattach and following are the logs.

$ sudo hciattach -t 30 /dev/ttyTHS1 bcm43xx 3000000 flow
bcm43xx_init
Set Controller UART speed to 3000000 bit/s>
Flash firmware /etc/firmware/BCM4345C0_003.001.025.0144.0266.1MW.hcd>
Set Controller UART speed to 3000000 bit/s
Device setup complete

  1. Then I tried pairing from board to device with bluetoothctl and got the following logs:

$ sudo bluetoothctl>
[NEW] Controller 48:EB:62:C2:B8:C7 BlueZ 5.48 [default]
Agent registered
[bluetooth]# agent on>
Agent is already registered>
[bluetooth]# default-agent
Default agent request successful
[bluetooth]# scan on
Discovery started
[CHG] Controller 48:EB:62:C2:B8:C7 Discovering: yes
[NEW] Device 75:6E:A7:64:9C:05 75-6E-A7-64-9C-05
[NEW] Device 94:65:2D:99:CD:12 793ffad1
[NEW] Device 0D:61:95:00:1C:9B boAt Rockerz 600>
[bluetooth]# scan off
[CHG] Device 0D:61:95:00:1C:9B RSSI is nil
[CHG] Device 94:65:2D:99:CD:12 RSSI is nil
[CHG] Device 75:6E:A7:64:9C:05 RSSI is nil
[CHG] Controller 48:EB:62:C2:B8:C7 Discovering: no
Discovery stopped
[bluetooth]# pair 0D:61:95:00:1C:9B
Attempting to pair with 0D:61:95:00:1C:9B>
[CHG] Device 0D:61:95:00:1C:9B Connected: yes
Failed to pair: org.bluez.Error.AuthenticationFailed>
[CHG] Device 0D:61:95:00:1C:9B Connected: no

I am getting the above issue " Failed to pair: org.bluez.Error.AuthenticationFailed ". But If I try to pair and connect from the device to my board it is successful. Can you help me to resolve this issue?

@kayccc @WayneWWW @jonathanh @alanz

Thanks,
Sakthi

Hello!

There is a note on this page that says if the device does not have a pin, then you may need to manully ‘trust’ the device first by executing the ‘trust’ command.

Regards
Jon

Hi,

I tried executing the trust command before pair command as mentioned in the above link. But I am facing the same issue.

#bluetoothctl
[NEW] Controller 48:EB:62:C2:B8:C7 mistral-desktop [default]
[NEW] Device F8:DA:0C:48:D7:BC LAP391U
Agent registered
[bluetooth]# trust F8:DA:0C:48:D7:BC
[CHG] Device F8:DA:0C:48:D7:BC Trusted: yes
Changing F8:DA:0C:48:D7:BC trust succeeded
[CHG] Device F8:DA:0C:48:D7:BC RSSI: -70
[CHG] Device F8:DA:0C:48:D7:BC TxPower: 10
[CHG] Device F8:DA:0C:48:D7:BC UUIDs: 0000110e-0000-1000-8000-00805f9b34fb
[CHG] Device F8:DA:0C:48:D7:BC UUIDs: 0000110c-0000-1000-8000-00805f9b34fb
[CHG] Device F8:DA:0C:48:D7:BC UUIDs: 0000110a-0000-1000-8000-00805f9b34fb
[CHG] Device F8:DA:0C:48:D7:BC UUIDs: 0000110b-0000-1000-8000-00805f9b34fb
[CHG] Device F8:DA:0C:48:D7:BC UUIDs: 00001112-0000-1000-8000-00805f9b34fb
[CHG] Device F8:DA:0C:48:D7:BC UUIDs: 00001108-0000-1000-8000-00805f9b34fb
[CHG] Device F8:DA:0C:48:D7:BC UUIDs: 00001133-0000-1000-8000-00805f9b34fb
[CHG] Device F8:DA:0C:48:D7:BC UUIDs: 00001132-0000-1000-8000-00805f9b34fb
[CHG] Device F8:DA:0C:48:D7:BC UUIDs: 0000112f-0000-1000-8000-00805f9b34fb
[CHG] Device F8:DA:0C:48:D7:BC UUIDs: 00001104-0000-1000-8000-00805f9b34fb
[CHG] Device F8:DA:0C:48:D7:BC UUIDs: 00001106-0000-1000-8000-00805f9b34fb
[CHG] Device F8:DA:0C:48:D7:BC UUIDs: 00001105-0000-1000-8000-00805f9b34fb
[CHG] Device F8:DA:0C:48:D7:BC UUIDs: 00005005-0000-1000-8000-0002ee000001
[bluetooth]# pair F8:DA:0C:48:D7:BC
Attempting to pair with F8:DA:0C:48:D7:BC
[CHG] Device F8:DA:0C:48:D7:BC Connected: yes
Failed to pair: org.bluez.Error.AuthenticationFailed
[CHG] Device F8:DA:0C:48:D7:BC Connected: no

Can anybody help me in resolving this?
@kayccc @WayneWWW @jonathanh @alanz

Thanks,
Sakthi

Can you give some pointers to resolve this issue?
@alanz @WayneWWW @jonathanh @kayccc

Hi,

Could anyone help me to resolve this issue?
@alanz @WayneWWW @jonathanh @kayccc

Thanks,
Sakthi

Is there any devices paired or connected? pls try as followed instructions.

[bluetooth]# devices

-> If there is something in here, run:

[bluetooth]# remove XX:XX:XX:XX:XX:XX

Now run the command trust and then try to pair:

[bluetooth]# trust XX:XX:XX:XX:XX:XX

[bluetooth]# pair XX:XX:XX:XX:XX:XX

Hi @alanz,

Thanks for your reply. I have tried the commands that you have mentioned, the output is as follows:

#bluetoothctl
Agent registered
[bluetooth]# agent on
Agent is already registered
[bluetooth]# default-agent
Default agent request successful
[bluetooth]# scan on
Discovery started
[NEW] Device D8:BB:2C:3C:88:8F iPhone
[bluetooth]# scan off
[CHG] Device D8:BB:2C:3C:88:8F RSSI is nil
[CHG] Controller 48:EB:62:C3:A0:D7 Discovering: no
Discovery stopped
[bluetooth]# devices
Device D8:BB:2C:3C:88:8F iPhone
[bluetooth]# remove D8:BB:2C:3C:88:8F
[DEL] Device D8:BB:2C:3C:88:8F iPhone
Device has been removed
[bluetooth]# trust D8:BB:2C:3C:88:8F
Device D8:BB:2C:3C:88:8F not available

I am getting the error “device not available”, if I try to remove the device and trust the device. Could you please let me know what other things I need to check?

Thanks,
Sakthi

You may try to systemctl restart bluetooth.service and make sure the devices (iphone) is aviable for pair and connection.

If it’s still not work, you can try other bluetooth device to see if there are any devices. I have an andriod phone which works well.

Hi @alanz,

I tried connecting to the android mobile after restarting bluetooth. If I do scan off and then remove device. I am getting “device not found” error.

Without turning off scan, If I do remove and trust. trust is succeeded but pairing issue still exists.

The following are the logs:

[bluetooth]# devices
Device F4:F5:DB:A2:69:4A Naveena
[bluetooth]# remove F4:F5:DB:A2:69:4A
[DEL] Device F4:F5:DB:A2:69:4A Naveena
Device has been removed
[NEW] Device F4:F5:DB:A2:69:4A Naveena
[bluetooth]# trust F4:F5:DB:A2:69:4A
[CHG] Device F4:F5:DB:A2:69:4A Trusted: yes
Changing F4:F5:DB:A2:69:4A trust succeeded
[bluetooth]# pair F4:F5:DB:A2:69:4A
Attempting to pair with F4:F5:DB:A2:69:4A
[CHG] Device F4:F5:DB:A2:69:4A Connected: yes
Failed to pair: org.bluez.Error.AuthenticationFailed
[CHG] Device F4:F5:DB:A2:69:4A Connected: no

Can you give some other pointers for me to debug?

Thanks,
Sakthi