Jetson Nano Bluetooth broken *Fix Inside*

Hello,

I’m using the WiFi/Bluetooth module:
https://www.amazon.co.uk/gp/product/B07SJLWWT3/ref=ppx_yo_dt_b_asin_title_o02_s00?ie=UTF8&psc=1

I’ve been using it for around a year mainly for connecting my PS4 controller. I have paired the controller and I could connect it in headless mode right away.

About few days ago I couldn’t do that anymore. Whenever I was trying to connect it was unsuccessful. After trying to connect for about 3 mins it can connect sometimes. (after trying non stop)

I have done a test where I have plugged in the display to see Bluetooth settings as it connects. It appears that they connect for half a second and immediately disconnect. (the on/off switch in main Bluetooth settings for this device).
Also the task bar Bluetooth symbol disappears and comes back with a lock on (like when it worked) and then immediately disappears again and Bluetooth symbol with no lock appears.

I have further tested:

  • Different Controller

  • Ordered a new WiFi/Bluetooth module

  • Got a different SD card and loaded up a fresh JetPack 4.5.

Prior to this incident I haven’t done anything remotely close that would cause this issue. It’s for my final year project in my university and I don’t have any idea what else I could try.

Any help is appreciated.
Thank you in advance

Have you tried enabling debug on the Bluetooth service via systemd?
You might be able to gain more info from the logs once enabled.

This should help: Enable debug Bluetooth stackoverflow

I have literally just fixed the issue.

The problem has 2 parts from my debugging.

1st part - on JetPack 4.5 there is a bug in nvargus-daemon and it crashes. (something I will try to fix later)
2nd part - for some reason ps4 controller needs to be reseted when pairing between different versions of JetPack (I’ve tested this on 4.5 and 4.4). 4.4 works flawlessly so far

maybe it’s to do with ubunut 18.4 update for Bluetooth manager

1 Like

I am facing the same issue. @garfmaster3 did you fix it?

Even though the topic says “fix inside” and marked as “solved”, I do not see a fix for the issue. Was you able to find a solution? I am using the same 8265 module and my issue was caused by upgrade to JetPack 4.5 too.

With JetPack 4.4 my Bluetooth keyboard with touchpad worked as expected: pairing without errors, after turning off and on it automatically connected. After upgrade to 4.5, it stopped working well. After pairing it fails to connect automatically, but I can connect it manually if I activate pairing mode on the keyboard and then choose connect from the menu in Bluetooth devices. Without the keyboard and touchpad, I cannot control the cursor, so I have to use VNC or ssh connection to get my keyboard and touchpad working by manually connecting after switching the keyboard with touchpad to pairing mode. If I do not use the keyboard for a while, it disconnects and never connects automatically again. But it seems it tries to connect automatically but fails, here is the log after the keyboard is turned on (since it is paired and trusted, it should have successfully connected but it did not):

Mar  1 08:12:46 jetson bluetoothd[4931]: src/adapter.c:connected_callback() hci0 device 54:46:6B:17:38:FA connected eir_len 5
Mar  1 08:12:46 jetson bluetoothd[4931]: src/device.c:device_set_class() /org/bluez/hci0/dev_54_46_6B_17_38_FA 0x000540
Mar  1 08:12:47 jetson bluetoothd[4931]: src/adapter.c:dev_disconnected() Device 54:46:6B:17:38:FA disconnected, reason 3
Mar  1 08:12:47 jetson bluetoothd[4931]: src/adapter.c:adapter_remove_connection()
Mar  1 08:12:47 jetson bluetoothd[4931]: plugins/policy.c:disconnect_cb() reason 3
Mar  1 08:12:47 jetson bluetoothd[4931]: src/adapter.c:bonding_attempt_complete() hci0 bdaddr 54:46:6B:17:38:FA type 0 status 0xe
Mar  1 08:12:47 jetson bluetoothd[4931]: src/device.c:device_bonding_complete() bonding (nil) status 0x0e
Mar  1 08:12:47 jetson bluetoothd[4931]: src/device.c:device_bonding_failed() status 14
Mar  1 08:12:47 jetson bluetoothd[4931]: src/adapter.c:resume_discovery()

I confirmed with bluetoothctl that it is trusted and paired. So far I haven’t found any workaround. The issue is still present after upgrade to latest JetPack 4.5.1.

exactly. same problem after upgrading to jetpack 4.5.
@ShaneCCC can you help us out please

Hi,

Sorry for late reply. Is any bluetooth device failed here? Or only specific bluetooth device like keyboard/mouse…

For me Bluetooth does not work properly at all but it has different issues with each device. For example, with keyboard/mouse the issue is that it does not connect automatically (this is regression and used to work perfectly in JetPack 4.4 but stopped working in JetPack 4.5, I tried to reinstall twice to be sure). This makes Bluetooth keyboard unusable since I am forced to use USB keyboard and mouse anyway in order to manually connect Bluetooth keyboard/touchpad. With headphones, it is stuck in low quality headset mode and I cannot switch to high quality A2DP mode. As it is right now, it is almost like not having Bluetooth at all. If there is anything I could try, please let me know.

Actually we tired to pair panel with Nano to transfer data and it works.

If this is specific to mouse/keyboard, then we need to find one and test.

I’m not sure what “panel” you are talking about.

To reproduce the issue with Bluetooth keyboard/touchpad (my guess exact model does not matter; I’m using Bluetooth Wireless Mini Keyboard with Touchpad Remote Control for PC | eBay):

  1. Connect and pair it as usually. It will work at first.
  2. Turn it off and back on, or reboot Jetson Nano. Bluetooth keyboard/touchpad will not work connect automatically with JetPack 4.5 (with JetPack 4.4 it worked as expected).

With Bluetooth headphones the issue is even worse because they do not work properly at all. My guess the issue would be reproducible with any Bluetooth headphones with built-in microphone. They will be stuck in low quality audio headset mode and will refuse to switch to A2DP mode which is necessary to actually hear good quality audio. It does not matter what method to switch to A2DP I use, both in GUI or in command-line, it just does not work. I can try to get more debugging information later (when I figure out how; right now I’m not sure exactly how to debug this).

Correct my word… should be tablet but not panel…
Not sure why I wrote panel in that comment…

in my case it is a sony ps4 controller with jetpack 4.5.
It connects for a second and disconnects.
I should try atleast 5 times to get it connected.
This problem does not occur in jetpack 4.3 when i tested. please confirm
thank you

Hi siddharth,

Could you also try jetpack4.4? Would like to know which release starts to have such issue.

jetpack 4.4 also has the same problem. jetpack 4.3 works completely fine

Any dmesg and syslog to provide here?

This issue looks like only to some specific devices.

i must confirm that ps3 controller behaves just the same as ps4, with the complication that it never completes the connection, the status keep jumping from connected to disconnected and, of course, it never works (if not connected via usb)

Same issue here:

I have an Edimax EW-7611ULB BT/WLAN USB dongle connected to a Jetson Nano P3450 with latest JetPack 4.5.1.

If I pair my Microsoft BT Notebook Mouse 5000 and my Apple Wireless BT Keyboard from the Ubuntu desktop, the connection is stable. But after a reboot, the devices seem to connect and disconnect within a second whenever activated (e.g. when the mouse is moved). The following can be seen in the syslog while physically moving the mouse:

Apr 22 22:58:31 jetson bluetoothd[7858]: src/adapter.c:connected_callback() hci0 device 00:22:48:DB:FC:B8 connected eir_len 46
Apr 22 22:58:31 jetson bluetoothd[7858]: src/adapter.c:dev_disconnected() Device 00:22:48:DB:FC:B8 disconnected, reason 3
Apr 22 22:58:31 jetson bluetoothd[7858]: src/adapter.c:adapter_remove_connection()
Apr 22 22:58:31 jetson bluetoothd[7858]: plugins/policy.c:disconnect_cb() reason 3
Apr 22 22:58:31 jetson bluetoothd[7858]: src/adapter.c:bonding_attempt_complete() hci0 bdaddr 00:22:48:DB:FC:B8 type 0 status 0xe
Apr 22 22:58:31 jetson bluetoothd[7858]: src/device.c:device_bonding_complete() bonding (nil) status 0x0e
Apr 22 22:58:31 jetson bluetoothd[7858]: src/device.c:device_bonding_failed() status 14
Apr 22 22:58:31 jetson bluetoothd[7858]: src/adapter.c:resume_discovery()
Apr 22 22:58:34 jetson bluetoothd[7858]: src/adapter.c:connected_callback() hci0 device 00:22:48:DB:FC:B8 connected eir_len 46
Apr 22 22:58:34 jetson bluetoothd[7858]: src/adapter.c:dev_disconnected() Device 00:22:48:DB:FC:B8 disconnected, reason 3
Apr 22 22:58:34 jetson bluetoothd[7858]: src/adapter.c:adapter_remove_connection()
Apr 22 22:58:34 jetson bluetoothd[7858]: plugins/policy.c:disconnect_cb() reason 3
Apr 22 22:58:34 jetson bluetoothd[7858]: src/adapter.c:bonding_attempt_complete() hci0 bdaddr 00:22:48:DB:FC:B8 type 0 status 0xe
Apr 22 22:58:34 jetson bluetoothd[7858]: src/device.c:device_bonding_complete() bonding (nil) status 0x0e
Apr 22 22:58:34 jetson bluetoothd[7858]: src/device.c:device_bonding_failed() status 14
Apr 22 22:58:34 jetson bluetoothd[7858]: src/adapter.c:resume_discovery()

For the adapter’s wireless functionality I also installed the following driver (but it did not affect the BT issue it seems): GitHub - lwfinger/rtl8723bu: Driver for RTL8723BU

Some more infos:

root@jetson:~# dmesg |grep -i blue
[    0.612073] Bluetooth: Core ver 2.22
[    0.612125] Bluetooth: HCI device and connection manager initialized
[    0.612138] Bluetooth: HCI socket layer initialized
[    0.612146] Bluetooth: L2CAP socket layer initialized
[    0.612171] Bluetooth: SCO socket layer initialized
[    1.440010] Bluetooth: RFCOMM socket layer initialized
[    1.440019] Bluetooth: RFCOMM ver 1.11
[    1.440032] Bluetooth: HIDP (Human Interface Emulation) ver 1.2
[    1.440037] Bluetooth: HIDP socket layer initialized
[    2.203791] usb 1-2.3: Product: Edimax Wi-Fi N150 Bluetooth4.0 USB Adapter
[    4.546325] Bluetooth: hci0: rtl: examining hci_ver=06 hci_rev=000b lmp_ver=06 lmp_subver=8723
[    4.546333] Bluetooth: hci0: rtl: loading rtl_bt/rtl8723b_config.bin
[    4.553228] bluetooth hci0: Direct firmware load for rtl_bt/rtl8723b_config.bin failed with error -2
[    4.562471] bluetooth hci0: Falling back to user helper
[    5.125520] Bluetooth: hci0: Failed to load rtl_bt/rtl8723b_config.bin
[    5.132421] Bluetooth: hci0: rtl: loading rtl_bt/rtl8723b_fw.bin
[    5.188312] Bluetooth: hci0: rom_version status=0 version=1
[    5.188330] Bluetooth: cfg_sz 0, total size 22496
[    5.437677] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[    5.437688] Bluetooth: BNEP socket layer initialized

root@jetson:~# bluetoothctl
[NEW] Controller 08:BE:AC:0E:99:67 jetson [default]
[NEW] Device 28:CF:E9:72:E4:8D Apple Keyboard
[NEW] Device 00:22:48:DB:FC:B8 Microsoft Bluetooth Notebook Mouse 5000
Agent registered
[bluetooth]# paired-devices
Device 28:CF:E9:72:E4:8D Apple Keyboard
Device 00:22:48:DB:FC:B8 Microsoft Bluetooth Notebook Mouse 5000

root@jetson:~# hciconfig -a
hci0:   Type: Primary  Bus: USB
        BD Address: 08:BE:AC:0E:99:67  ACL MTU: 820:8  SCO MTU: 255:16
        UP RUNNING PSCAN ISCAN
        RX bytes:7692 acl:27 sco:0 events:410 errors:0
        TX bytes:29597 acl:27 sco:0 commands:278 errors:0
        Features: 0xff 0xff 0xff 0xfe 0xdb 0xff 0x7b 0x87
        Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3
        Link policy: RSWITCH HOLD SNIFF PARK
        Link mode: SLAVE ACCEPT
        Name: 'jetson'
        Class: 0x000000
        Service Classes: Unspecified
        Device Class: Miscellaneous,
        HCI Version: 4.0 (0x6)  Revision: 0xe2f
        LMP Version: 4.0 (0x6)  Subversion: 0x9f73
        Manufacturer: Realtek Semiconductor Corporation (93)

root@jetson:~# grep -v ^# /lib/systemd/system/bluetooth.service.d/nv-bluetooth-service.conf

[Service]
ExecStart=
ExecStart=/usr/lib/bluetooth/bluetoothd -d

(in other words, this proposed solution did not help)

Any help would be appreciated.

Same probleme here , PS4 Controller…

src/device.c:device_bonding_failed() status 14

But after a reboot, the devices seem to connect and disconnect within a second whenever activated (e.g. when the mouse is moved). The following can be seen in the syslog while physically moving the mouse:

Can more people here confirm that this issue requires a reboot? And if this issue is only happens on jetpack4.5?

I got the probleme without reboot.

here is my case :

Hardware : Jetson nano JP4.5 + AC8265 module + PS4 Bluetooth controller

  1. Factory reset my bluetooth controller
  2. Pair it with Jetson
  3. At this step controller is properly paired and working
  4. turn off bluetooth in ubuntun UI.
  5. turn on bluetooth again
  6. Turn on my controller
  7. probleme append here ( It connect than, inmediatly disconnect)

So just switching bluetooth on and off make the probleme append also