Nano Bluetooth

I am having a problem with getting a bluetooth speaker to work on the Nano. I go through pairing and it says that it is paired. When I select from the bluetooth Icon and select the device. There is a padlock beside the bluetooth Icon and it disappears after 3 second… I there a sequence i am not aware of ? I have searched the forum for a recommended set up sequence but have found none. I am using the intel 8265 module.

hi bell55527

I don’t have a bluetooth speaker now.
I tried with my Nano and Intel 8265NGW module. It works fine.

I send a file from the nano to my phone via the bluetooth without any issue.

jetbot@jetbot:~$ ifconfig
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.0.172  netmask 255.255.255.0  broadcast 192.168.0.255
        inet6 fe80::e07:2a7a:ce82:cba  prefixlen 64  scopeid 0x20<link>
        ether 00:04:4b:e3:f8:61  txqueuelen 1000  (Ethernet)
        RX packets 61  bytes 12647 (12.6 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 151  bytes 19076 (19.0 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 148  base 0xe000  

l4tbr0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        inet 192.168.55.1  netmask 255.255.255.0  broadcast 192.168.55.255
        inet6 fe80::2021:39ff:fed7:3df3  prefixlen 64  scopeid 0x20<link>
        inet6 fe80::1  prefixlen 128  scopeid 0x20<link>
        ether 72:b5:f7:73:b7:5d  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 10  bytes 864 (864.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1  (Local Loopback)
        RX packets 226  bytes 17294 (17.2 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 226  bytes 17294 (17.2 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

rndis0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 72:b5:f7:73:b7:5d  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

usb0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 72:b5:f7:73:b7:5f  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.0.102  netmask 255.255.255.0  broadcast 192.168.0.255
        inet6 fe80::c671:a3c7:3755:3d31  prefixlen 64  scopeid 0x20<link>
        ether 44:03:2c:7c:4e:3f  txqueuelen 1000  (Ethernet)
        RX packets 77  bytes 8302 (8.3 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 46  bytes 7425 (7.4 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

jetbot@jetbot:~$ lspci
00:01.0 PCI bridge: NVIDIA Corporation Device 0fae (rev a1)
00:02.0 PCI bridge: NVIDIA Corporation Device 0faf (rev a1)
01:00.0 Network controller: Intel Corporation Wireless 8265 / 8275 (rev 78)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)
jetbot@jetbot:~$ lsusb
Bus 002 Device 002: ID 0bda:0411 Realtek Semiconductor Corp. 
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 8087:0a2b Intel Corp. 
Bus 001 Device 002: ID 0bda:5411 Realtek Semiconductor Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
jetbot@jetbot:~$ 
jetbot@jetbot:~$ 
jetbot@jetbot:~$ lsmod
Module                  Size  Used by
fuse                  103841  3
bnep                   16562  2
btusb                  40149  0
btrtl                   7318  1 btusb
btbcm                   8808  1 btusb
btintel                10771  1 btusb
iwlmvm                368205  0
mac80211              719792  1 iwlmvm
iwlwifi               167043  1 iwlmvm
nvs                    54527  0
cfg80211              589351  3 iwlmvm,iwlwifi,mac80211
nvgpu                1555053  18
bluedroid_pm           13912  0
ip_tables              19441  0
x_tables               28951  1 ip_tables
jetbot@jetbot:~$ iwconfig
lo        no wireless extensions.

usb0      no wireless extensions.

l4tbr0    no wireless extensions.

dummy0    no wireless extensions.

wlan0     IEEE 802.11  ESSID:"vvt_2.4G"  
          Mode:Managed  Frequency:2.427 GHz  Access Point: B4:0F:3B:2C:75:91   
          Bit Rate=144.4 Mb/s   Tx-Power=22 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=70/70  Signal level=-21 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:32   Missed beacon:0

eth0      no wireless extensions.

rndis0    no wireless extensions.

asking about bluetooth to an audio speaker. Not data xfer

Hi, bell55527

I don’t have a bluetooth audio speaker by hand. Maybe someone else could share some useful information.

I do have a Bluetooth speaker I use with Ubuntu. I have noticed the audio doesn’t work everywhere. For example, it’s muted in chrome. If I plug the speaker in via 3.5mm it works fine. I would wager this is an Ubuntu Bluetooth/audio issue. I will test it on nano later if I find my USB Bluetooth adapter which is small and hiding

Thank you mdegans for investigation. I didn’t know that the audio on chrome is muted.

I plugged in a bluetooth adapter and it bound to a speaker, but no sound came out.

I also plugged the HDMI cable into a monitor that has speakers and got no sound, this was playing a video on youtube. My conclusion at this time is that the nano is not configured to output sound.

There is a setting for Chromium, under advanced, for blocking sound, but it appeared to be enabled and just to make sure I added the website to the approved group.

Hello!

Audio playback via HDMI is definitely supported and should work. Please ensure that you have selected the HDMI as the current playback device in the ‘Sound’ settings menu under the Ubuntu desktop settings menu.

I believe that Bluetooth audio should also be supported. I will ask someone to confirm the status.

Regards,
Jon

I selected HDMI as the current playback device in the 'Sound" settings menu and that works. Under “Bluetooth” settings it shows the speaker as paired, but the on/off button does not toggle for the speaker.

I tested today with a usb bluetooth adapter and a speaker and it didn’t work. Different symptoms than on Desktop Ubuntu, however. On my desktop the speaker pairs and it works in the test app but not in chrome. On nano, it doesn’t seem to want to stay paired at all. Lsusb for the USB bluetooth adapter is Bus 001 Device 013: ID 0a5c:21e8 Broadcom Corp. BCM20702A0 Bluetooth 4.0 and the speaker is a Fugoo FSNA1 (if i’m reading that right).

I checked to make sure and the audio isn’t muted, but thanks for pointing me to that. I wasn’t aware of the setting. Audio comes out of my workstation if i plug in wired headphones and the audio device switches to the internal audio card. It’s one of those wierd things. I showed the problem to a Chrome engineer who isn’t sure what’s causing it either (but he doesn’t work on audio). My solution is to just use the 3.5mm input which provides better quality anyway. Bluetooth audio is laggy and lossy.

Could you tell me where the 3.5mm audio jack is on the Jetson Nano?

Sorry for the confusion. I meant that’s what I do on my Ubuntu desktop and laptop to connect to the speaker or my bluetooth heaphones that have similar issues. The nano has no 3.5mm jack that I know of.

The bluetooth audio is related to A2DP profile, and that’s disable by default due to Nano does not have bluetooth, we did have some guideline documentation for TX2/TX1 about how to enable the bluetooth audio, probably same could be applied to Nano as well, please follow the L4T doc to see if can get it working:
https://docs.nvidia.com/jetson/l4t/index.html#page/Tegra%2520Linux%2520Driver%2520Package%2520Development%2520Guide%2Fbluetooth.html%23wwpID0ESHA

Thanks

I knew that the jetson nano didn’t have bluetooth so I purchased and installed the intel 8265NGW with dual antennas. I was able to get through the first 2 step of enabling bluetooth audio. However when I get to step 3 to remove A2DP. I get the following response:

grady@grady-desktop:~$ sudo ExecStart=/usr/lib/bluetooth/bluetoothd -d --noplugin=audio,a2dp,avrcp
sudo: invalid option – ‘d’
usage: sudo -h | -K | -k | -V
usage: sudo -v [-AknS] [-g group] [-h host] [-p prompt] [-u user]
usage: sudo -l [-AknS] [-g group] [-h host] [-p prompt] [-U user] [-u user]
[command]
usage: sudo [-AbEHknPS] [-r role] [-t type] [-C num] [-g group] [-h host] [-p
prompt] [-T timeout] [-u user] [VAR=value] [-i|-s] []
usage: sudo -e [-AknS] [-r role] [-t type] [-C num] [-g group] [-h host] [-p
prompt] [-T timeout] [-u user] file …
How do I get to the command line?

kayccc, as I am able to see the bluetooth device and bind to it, I figured that only the first step of installing pulse-audio-module-bluetooth was all that would be required. here is what happened when I tried it:

len@len-nano:~ sudo apt-get install pulse-audio-module-bluetooth [sudo] password for len: E: Could not get lock /var/lib/dpkg/lock-frontend - open (11: Resource temporarily unavailable) E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), is another process using it? len@len-nano:~

bell, try ^C (control and c)

kaycc, I tried again thinking it may be, as it said, temporary. This time, after the usual reading lists and building tree, reading state info, it came back with:
E: Unable to locate package pulse-audio-module-bluetooth

At this point it is academic for me as I have plugged into a HDMI monitor with speakers and no longer need the bluetooth audio.