Performance Issues with MX250 on Kubuntu 18.04 LTS after changing prime profile

Hi guys,

I am relatively new to Linux and the open source world.
I installed Kubuntu 18.04 LTS on my Xiaomi Mi Notebook Pro 2019 Version about a month ago. After the OS install, I installed the latest proprietary drivers via the Kubuntu Drivers GUI (nvidia-435) and everything worked fine until two weeks ago.
I unplugged my Laptop and changed the prime profile to power save mode, so that I can save some battery on the go. After that, I changed back to power mode and that was when the issues started. The font sizes were much smaller than they normally should be and also my system is extremely slow, much slower than with internal graphics. My fans are as well working really hard, even though I am not doing anything.
Also when I look into the driver manager GUI it shows, that I am using the nouveau driver instead of the nvidia one. When I change that, it installs the driver, refreshes and shows that I am using the nouveau driver again. When I run sudo lshw -c video I can verify that the proprietary driver is used however. So this at least seems to be an error of the GUI only. The performance and the thermal issues on the other hand persist and I cannot figure out what causes this.
When I change the prime profile to power save mode and my system is using the internal graphics card, everything is working like a charm.

I already tried the following:

  • Changing the driver to the older version 430.
  • Removing all nvidia drivers with sudo apt-get purge nvidia* and reinstalling with command line
  • Removing all nvidia drivers and reinstalling with GUI
  • Removing all nvidia drivers and reinstalling latest driver nvidia-440 (GUI and command line)

Can anybody tell me what I am missing here?

nvidia-bug-report.log (728.9 KB)

There’s something wrong with your system’s acpi or pci, bbswitch is turning off your gpu and then can’t turn it on again:
[ 297.951751] bbswitch: Succesfully loaded. Discrete card 0000:01:00.0 is on
[ 297.953408] bbswitch: disabling discrete graphics

[ 8049.660901] bbswitch: enabling discrete graphics
[ 8049.660947] pci 0000:01:00.0: Refused to change power state, currently in D3
For a quick workaround, please create
/etc/lib/modprobe.d/blacklist-bbswitch.conf with contents
blacklist bbswitch
then run
sudo update-initramfs -u
and reboot.
To check if there’s something wrong with acpi, please run
sudo acpidump >acpidump.txt
and attach the output file.

Thank you very much for the fast reply.
I did as you suggested and attached the new log and the acpidump files.

acpidump.txt.log (971.7 KB) nvidia-bug-report_new.log (998.0 KB)

Ok, looks like the nvidia gpu is functional again. Now please check for a better workaround, add kernel parameters
acpi_osi=! acpi_osi=“Windows 2009”
remove the blacklist file again, run sudo update-initramfs -u and reboot. Then check if the nvidia gpu is still functional.

Yes the nvidia gpu is still functional. The performance is still really bad however.
Attached the new bug-report and acpidump.txt
acpidump.txt.log (971.7 KB) nvidia-bug-report.log (2.2 MB)

Something is taxing your gpu, please use nvidia-settings to check GPU Utilization for opening/closing the applications you’re using.

Again thank you for your help.
This is already happening after boot. When I open any program even if it is only the terminal and I want to maximize the window, it takes about 20 seconds to finish the operation. Also the font sizes of the whole system is completely messed up, once I activate the Nvidia (Performance Mode) prime profile.
When I use the prime profile Intel (Power Saving Mode), everything is working as it is supposed to be. So I can only assume that there needs to be something wrong with the Nvidia driver.
I do not understand what I am supposed to do with the nvidia-settings now. I am sorry, I am new to Linux. Can you please explain further?

Regarding nvidia-settings, start it, click on"GPU 0", there a line “GPU Utilization:” should show up. The problem looks like something is putting a high load on your gpu while not doing much.
Since it’s right from the start, that would not show anything, I guess. Please run ‘top’ in a terminal and check if some process is also eating up cpu.

There is no process putting a high load on my system. GPU Utilization shows that my graphics card is only 5% in use. Also the CPU is totally fine with only 3% in use. I really do not know whats going on here. On my other PC everything is working perfectly fine out of the box with an AMD graphics card. I do not understand why Nvidia is not able to do this.
Seems like I have to stick with my internal GPU for now and hope that the upgrade to Kubuntu 20.04 will solve the issue soon.