Kbuntu 18.04 gives black screen on prime-select after starting up after the new updates

Hello! I’m a bit new to this. So, after the last couple of updates (kernel upgrade to 5.3.0 and nvidia-driver to 440 of the official kubuntu repos), I noticed that I can’t switch to the NVIDIA graphics anymore. I have a hybrid graphics laptop with NVIDIA Quadro M1200 Mobile and intel 591b. I tried to switch with sudo prime-select nvidia but when I rebooted I was stuck on a black screen (no SDDM login screen nothing) and I couldn’t switch to any TTYs either. The only way to get it back and running was by force powering off my laptop to go back in recovery mode and switch back to the intel graphics. I’ve tried the fixes provided here but unfortunately it did not work and I’m stuck at where I was at the beginning of the day, unable to use my NVIDIA GPU. I also tried a couple of fixes from the forum here and there (from the Ubuntu 18.04 users) but none seemed to work for me. I’ve even tried rolling back to the 5.0 kernel and nvidia-drivers 418, 430, 435.

Attached is the log I got from sudo nvidia-bug-report.sh from the recovery mode with sudo prime-select nvidia before booting (I figured running it with intel selected would not be useful).

nvidia-bug-report.log (890.1 KB)

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post. You will have to rename the file ending to something else since the forum software doesn’t accept .gz files (nifty!).

Done! I have edited the original post and included the log file. Thanks for the quick reply!

Please remove the kernel parameter ‘nomodeset’
Please remove the file /usr/share/X11/xorg.conf.d/30-virtscreen.conf

1 Like

Thanks a lot for that! Never thought the 30-virtscreen.conf would be interfering with that! It used to work when I set it up months ago. I’ve set the nomodeset parameter to modeset=0 in the /lib/modprobe.d/nvidia-kms.conf. This let me boot up into the system with the NVIDIA configuration.

However, the DE has started lagging quite a bit with occasional screen tearing. /usr/lib/xorg/Xorg is taking a whopping 3.3GB of the 4GB GPU memory usage as shown by the output of nvidia-smi.

modeset=1 is required for tear-free display on hybrid graphics.
That high memory consumption doesn’t sound good, please create a new nvidia-bug-report.log.

1 Like

I have set modeset=1 as you suggested and the screen tearing is indeed gone after rebooting. But the Xorg issue still remains. This is the new log after the your recommended modeset changes. Thanks again for the quick reply!

nvidia-bug-report.log (1.1 MB)

That’s not looking good, nvidia gpu running full throttle, graphics memory full.
You’re running slightly outdated xorg and nvidia driver versions, please do a full system update
sudo apt update
sudo apt upgrade
and check if that resolves it.

1 Like

It’s all up to date according to the official Kubuntu 18.04 repositories. I even changed the mirror to my residing country’s most up-to-date mirror (Sweden, Operation Tulip: 1 hour behind). Nothing updated of course so everything’s where it was.

sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade
Hit:1 http://linux.teamviewer.com/deb stable InRelease
Get:2 http://mirror.operationtulip.com/ubuntu bionic InRelease [242 kB]                                                                                      
Hit:3 http://dl.google.com/linux/chrome/deb stable InRelease                                                                                                 
Ign:4 http://download.opensuse.org/repositories/shells:/zsh-users:/zsh-autosuggestions/xUbuntu_18.04  InRelease                                              
Hit:5 http://ppa.launchpad.net/alessandro-strada/ppa/ubuntu bionic InRelease                                                                                 
Get:6 http://mirror.operationtulip.com/ubuntu bionic-updates InRelease [88.7 kB]                                                                             
Hit:7 http://download.opensuse.org/repositories/shells:/zsh-users:/zsh-autosuggestions/xUbuntu_18.04  Release                                                
Hit:8 https://deb.nodesource.com/node_12.x bionic InRelease                                                                                                  
Get:9 http://mirror.operationtulip.com/ubuntu bionic-backports InRelease [74.6 kB]                                                                           
Hit:10 http://ppa.launchpad.net/fontforge/fontforge/ubuntu bionic InRelease                                                                                  
Hit:11 https://download.docker.com/linux/ubuntu bionic InRelease                                                                                             
Get:12 http://mirror.operationtulip.com/ubuntu bionic-security InRelease [88.7 kB]                                                                           
Hit:13 https://nvidia.github.io/libnvidia-container/ubuntu18.04/amd64  InRelease                                                                             
Hit:14 https://nvidia.github.io/nvidia-container-runtime/ubuntu18.04/amd64  InRelease                                                                        
Hit:15 https://nvidia.github.io/nvidia-docker/ubuntu18.04/amd64  InRelease                     
Hit:16 http://ppa.launchpad.net/linuxuprising/apps/ubuntu bionic InRelease                     
Hit:17 http://ppa.launchpad.net/mikhailnov/pulseeffects/ubuntu bionic InRelease
Hit:18 http://ppa.launchpad.net/papirus/papirus/ubuntu bionic InRelease
Hit:19 http://packages.ros.org/ros/ubuntu bionic InRelease
Hit:20 http://ppa.launchpad.net/pbek/qownnotes/ubuntu bionic InRelease        
Hit:21 http://ppa.launchpad.net/peek-developers/stable/ubuntu bionic InRelease
Fetched 494 kB in 8s (59.4 kB/s)                                                                                                                             
Reading package lists... Done
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

Yes, looks like you’re up2date for 18.04. I find this behaviour rather eerie, please check if you can use Software&Updates to switch back to the nvidia 390 driver for testing.

1 Like

Tested on the 390 driver. Nothing changed. Same 3.3GB memory by Xorg and really high temperatures.

Here is the log with the 390 driver if it helps.

nvidia-bug-report.log (815.5 KB)

Looking on what’s running on the gpu, there’s ‘glava’. Please check if stopping that is returning the gpu to normal.

1 Like

Otherwise, you could install and use ‘nvtop’ to check what’s taxing the gpu.

1 Like

Oh my god that was the program which was causing Xorg to behave weirdly! I have no clue why it did that because Glava in itself didn’t show much memory usage in the output of nvidia-smi. But stopping that fixed Xorg’s weird behaviour and my memory usage is down to less than 500MB out of 4GB (and no weird temperatures either). I will let the developers of Glava know of this issue to see if they can fix it because this is really unexpected.

Thanks a lot @generix for all your help! I don’t know if I could have solved this on my own without your assistance. You truly are God-sent.

Ok, then you can return to the 440 driver version.

1 Like