PGIinstall problem

Hello, I realise version 5.2 is ancient history but I am trying to get Gaussian 03 running on a Rocks 5.2 cluster (CentOS5.3) so I have to use this version of your compilers.

I have succesfully compiled a small hello world fortran program so the install seems to be OK. During the installation, I got an unexpected end-of-file syntax error for the 64-bit makelocalrc file. I noticed that it didn’t make a localrc file in the linux86-64 directory so I took the one in the linux86 directory and edited it.

The remaining problem is that when I run pgf77 anywhere but in /usr/pgi I get the following error:

[root@golem jfprieur]# pgf77 -V x.f

pgf77 5.2-4
Copyright 1989-2000, The Portland Group, Inc.  All Rights Reserved.
Copyright 2000-2004, STMicroelectronics, Inc.  All Rights Reserved.
./PGIinstall: No such file or directory

When I run it in the /usr/pgi directory it works OK:

[root@golem pgi]# pgf77 -V x.f

pgf77 5.2-4
Copyright 1989-2000, The Portland Group, Inc.  All Rights Reserved.
Copyright 2000-2004, STMicroelectronics, Inc.  All Rights Reserved.
NOTE: your evaluation license will expire in 14 days, 21.7 hours.
For a permanent license, please read the order acknowledgement
that you received.  Connect to https://www.pgroup.com/License with
the username and password in the order acknowledgement.

	Name:	"Jean-Francois Prieur"
	User:	j_prieur@live.concordia.ca
	Email:	j_prieur@live.concordia.ca
	Hostid:	PGI=001517E082796C60CDEABD
PGFTN/x86-64 Linux/x86-64 5.2-4
Copyright 1989-2000, The Portland Group, Inc.  All Rights Reserved.
Copyright 2000-2004, STMicroelectronics, Inc.  All Rights Reserved.
PGFTN-F-0002-Unable to open source input file: x.f

I have /usr/pgi in the .bash_profile PATH statement, and if I echo $PATH /usr/pgi shows up.Here are the relevant sections from my .bash_profile for root:

PATH=$PATH:$HOME/bin
PATH=/usr/pgi:/usr/pgi/linux86-64/5.2/bin:$PATH
export PATH

MANPATH=$MANPATH:/usr/pgi/linux86-64/man
export MANPATH

LM_LICENSE_FILE=/usr/pgi/license.dat
export LM_LICENSE_FILE

Finally, here is my manually edited localrc for the 64-bit compiler, I don’t think the problem is here but you never know:

set LFC=-lg2c;
set LDSO=/lib64/ld-linux-x86-64.so.2;
set GCCDIR=/usr/lib/gcc/x86_64-redhat-linux/3.4.6;
set GCCINC=/usr/lib/gcc/x86_64-redhat-linux/3.4.6/include;
set G77DIR=/usr/lib/gcc/x86_64-redhat-linux/3.4.6;
set THROW=__THROW=;
set DEFLIBDIR=/usr/lib64;
set DEFSTDOBJDIR=/usr/lib64;
# makelocalrc executed by root Fri Jul 3 10:58:58

Once again, i realise 5.2 is unsupported by I hope someone can help me with this, I think it is only a small setting that I am missing.

Thanks for any help you can provide

Never mind, I had not set the PGI environment variable to /usr/pgi, after adding EXPORT PGI=/usr/pgi the error disappears.