pgf90-Error-Please run makelocalrc to complete your installa


Just installed Workstation 7.0 on OpenSuse 11.1 and have this output:

nebojsa@linux-sckl:~> pgf90 -o program.exe program.f
pgf90-Error-Please run makelocalrc to complete your installation

Then I tried to run makelocalrc but got this:

linux-sckl:/home/nebojsa # /opt/pgi/linux86/7.0/bin/makelocalrc -x /usr/pgi/linux86/7.0
/opt/pgi/linux86/7.0/bin/makelocalrc: /usr/pgi/linux86/7.0: directory not found
Usage: /opt/pgi/linux86/7.0/bin/makelocalrc [installdir] [switches]…
installdir the directory where the PGI compilers are installed
-d outdir directory to put localrc; default is installdir
-n show the install information, do not write a localrc file
-o create the localrc file and write to stdout
-x write the localrc file and place in outputdir
-l lic flexlm license file to add to localrc
-gcc gcc gcc command name; default is gcc
-g77 g77 g77 command name; default is g77
-net locdir perform network install with named local directory

Example: /opt/pgi/linux86/7.0/bin/makelocalrc -x /usr/pgi/linux86/7.0

Any solution?


Hi Nebojsa,

You shouldn’t need to run makelocalrc directly. Did you try running the “install” script? Did you get an error?

While I’m not sure about OpenSuse11, other OS like Ubuntu don’t install the 32-bit development packages by default. Unless these packages are installed, the PGI installer wont install the 32-bit compilers.

Note that the error your seeing from makelocalrc is because you’re using “/usr” instead of “/opt” for the location on the PGI installation directory.

  • Mat

Hi Mat,

That about directories is very confusing: the pgi is in /opt, not i /usr.

PS, there were no errors during installation.

I tried this:
linux-sckl:/opt/pgi/linux86/7.0/bin # ./makelocalrc - x /opt/pgi/linux86/7.0
Unknown glibc version (2.9); treating like 2.4
ERROR: gcc not found;
successful use of compilers requires existence of gcc libraries
linux-sckl:/opt/pgi/linux86/7.0/bin #

But, at the first place, I do not know and understan why I have to run makelocoarc? In manula it is mentioned with networks, not with single machine.

Hi Nebojsa,

The problem is that you do not have the 32-bit developer packages installed on your system. These packages are required in order to run the PGI 32-bit compilers.

I do not know and understan why I have to run makelocoarc?

Again, you should not need to run makelocalrc directly. You should run the install script again after you have installed the 32-bit developer packages.

Hope this helps,

Well, installing gcc library solves problems…

I have this problem in Ubuntu 9.1. I get makelocalrc error when running. How do I specify to install 32-bit libraries?