Makelocalrc error -- prior solutions not working

Hi all –

I have a user on one of my systems who is trying to build an executable, using “pgf90 -tp p6 .f”, and he’s getting the “Please run makelocalrc to complete your installation” error.

It’s a Debian 5.0 (“lenny”) x86_64 system, with PG Workstation 9.0-4 installed.

I have read on this forum that this error can arise if the 32-bit build environment is not installed, which makes sense since the “-tp p6” switch sets the PG compiler to build for the 32-bit architecture.

However, I seem to have all the plausible 32-bit library packages installed. I have lib32gfortran3, and the “ia32-libs” metapackage (which is mostly C stuff), along with lib32stdc++6, and several others.

This makes me wonder if I’m possibly missing a simple environment path or something similar, if for some reason the pg compiler is not noticing the existing 32-bit libraries.

Also, I know that Debian is not on the list of official support systems, but it’s worked very well in the past, and it’s very similar to Ubuntu, which is supported.

Can anyone help? Is there another way to test the 32-bit build environment, other than just looking at the installed-package list?



The way to determine if you have 32-bit gcc support (which is what we look for),
is to compile hello.c

% gcc -m32 -o hello_32 hello.c
and then verify with
% file hello_32

% more hello.c
#include <stdio.h>
#include <stdlib.h>

int main()
printf(" hello\n");



Thanks, that’s helpful – this did identify a missing include file, which is available from the libc6-dev-i386 package, which was not installed.

However, after installing it, I can now compile the 32-bit hello.c, but am still getting the makelocalrc error when trying to compile a comparably trivial f90 program, which I got by googling “hello world f90”:

program HelloWorldF90
  write(*,*) "Greetings, denizens of plant Earth!"
end program HelloWorldF90

I can build this with pgf90 hello.f, but not with pgf90 -tp p6 hello.f.

Is it necessary to reconfigure or reinstall the PGI suite once the 32-bitness is fixed? If so, how does one do that?

Thanks again.

Addendum – I just checked, and I can also compile the trivial f90 “hello world” program with both “gfortran” and “gfortran -m32”. The latter generates a proper 32-bit executable, as shown by “file a.out”, which IDs it as “a.out: ELF 32-bit LSB executable, Intel 80386…”

So it seems my 32-bit build environment was broken, but is now fixed, and the task is to make the PG system aware of it?

Hi reid,

Have you tried re-installing?

  • Mat

I have now re-installed (by re-running the “./install” script from the unpacked tar-ball), and it works now.

Re-installation seems weirdly drastic to me, but of course I’m happy to have the problem solved.