Preempt Real-time patch on Jetson NX but no performance change

I have successfully patched the Preempt RT patch to the board but the patch gives the similar result as without patch.
when doing test
taskset -c 1 cyclictest -smp 99 -i 250

/dev/cpu_dma_latency set to 0us

T: 0 ( 9597) P:99 I:250 C: 6205 Min: 7 Act: 27 Avg: 19 Max: 212
T: 0 ( 9600) P:99 I:250 C: 12601 Min: 8 Act: -229 Avg:6202591432450390016 Max: -149
Not sure what’s going on and can someone help please

Our team will do the investigation and provide suggestions soon. Thanks

Could you try below command.

sudo su
echo -1 > /proc/sys/kernel/sched_rt_runtime_us

Hi, thanks for the reply and I tried this command but the result is still not improved. The result is as:
taskset -c 1 cyclictest -smp 99 -i 250

/dev/cpu_dma_latency set to 0us

policy: fifo: loadavg: 0.27 0.87 0.58 3/809 9012

T: 0 ( 9012) P:99 I:250 C: 56273 Min: 13 Act: 28 Avg: 20 Max: 272

What your BSP version?
cat /etc/nv_tegra_release

Try boost system to max performance mode. Confirm the power ID by /etc/nvpmodel.conf

sudo nvpmodel -m 8
sudo jetson_clocks

Hi, bsp version is

R32 (release), REVISION: 5.1, GCID: 26202423, BOARD: t186ref, EABI: aarch64, DATE: Fri Feb 19 16:50:29 UTC 2021

command sudo nvpmodel -m 8 gives:
NVPM ERROR: request for bad power mode 8
NVPM ERROR: optMask is 1, no request for power mode

and the current power mode is:
NV Fan Mode:quiet
NV Power Mode: MODE_15W_2CORE

I have done sudo jetson_clocks BUT the result is still not good.

I have NX too… without preempt RT.

ubuntu:~/Documents$ sudo nvpmodel -m 8
NVPM WARN: patching tpc_pg_mask: (0x1:0x4)
NVPM WARN: patched tpc_pg_mask: 0x4

CPU 1 - 6 running at 1.4GHz

Did You try sudo nvpmodel -m 6 to running at 1.9GHz ?
If You can, please, share your kernel RT tree on the github and I will try to build here.