Problem after flashing the Jetson TK1

I have a problem after flashing the Jetson TK1. Im working with the jetson tk1 but after awhile it froze on me and after rebooting I couldnt get into the graphical interface. I keep trying to log in but it logs me right back out and asks for me to log in again. I flashed the jetson but I couldnt use it properly,I couldnt install normal applications like eclipse or putty. I tried to follow these steps https://cyclicredundancy.wordpress.com/2014/05/10/flashing-the-rootfs-on-a-nvidia-jetson-tk1/ but after trying to run

sudo apt-get update && sudo apt-get upgrade

command, it took a few minutes to install whatever it was installing and then the whole system froze and the same problem arose, I couldnt gain access to the graphical interface. The whole system works fine because I can use the terminal by pressing ctrl-alt-F1. Any help would be appreciated.

Which version did you flash?

Unfortunately, the link from the original question is for R19.2 (very very old), and flash size ("-S") is way too small. The best place at this time for download of L4T R21.4 is:
https://developer.nvidia.com/embedded/linux-tegra

To be sure you use the full eMMC, flash with “-S 14580MiB” instead of “-S 8GiB”.

Thank you for your responses. And yes linuxdev I was using the old versıon,but when I flashed usıng the R21.4 version I get a watchdog check hardlockup error and many more lockup errors when trying to reboot. The last line that is written “end trace ede1f911b923583c”. I used a vmware for my linux host and the ubuntu version is 14.04. Also I set my memory to 2GB (on the virtual machine) and the hardware memory is 20GB.The VMWare is a 32 bit version. I moved the R21.4 files to computer (/) and started my directory from there. It also took surprisingly a short time to flash this time. When I tried it with the old version it took me nearly 3 hours to flash but by using the R21.4 version it only took me 40 minutes. Am I not being able to flash the whole device,are there missing files? Why can I not properly flash this device?

The R21.4 errors suggest the flash was completely corrupt, or the hardware is bad. vmware and other VM hosts are known to have issues that can get in the way if not careful, so I believe this is the issue and probably R21.4 should be re-attempted after working on the vmware install.

First, I do not know if 32 bit matters or not on host. It might…or might not, I can’t test (anyone know?). I suspect it does matter when generating and using the system.img file which is around 15 GB (2^32 implies 4 GB max without special handling), but I’m not sure. On your install attempts, there would be a file left over in the bootloader subdirectory, “system.img”. This file should be approximately the size of the “-S” parameter of flash. For “-S 14580MiB” or “-S 14GiB” this file approaches 15 GB…or for default I think it is around 12 GB. Check the directory and confirm that this file is in the approximate 12 to 15 GB size range.

Second, you need much more space for flash. Even if the flash software install can be put in with 20 GB spare (beyond the linux host use itself), temporary files (including the above system.img which itself occupies 15 GB all by itself) will at least momentarily occupy a lot of space. You might want to be sure that you have more like 50 GB spare space just to be sure.

Make sure that the partition type which the vmware lives on is a native linux type. If you run this command a “type” column will show something like “ext4”:

df -T /

Note that when a flash does succeed, it takes significant time. It’s building system.img (an entire linux root file system) from rootfs, then making a compressed version of it, and only then running flash, so it takes significant time.

You can log the flash via something like this:

sudo flash.sh -S 14580MiB jetson-tk1 mmcblk0p1 2>&1 | tee log_flash_r21-4.txt

Be sure to check after flash that the bootloader/system.img is around 15 GB…if around 4 GB or less 32 bit cut it off.

Well yesterday I used Ubuntu 12.04 as the host and retried flashing with the R21.4.0 version and again it took less than an hour but now the system is working fine. I can install eclipse and run programs as well. But I feel this is to good to be true and I’m afraid the system will crash again. I dont know what it is about 14.04 but I can never sucessfully flash a device using that version of ubuntu as the host. By the way I have two cards that I needed to flash and the second jetson took an hour and 20 minutes to flash. I took a screenshot of the flashing process.

If still interested in using Ubuntu 14.04, you could try, if not done already, the new version 14.04.3, released last week.
At least for me, this worked in contrast to 14.04.2.