Jetson does not boot after flashing R21.4


After installing Jetpack and flashing L4T R21.4 my Jetson board does not work anymore. I also tried using -S 12 GiB.

Flashing seems to be correct, but after the first reboot the boot process stops at
tegra_dvfs: vdd_gpu connected to regulator

After resetting the board, I can only see
U-Boot SPL 2014.10-rc2-00002-g105d2f3 (Jun 25 2015 - 15:19:50)
in the serial console and it does not even start to load the kernel.

The serial console log of the flash (with -S 12 GiB) and the first boot can be found here:

Any suggestions?




Tried to flash with fastboot, now things are a little different. Still cannot boot into Linux, but at least the kernel starts after reset(s). Seems to be quite non-deterministic where and why it crashes. There are “Internal error: Oops - BUG:…” messages at every boot.

Serial logs:
Flash and first boot:
Second boot after reset:
Third boot after reset:
Fourth boot after reset:
Fifth boot after reset:



There’s a lot that can go wrong and not be immediately obvious. What was the exact flash command? If not this, can you try:

sudo -S 14580MiB jetson-tk1 mmcblk0p1

Was this via a JetPack install, or just manually setting up flash without all of the JetPack add-ons? Does your flash host have any kind of anti-virus running, or is there anything unusual about the host (e.g., VM)?

Thanks for the suggestion.

I tried the command you suggested, the result is the same: after the first reset the kernel starts to load (and crashes), but after the second reset I see only “U-Boot SPL…” line in the serial console and nothing happens.

If I flash with -L bootloader/fastboot.bin, the kernel starts to load even if I reset the board multiple times, but it always crashes with a lot of trace prints.

The first time I flashed via the JetPack install, but since then I flash from a terminal. The host is a real (non-VM) Ubuntu 14.04.

Normally if there were an issue with flash I’d expect u-boot to load and the failure to occur during kernel load or later. At this point it is probably safe to start the RMA process. Go here and search for “RMA” near the top:

The live chat portion of that may provide additional testing. If you want to try one more thing before RMA, you could unpack and install a completely new R21.4 flash setup on your host (ignore JetPack) to verify unpacking did not involve corrupted files. Then flash again via the most basic flash:

sudo -S 14580MiB jetson-tk1 mmcblk0p1

…serial console after flash should indicate kernel load or beyond if the hardware is functional.

I have downloaded and unpacked R21.4 and tried to flash it with the command you suggested. The result is the same.

  • Flashing seems to be ok
  • After the firts (soft) reset it starts to boot, but crashes after “tegra_dvfs: vdd_gpu connected to regulator”, which is followed by a lot of trace prints which ends with “Code: bad PC value”
  • After a hard reset it does not start to load the kernel, stops at U-Boot SPL

Log (flash + 2 resets):

Most probably I will start the RMA process, thanks for the help.

It still seems like a hardware error, but it is interesting that the boot loader succeeds and loads and hands off to the kernel. Failure looks to be related to clock and regulator control. The first error line replaces what should instead read:

cpu_cold cooling device is registered

This first error always occurs at the same spot, which I’m betting is a hardware issue and not software-related. I would RMA, I believe this part of the SoC has failed.