TX1 can reboot but not cold boot

I just purchased a new TX1 devkit while my other one is in RMA for that old WiFi bug and I’m having some trouble with the new one. The TX1 shows up in recovery mode over USB and I’m able to use Jetpack to flash the latest L4T 24.1 on it. I can reboot and the GUI works fine. WiFi works and everything. As soon as I shut down, however, it no longer boots. There’s absolutely nothing on the serial terminal either after the shut down. The TX1 does show up in recovery mode on USB again though. And I can flash it again with Jetpack, but I get the same behavior. Reboot works after flashing, but once it’s shut down it can’t boot anymore and comes up in recovery mode.

I’m using a dedicated Ubuntu 14.04 LTS host machine, not a VM.

Any ideas?

Here’s my flash_os_64_tx1.log if that helps: http://pastebin.com/JU1t7Rpn

There were some Jetsons which required a quick double-tap of the power button. Can you try two (or several) quick power button presses to see if this is the case? The fact that it reaches recovery mode means it basically works, and the tail of the flash said it succeeded (this doesn’t mean the file system put on it is good, but likely it is).

I tried two (and more) presses and that didn’t help. Starting from a fresh power up, when I press the power button the SOC and PWR LEDs come on and

Bus 004 Device 011: ID 0955:7721 NVidia Corp

appears in lsusb. The behavior appears to be the same whether I press the power button once or several times.

Is this lsusb occurring for a Jetson which was not intentionally placed in recovery mode? If so, there is a definite problem. The flash itself looked normal.

If you still have the file from “bootloader/system.img.raw”, what is the exact size? If this got truncated there could be issues even if the flash app itself worked.

Yes, a cold boot results in the Jetson going into recovery mode and there’s no output on the serial terminal.

system.img.raw is 15032385536 bytes, which seems correct. I tried building and flashing from a different computer and I get the same results.

Yes, 15032385536 bytes is an exact match to “-S 14GiB”, so this was not truncated. The Jetson itself is not supposed to enter recovery mode unless forced, so it is time for RMA. Look for RMA near the top of this URL:
https://devtalk.nvidia.com/default/topic/793798/embedded-systems/some-jetson-web-links/

Sorry to see you had two bad ones in a row.

Thank you for your help linuxdev. I hope they’ll cross-ship me a new one this time because I’m not paying for another whole dev kit again.