Jetson TX1 Screen Freezes

I’m having this issue with my brand new Jetson TX1. It booted up just fine, however after about 5 five minutes the screen freezes up and becomes unusable.

I reset and tried several times, but the exact same thing happens and I have to reset once again.

This is very annoying and the board is not cheap, wondering if someone can help me find a fix for this.

Thanks in advance!

If you are running R23.1 (see “head -n 1 /etc/nv_tegra_release”), the default, you might want to flash R23.2 instead. In cases like this a serial console is very nice to see what goes on:

If not, you can check “/var/log/Xorg.0.log” (this gets rotated to “Xorg.1.log” after a reboot). There may be more information there.

Thanks for the info. I’m a newbie to this board, are there any instructions on how I can flash 23.2?

You can either run the JetPack front end to the packages on an Ubuntu 14.04 x86_64 host with plenty of disk space available, or you can manually download the driver package plus sample rootfs. JetPack has a lot of conveniences, e.g., network setup and the ability to simply tell it to install the extra “goodies” (e.g., CUDA). The download page is here for R23.2:

The download page for R24.1 is here:

If you just go with flashing, and don’t use JetPack, the basic steps are these (assumes R24.1 64-bit for the example file names):

  1. Unpack the driver package...there will be directory Linus_for_Tegra
  2. cd to the rootfs subdirectory..."sudo tar -xjf /where/ever/sample/rootfs/is/Tegra_Linux_Sample-Root-Filesystem_R24.1.0_aarch64.tbz2"
  3. cd .. # puts you back in the Linux_for_Tegra directory.
  4. sudo ./
  5. Connect the micro-B USB cable. Put the Jetson in recovery mode...hold the recovery button down while either turning on power or hitting the power reset.
  6. Verify the JTX1 is in recovery mode from the host: "lsusb -d 0955:7721" should show some output.
  7. sudo ./ -S 14580MiB mmcblk0p1 jetson-tx1
  8. ...wait a long time, probably over an hour... :)
  9. Jetson will reboot.

I think JetPack has some documentation with it. In the case of JetPack you’ll need the same micro-B USB cable for flash while in recovery mode, but then the other package installs require the ethernet cable connected for those later stages.

I have now tried several times using Jetpack to re-install everything. However, every time the screen freezes and the device is unusable until I reset and it it boots up again and the same thing happens.

I would appreciate any help on this.

Also, wondering now if I’ve received a clunker and if I can exchange the TX1.

I get this error and messages before the screen (and system) freezes on me:

Error: CUDA cannot be installed on device. This may be caused by other apt-get command running on device when installing CUDA. Please make sure the following packages are installed on device before continuing:

cuda-toolkit-7.0 libgompl libfreeimgdev libopenmpi-dev openmpi-bin


For the general question about exchanging a TX1 see the top of this URL (look for “RMA”):

One of the difficulties of figuring out freezing is we need to know if it was just the graphical interface or if it was the whole system. If it is graphical interface this can be related to the monitor and the data it replies with when queried. When it freezes, can it be pinged? Can ssh login work? Better yet, if you have a serial console, does this show any indication? See:

Perhaps “ctrl-alt-F2” gives a console…if so you can check the log file “/var/log/Xorg.0.log” (if you’ve rebooted you’ll see the previous boot via “Xorg.0.log.old”.

If CUDA install did fail because the package manager is stuck, there may be a temporary file getting in the way (not common, but it can happen).

To simplify debugging, I’d strongly suggest doing the manual flash with no other packages as listed above (does not use JetPack). Once more is known about actual flash success/failure it’d be easier to figure out other issues.

Thanks, I’ll try the manual flash.

I usually have time to open a console, but not enough time to check any logs due to the freeze.

OK, I tried the manual flash as well.

Once it completed I restarted the TX1 and within a few minutes (3-4 minutes) I ran into the exact same problem with the screen freeze. So I’m not sure if this is an issue with the installation or some drivers conflicting while running.

I really want to return this TX1 and get a different one. How would I go about doing that? I ordered directly from the Nvidia website.

I’m interested in utilizing the GPU for computations and all this is keeping me from doing that.

The RMA process is listed near the top of this URL: