Unable to log into Jetson TX2

Hi,

I received my new Jetson TX2. On powering on the board, I see that tegra-ubuntu display comes up with the following users

nvidia
ubuntu
Guest Session

I try to login to the following usernames with their respective passwords mentioned here

user - ‘nvidia’ with password - nvidia
user - ‘ubuntu’ with password - ubuntu
user - ‘Guest Session’ (no password required)

For each of the above login’s, no wrong password is reported. Instead it appears as if the password is taken successfully and the log-in is in progress. The display stays at the tegra-ubuntu screen and after a few seconds the login screen shows up again.

This happens recursively every time I try to login to the system. Looks like it is recursively coming back to the login screen every time I punch in a password.

Could someone help on how I could log into the Jetson TX2? Is my password correct? Is there something that I am missing?

Thanks for all the help.

Have you tried to reflash the Jetson?
What if you press “cntrl+alt+f2” and enter the login credentials?
What is the return of df -h?
I used to have that symptoms when my disc was full id est [0 bytes free space]

I think you mean

df -h

not

dh -h

Exactly! When there is no free space a loop on login could take place as described.

Most people use a Jetson through a router (this has some protection from outside attacks), but there have been cases where someone connected directly to a non-private network (such as a university dormitory where all students could see each others’ devices) and got hacked (any time I’ve installed to a machine directly touching the internet I see the hack attempts and port scans start within about 3 minutes of the machine being booted). Everyone knows about the ubuntu/ubuntu login/pass, so if the Jetson was connected unprotected to the network, it is also possible it was hacked. Not likely, but it does happen.

The original install (R27.0.1) was not very reliable, I’d have to agree with @Andrey1984, flash would be a very good idea (current release is R27.1…JetPack 3 can do this if you use JetPack, or command line flash is possible). If it turns out there is a crash while starting the GUI desktop this should take care of it…and you’d want R27.1 anyway, it’s quite an improvement in reliability.

I logged into console mode and tried logging in, and was able to login

CTRL + ALT + F1
Username: nvidia
Password: nvidia

and it worked. But in GUI mode it loops-back to the login screen.

Did a dist-upgrade through console mode
$ sudo apt-get dist-upgrade

and post this able to login successfully via the GUI.

So the issue of loop-back in login screen is resolved this the above update.

But when I try to update the version of the driver, via JetPack, I get an error that “JetPack must run on x86_64 HOST platform. Detected aarch64 platform”.

  1. How do I fix this?
  2. Also the fan on my Jetson TX2 does not start. NOTE: The CR5 and CR6 LEDs glow RED. Is this related to the fan not rotating?

Thanks for all the help so far.

JetPack must run on x86_64 HOST platform,
run it from a Host OS.
If you run /jetson_clocks.sh the fan will likely to rotate and acceleration will get on.

The red LEDs are just indicators that the power bus is up. It’s a “good thing”.

For the case of the GUI failing, you could run “dmesg --follow” on one of the text terminals, then try to log in via GUI, and see what the dmesg output is. You could post this, and the content of “/var/log/Xorg.0.log” after a failed login.

Also, what is the content of file “/sys/kernel/debug/tegradc.1/edid” (you can use “cat”)? What is the exact cable type (including any adapters) used with the monitor?

Hi,

I got the same problem when logging in via GUI. Unfortunately, the problem remains even if I did a ‘sudo apt-get dist-upgrade’.

And the following messages are caught by ‘dmesg --follow’:

Link Compression not supported by the panel

I got a picture of my screen, in which more detailed info are contained:
https://pan.baidu.com/s/1o8v330A

Any clues on how to fix it ?

Many Thanks,
FC

Unfortunately, the resolution on that picture is so coarse that I can’t read the text.

What is the output of “df -h” on your machine? Is there sufficient free space?

This is normal, and won’t cause GUI to fail:

Link Compression not supported by the panel

There were some known issues with the GUI on the default version of L4T (R27.0.1). With R27.1 there are still some auto configuration issues with some monitors, but outright crashes and the cycling described should be fixed (auto configuration won’t cause the cycling which is being described…the bugs of R27.0.1 would). If you have a GUI cycling like that, then it is probably just crashing as you log in, and the fix would be flash to R27.1. If you are already at R27.1, then more information would be needed (for example the “/var/log/xorg.0.log” and dmesg during the crash).

Have you flashed to R27.1?

@snarky & @linuxdev, thanks a lot for your reply. I was using the default version of L4T, and I would like to try R27.1 to see if the problem’s gone.

Thanks Andrew.

Ran JetPack from a x86_64 HOST platform and was able to flash 27.1 from it on to the Jetson TX2 Dev Kit.

Also, fan now works after running ./jetson_clocks.sh

Thank you for all the help and support.

./jetson_clocks.sh state could be saved and restored with ./jetson_clocks.sh restore:

255  sudo ./jetson_clocks.sh --show
  256  sudo ./jetson_clocks.sh --store
  257  sudo ./jetson_clocks.sh
  258  sudo ./jetson_clocks.sh --restore

I am not sure if having it permanently enabled does make sense.
For the power modes please refer to the post:
https://devtalk.nvidia.com/default/topic/1005800/jetson-tx2/is-it-possible-to-run-tensorflow-on-tx2-/post/5135112/#5135112

Hi,

I am able to successfully flash the Jetson TX2 with the latest 27.1 release using JetPack. But I have few related questions for which I couldn’t find the correct information online.

  1. I believe JetPack installs the latest driver on Jetson TX2. How do I confirm the version of the driver? $ uname -a : is this the correct way?

  2. I am not able to find the vdpau drivers on Jetson TX2 : libvdpau-nvidia.so. Is there any package that needs to be installed for enabling this library?

Thanks for all the help

A Jetson uses Ubuntu as the operating system; when you overlay this with the NVIDIA-specific hardware drivers it becomes “Linux for Tegra” (L4T). The current L4T version is R27.1. You can verify this with:

head -n 1 /etc/nv_tegra_release

To validate the actual hardware-accelerated access files are in place:

sha1sum -c /etc/nv_tegra_release

Any additional libraries (such as CUDA or multimedia programs) simply use the standard Ubuntu administrative commands, e.g., apt or dpkg. Flash does not install these “extras”…flash is responsible for the files from the nv_tegra_release listing. The nv_tegra_release file is human readable text…if you are wondering about a file not in that list of files, then it is probably something added after flash and not during flash, or else it is part of the base Ubuntu system.

For anyone running into this issue, you have to click the little cogwheel next to “login” and select “Ubuntu” instead of “Unity”