Jetson TX1 login failed to start session

I wanted to know the procedure to restore my Jetson TX1. I recently uninstalled a few apps that i installed due to incomplete installation and ever since this i cannot get past the login page. I cannot sign in as a guest as well. How do i proceed? Pls help.

Also does it come as a 32 bit or 64 bit userspace?

Thanks in advance

The original R23.1 came with 64-bit kernel space and 32-bit user space. R24.1 introduced 64-bit user space. Current version is R28.1 and is also 64-bit user/kernel space (this is the first release where the TX1 and TX2 share a sample rootfs, though they do use different driver packages). If for some reason you must stick to a 32-bit user space you probably want to load R23.2. Here is a list of release versions:
https://developer.nvidia.com/embedded/linux-tegra-archive

If you have an Ubuntu PC, then you probably want to flash using the JetPack front end. JetPack 3.1 covers the more recent release versions:
https://developer.nvidia.com/embedded/jetpack

If you have another version of Linux on your PC you may want to flash on command line using the driver package plus sample rootfs. This does not require Ubuntu…any 64-bit Linux PC will work for this (extra package and setup features are a function of JetPack, so it is just the flash).

Would it be possible to flash the jetson TX1 using a macbook?
If possible how would you suggest i go about it.

The host must be x86_64 Linux or the flash software won’t run…I don’t know if the modern macbook is ordinary x86_64 or not, but if it is, and if you run Linux on it, then it might work. If not running Linux, or not running x86_64, then it can’t work. If this is x86_64 and if you have Linux running on it, then you would also have to be certain to use a native Linux file system type under it (you couldn’t use HFS).

Using JetPack instead of command line adds the Ubuntu requirement.

Can you please help me out with how to proceed from the login page? It is stuck in the login page and it does not recognise my login credentials. How do i get past this page. It would be helpful if you can explain it in detail as i am a beginner.

To verify if I understand correctly, are you logging in to the Jetson from the local graphical login screen? The default pass for user “nvidia” is “nvidia”, and for user “ubuntu” is “ubuntu”. If these fail, try ssh login…knowing if both ssh and GUI fail versus just GUI login is useful debugging information; knowing if both user names fail in the same way is also good information. If ssh connects and then says incorrect password, versus ssh not even connecting to ask for a password, this too is useful debugging information.

In some cases login failure may occur if the disk is full since temporary files are needed for some logins. In the case of your host PC having flashed with incorrect preservation of permissions there may also be an issue…if the underlying file system type on the host PC is not a native Linux type (e.g., not ext4, instead being hfs or NTFS or VFAT), then permissions cannot be preserved. If your host PC had insufficient disk space during the flash, then a truncated file system will be put on the Jetson, and this too may cause strange/undefined login behavior. So basically more debugging information is needed:

  • Does ssh work?
  • If ssh does not work, what is the failure message or behavior?
  • Do both accounts "nvidia" and "ubuntu" fail, or just one particular login?
  • What kind of file system type and how much spare disk do you have on the host you flashed from (use "df -H -T" to see this information)?

A serial console can be used for additional debugging. If you are interested in serial console see these URLs:
http://elinux.org/Jetson/TX1_Serial_Console
http://www.jetsonhacks.com/2015/12/01/serial-console-nvidia-jetson-tx1/

For user ubuntu the password is ubuntu. I have tried this and i get a failed to start session. I do not know how to get a terminal window from the login page to move on further to use commands. When i hit ctrl-alt-f4 to get the terminal the display goes off.

So as of now i am stuck on the login page with ubuntu account. Cannot sign in as guest user as well.
The system is an ubuntu 14.04 LTS. and i have sufficient space on the TX1 as i do not have anything much installed on it and it is brand new.

The error happened as a result of me trying to uninstall a few ROS files.

I cannot use any of the ctrl-alt f1 or ctrl-alt-f4 commands, because the display goes off when i hit these keys. Any suggestions?

There are different pieces of software which set the video mode depending on whether it is the X11 GUI or text console. It is very likely that the text console is failing to set correct video mode. One of the big reasons for serial console is so useful is that it essentially has close to no driver needed…it’s just a string of bytes, so it works even when large parts of the system have crashed and burned. I would think serial console would be a good way to see what’s going on.

Since you can’t log in you can’t run this command, but if you could, this would possibly tell you something in hardware drivers is out of place:

sha1sum -c /etc/nv_tegra_release

Failing to start session could be the inability to create temporary files, which can sometimes be because of any failure of permissions (not just a filled file system) or a component needed to write the file being missing. You could examine the system by cloning it, then loopback mounting it on your host PC. However, it seems like fixing it might still be answered as “it needs to be flashed” even if you do discover some reason for the failure.

Is there any reason you can’t flash? If you need to first save some critical data then cloning would do the job, but I think there won’t be any easy fix other than just flashing it new since you can’t ssh in.

So I’ve gotten display and i ran the command that you mentioned. I get OK for all the hardware drivers.

Can you guide me through the procedure to connect to a wifi connection through the terminal? I cannot run the sudo apt-get install ubuntu-desktop command without a working connection and i can’t connect to wifi through the login page.

WiFi isn’t something I can help with, but there may be more going on which will cause you to end up flashing anyway. Someone else may want to chime in and give the edits needed in “/etc” to directly configure WiFi, but meanwhile, what is the output of:

ls -l /usr/bin/sudo

Does something simple like “sudo ls” work without error? What is the output of “df -H -T /”?

The output for ls -l /usr/bin/sudo is “-rwsr-xr-x 1 root root 138464 Feb 10 2014 /usr/bin/sudo”

sudo ls works and gives me a set of files displayed

df -T gives the output

Filesystem Size Used Avail Use% Mounted on
/dev/root 15G 6.4G 6.8G 49% /
devtmpfs 1.9G 4.1K 1.9G 1% /dev
none 4.1k 0 4.1K 0% /sys/fs/cgroup
none 405M 898K 404M 1% /run
none 5.3M 0 5.3M 0% /run/lock
none 2.1G 148K 2.1G 1% /run/shm
none 105M 25K 105M 1% /run/user

df -T

Filesystem Type 1K-blocks Used Available
/dev/root ext4 14564384 6691740 7109764
devtmpfs devtmpfs 177856 4 1777852
none tmpfs 4 0 4
none tmpfs 394536 876 393660
none tmpfs 5120 0 5120
none tmpfs 1972664 144 1972520
none tmpfs 102400 24 102376

It looks like basic install is probably correct. Would you please try monitoring some log files while attempting to log in as ubuntu?

sudo dmesg --follow
tail -f /var/log/Xorg.0.log
sudo tail -f /var/log/auth.log

Also, is your network protected behind a router? If this is a public network (like in a dormitory), then anyone could have logged into account “ubuntu” unless the password was updated (“ubuntu” is a default password everyone knows…everyone on the inside of a router would have access to this).

In the end it’ll still be likely to have a recommendation to flash the newest L4T. If this is a public network then I’ll suggest flashing is the only secure way to go (along with changing the password before going to a public network). I mention this because parts of the system seem to work correctly, yet the default account does not.