Jetson TK1 - Bios

I just bought a Jetson TK1 but I can not get into the BIOS . Does anyone know how I can do?

If by BIOS you mean the U-Boot bootloader environment then you need to use a serial cable and a terminal app.

Pressing a key in the serial terminal lets you halt the boot process and use the U-Boot command line:

These commands are available if you flash your TK1 with the most recent image:

FYI, ARM embedded has no BIOS. As allanmac said, what is normally done in BIOS for x86 is done with a combination of device tree data (.dtb files) and boot loader (if you use default fastboot you need to flash to update anything…if you use u-boot you can modify just the device tree file or arguments when booting). I guess the real question would be what you are interested in accessing or modifying?

My idea was to reinstall the operating system to correct a problem that I had.
My problem is that I have installed the CUDA Toolkit 6.5 on my Jetson TK1 but after this I could not access the desktop.I read on this forum some solution to this problem but none work on my Jetson . If I understand correctly the problem is related to an incompatibility between the GUI and the toolkit. I tried to install other different GUI like xfce but I have this kind of error:
Reading package list… Done
Building dependency tree
Reading state information… Done
E: unable to locate package update`,

I tried with apt-get update and also with apt-get upgrade but i didn’t solve it.
I don’t know how to do .I’m not expert on ubuntu.
So I decided to try to reinstall the OS , change the GUI e reinstall the toolkit. Could this be a good solution? Is there a better solution?

Sorry for my english, i’m an italian student! :)

If you haven’t yet flashed the new 21.1 release, you should do it now. It will delete everything, so be sure to backup what you need.

The desktop not starting problem has been fixed on the latest release.

For installing XFCE (if you want it) you can check the sections “Extra repositories” and “XFCE” in my tips-post:

I would reflash the board, please read:

FYI, the most recent CUDA 6.5 just became available under L4T R21.1, which I don’t think ships on Jetson yet. You would have to upgrade if you want to use this instead of 6.0.

I’m still curious about the display failure. From ssh or serial console can you check the output of:

sha1sum -c /etc/nv_tegra_release

…from this output one of the last lines is to check…is this listed as OK?

Ok i have a question:
-How can i install the 21.1 version if I can’t access to the desktop?Can you explain it?

I tried the command “sha1sum…”
and the line is FAILD and it’s the only one that fail.What can I do?

Thanks everybody! :)

The desktop can be fixed without too much trouble. See this:

FYI, flash would be done from another linux host with the USB mini-A/B cable connected between Jetson and host. Even if you fix R19.2 (probably Jetson still ships with this version) R19.3 has useful fixes; if you need CUDA 6.5 you must go to R21.1.

I tried to solve the problem of my desktop with the guide in your post but it doesn’t work.I’m sure i did something wrong following the steps due to the fact that I found a bit difficult to translate all parties. Could you post all passages to do with their commands in a simpler way? I would be grateful. Thanks a lot.

What it comes down to is that it is very unlikely CUDA has caused any issue. It is a 100% guarantee that the failed sha1sum for prevents the graphical interface login. Replacing the file means extracting it from the same sources used for a full flash, followed by putting it on Jetson. Even with and graphics not functioning, other parts should still work…meaning network and serial console still work without graphics. Full flash is not necessary to fix the issue, and instructions on the other thread were for people who have backed up or have the sources used for flash (R19.2, R19.3, or R21.1) since the file is there as well.

What is the current version of L4T installed on your Jetson? If it was never upgraded, then it will be L4T R19.2. Many people have upgraded to R19.3, a few have upgraded to R21.1. From what you’ve said it is likely you have R19.2, and this determines which L4T download contains the backup of you will want…if you’ve never backed up then downloading it is the only way of getting the replacement file. See this page for download versions:

The question of upgrading and whether this helps is a different question. If you have R19.2 and need to download, lack of R19.2 availability may force upgrade to R19.3 or R21.1 (unless you can find R19.2).

I wrote how to install lastest Linux for Tegra to Jetson TK1.
If there are important files in internal storage on Jetson TK, buck up them before trying it.

The version on my Jetson is R19.2 . I tried again to follow the steps of your post and I am sure I have done everything in the right way now because when I try the command ‘sha1sum -c / etc / nv_tegra_release’ the line with is now OK but the desktop still does not work .What can I do??

EDIT: I upgrade to 19.3 but i still find the problem. I also noticed that there is another thing that probably can be linked to the failure of the desktop:

  • Starting early crypto diskd…[OK]
  • Setting up X socket directories…[OK]
  • speech-dispatcher disabled; edit /etc/default/speech-dispatcher saned disabled; edit /etc/default/saned

and than it is stopped till I press Ctrl+C
What is this?

speech-dispatcher is normal, so is saned (these are for installed software standard for Ubuntu, but for items not configured, e.g., saned is for a scanner such as on a printer which you have not configured).

FYI, running that sha1sum and getting “OK” on all means likely it was installed 100% correct.

Is this on serial console that you see this message? I have the feeling that the login delay and/or need for Ctrl+C is related to an attempt to check for package update availability pausing. I had this happen to me exactly once on R19.3 and then not again. So I guess the first question is whether Ctrl+C always works? Second is whether this Jetson has network available? Third, if network is available, is it secured from outside incoming connection attempts (such as changing the ubuntu password or being on a router which prevents this)?

When i turn on my jetson, desktop doesn’t work so to interact with the tk1 I press Ctrl+Alt+F1 and I go to the terminal.After this i can login into the system and if I wait for some seconds the message comes out on the screen.It happens even if i’m not logged in : if I wait a few seconds to login the message comes out and to have the possibility to login I have to press Enter, in other cases nothing happens.

So to answer your questions , Ctrl+C works ever but only if i’m logged in, if i’m not it doesn’t work and in that case i have to press Enter.
Second , yes, my Jetson has network available and third it is secured from outside incoming connection attempts.

I tried a command : grep EE /var7log/Xorg.0.log , and it gave back to me the following error:

  • (EE) faild to initialize GLX extension (Compatible NVIDIA X driver not found ) .

What’s this? Perhaps the problem is not yet solved , isn’t it ? What can I do ?

The GLX extension is the smoking gun as to why the GUI cannot work. This is the file…so it seems that getting “OK” from “sha1sum -c /etc/nv_tegra_release” is not possible.

There is one scenario where you would get “OK” when is really NOT OK: If you used the from a different release of L4T such that the /etc/nv_tegra_release was also from the different release. The file and the nv_tegra_release are packaged in the same archive…if you unpack everything from a tar archive, then nv_tegra_release will match…but if the archive itself is from a different version such as unpacking R19.3 on R19.2, then X cannot link against this version. Is it possible you unpacked the entire nvidia_drivers.tbz2 from a different release than the release of the running Jetson?

No I don’t think is possible because when i followed the steps on my jetson there was the R19.2 version.After the procedure i checked and it didn’t work.So i did the upgrade and it didn’t bring anything good.

Anyway do you think that installing the R21.1 version i can automatically solve all my problems? I mean if i install R21.1 vesion , will be everything compatible?Will the desktop work?
How can i do the upgrade? Thanks!

I wrote how to install Linux for Tegra R21 to Jetson TK1.
This will overwrite whole internal eMMC.

Following commands update only nvidia drivers to R21 but not kernel if you use fastboot.
This is executed in Jetson TK1, not Host PC.

sudo tar -vxjf Tegra124_Linux_R21.1.0_armhf.tbz2
cd Linux_for_Tegra
sudo ./ -r /

Check updated files.

sha1sum -c /etc/nv_tegra_release

Use this command before apt-get upgrade to protect nvidia drivers.

sudo apt-mark hold xserver-xorg-core

You can return to R19.3 drivers with this file.

There is a good chance the R21.1 will solve the GUI problems, though I still don’t know why the current system fails (thus it is impossible to be certain R21.1 will fix this).

Btw, if you want to upgrade or do anything requiring a lot of disk space, you should consider putting an SD card in the slot and mounting it somewhere. Then the download itself will always be available on the SD card and won’t take up precious space on the Jetson. Beware, however, that you will have to reformat the SD card partition as something like ext4…the format which comes stock on store SD cards is usually a windows file system which likely won’t understand device special files and full linux permissions.

Personally though, I’d try just the download above to see if satisfied since it is very easy to do, but be prepared for doing a full flash in case the nVidia files are not the source of the issue. A full flash updates everything and not just the nVidia files.