Jetpack Not able to load on TX1

Hi,

Recently i brought two jetson tx1 boards, one with complete set of development boards

i am unable to install Jetpack L4t3.0 on it…for both the cards i am getting the following error.

    /bin/bash: ./flash.sh: No such file or directory

    Failed to flash device. Chech /home/ubuntu/Desktop/jetpackTx1/_installer/logs/64_TX1/flash_os_64_tx1.log for more details. Please cloe this terminal window, fix the issue mentioned in log, and run JetPack again to reinstall

And in …/…/64_TX1/flash_os_64_tx1.log

/bin/bash: ./flash.sh: No such file or directory

kindly help me to get rid of it.

Hi Satheesh,

We are release Jetpack3.0 now.
https://developer.nvidia.com/embedded/jetpack

After download completed, you can following “index.html” steps to install.
Location: /jetpack_docs/index.html

Hi Carolyuu,

What I was tried is the same Jetpack3.0. And also I have followed “index.html” but still the problem exists???

/bin/bash: ./flash.sh: No such file or directory

The Jetson TX1 is connected properly is confirmed, since I am getting the below message on giving lsusb command

Bus 003 Device 007: ID 0955:7721 NVidia Corp.

Also note that if you flash from command line that typing just “sudo flash.sh …” won’t find flash.sh…you’d need the “./” relative path, e.g., “sudo ./flash.sh …”.

But i am using jetpack installer [ JetPack-L4T-3.0-linux-x64 ] to install jetpack… i dont want to install manually through command line.because i cant install cuda manually.So i would like to install complete package of jetpack.so kindly help me to install jetpack on my tx1.

CUDA can be installed manually after extracting it from JetPack, but you are right, it is tedious and error prone (and not simple). If you are interested in knowing how to extract CUDA from JetPack see:
https://devtalk.nvidia.com/default/topic/982848/jetson-tx1/tx1-specific-arm64-deb-repo-for-cuda-8/post/5063053/#5063053

Another reason why flash.sh might not be found if it is actually there (other than not being in your path and not being named with the correct path information) would be if it were not set to executable. I’m not sure what the instructions are for unpacking JetPack (I use Fedora and can’t use JetPack for basic intended purposes), but you might want to make sure that where you unpack it to is somewhere you have permission to set flash.sh to executable (i.e., unpack it somewhere you know your user has permissions for).

Out of curiosity, wherever the base directory is of your JetPack install, cd to that location, and does this find flash.sh?

sudo find . -name 'flash.sh'

…if that succeeds, what are the file permissions of the flash.sh from “find”?

I’m running into the same issue as Satheesh, with JetPack 3.0 as well. No file named flash.sh appears in the results of the find command. Is that something available separately?

I’m not sure what JetPack unpacks where, or what triggers each unpack. flash.sh is part of the driver package and JetPack is a front end for this…so flash.sh is included with JetPack, but where it is and what unpacks it I don’t know (I have a Fedora host so I can’t use JetPack). I suspect if you run JetPack to flash once then flash.sh would appear.

If you prefer you can download the driver package separately, this has flash.sh. If you want to use this separate download to flash with, then you’d also need the sample rootfs. Generally JetPack takes care of this.

It looks like JetPack-L4T-3.0 just fails to unpack flash.sh in this particular case. I wound up fixing this issue by running the 3.0 uninstaller, then running the 2.3.1 version. That added a file in ./64_TX1/Linux_for_Tegra_64_tx1/flash.sh. I aborted the installation just before actually flashing the device, then ran JetPack 3.0 again and it worked fine.

It took a little looking to find a working URL for the old installers - this one worked for me:
https://developer.nvidia.com/embedded/dlc/jetpack-l4t-2_3_1

Hi Satheesh_Ramasamy,

I couldn’t reproduce this issue on a clean Ubuntu 14.04 host machine.
Not sure if there is any environment issue? Such as disk full, non-English locale, installation to a dirty directory, etc?

The flash.sh file should reside in /home/ubuntu/Desktop/jetpackTx1/64_TX1/Linux_for_Tegra_64_tx1 directory on your host machine. Could you please check what files are in that directory?

I have used latest Jepack(24.2) for TX1, in that flash.sh file is reside in /home/ubuntu/Desktop/jetpackTx1/64_TX1/Linux_for_Tegra_64_tx1/Linux_for_Tegra directory.

The Directory you have mentioned( /home/ubuntu/Desktop/jetpackTx1/64_TX1/Linux_for_Tegra_64_tx1) contains two directories inside it (1 . Linux_for_Tegra , 2 . rootfs ).where the flash.sh is located inside Linux_for_Tegra.

Hi Satheesh_Ramasamy,

Thanks for your reply. Can you please verify with the following actions?

  1. Run the JetPack installer and select TX1 platform.
  2. Press “Clear Actions” button.
  3. Find the “Linux for Tegra Host Side Image Setup” row, click the Action column to change the action to be “uninstall”.
  4. Click “Next” button to uninstall.
  5. Verify that Linux_for_Tegra_64_tx1 directory has been completely removed from /home/ubuntu/Desktop/jetpackTx1/64_TX1/.
  6. Start JetPack installer again to reinstall the “Linux for Tegra Host Side Image Setup” component for TX1 platform.
  7. Verify that flash.sh exists in /home/ubuntu/Desktop/jetpackTx1/64_TX1/Linux_for_Tegra_64_tx1 directory.

I can confirm the above is a workaround for a similar problem I had. Running the JetPack installer did not result in a “Linux_for_Tegra_64_tx1” directory inside a “64_TX1” folder. After performing the 7-step process above, I am able to complete the Jetpack 3.0 installation.

Thanks PStrong,

The 1-5 steps above are to clean up the environment, and the 6-7 steps are to re-install in a clean environment. Please make sure installation is done in a clean directory.

Hi EdwardZhou,

Sorry I was hooked up with some other system issues, so unable to check these days…

Yes, I too confirmed the above steps are the best workaround for this issue.

Hi

I have an issue with TX1 trying to install L4T 3.0, it basically only flashes the OS and stops before installing the remaining SW.

I had tried over and over and followed all the steps given in this topic (1-6). the issue is that for some reason after the first reboot the TX1 does not allow any connection and refuses to SSH

my TX1 is connected to the same LAN SW as the host (running Ubuntu 14.0) and all the jetpack is installed on a file system that is a full 2TB HD and I had plenty of space, so the issue is not space.

also I had noticed that the cuda, OpenCV, vision works do not install.

I wonder if NVIDIA has a better way to fix this issue or it is my TX1?

if my TX1 is faulty how do I test it

I will try to downgrade and install L4T 2.3.1 to see if this makes a difference, however if so, please let me know how I can upgrade form the TX1 directly without the terrible support on the installer.

Thanks

You should be able to install software later once you have a good flash…JetPack will still work after other issues are worked out. Command line flash is possible without JetPack, and has fewer restrictions. FYI, 2.3.1 and 3.0 are JetPack versions…JetPack does not actually go on the Jetson, the most recent L4T version for a TX1 is R24.2.1 (this version is quite good and has fewer issues than earlier versions)

For just flash without JetPack and without extra packages, the minimum goes something like this:

  1. Download the driver package plus sample rootfs. Most recent R24.2.1 is at: https://developer.nvidia.com/embedded/linux-tegra-r2421
  2. Unpack the driver package (creates a "Linux_for_Tegra" subdirectory). Within this is subdirectory "rootfs"::
    tar xjvf Tegra210_Linux_R24.2.1_aarch64.tbz2
    
  3. cd into rootfs, use sudo to unpack the sample rootfs:
    sudo tar xjvf /wherever/it/is/Tegra_Linux_Sample-Root-Filesystem_R24.2.1_aarch64.tbz2
    
  4. cd back up one directory to the "Linux_for_Tegra" directory ("cd ..").
  5. Use sudo to apply_binaries.sh:
    sudo ./apply_binaries.sh
    
  6. Verify you still have enough disk space of type ext4, perhaps 25GB:
    df -H -T .
    
  7. Put the Jetson in recovery mode (hold the recovery button while powering on the Jetson or hitting reset for an already on Jetson, connect the micro-B USB cable to host). Verify host can see the Jetson...see output from this lsusb command:
    lsusb -d 0955:7721
    
  8. Flash with sudo:
    sudo ./flash.sh -S 14580MiB jetson-tx1 mmcblk0p1
    

About ssh: If the host and Jetson have connected via ssh before the keys will be memorized. If something goes and changes keys this could account for the failed ssh. You can get more info about an ssh failure from command line on host to Jetson via the “-v” verbose argument to ssh.

If you use a serial console you can see everything going on from boot loader on and see if there is some sort of big failure. See:
http://elinux.org/Jetson/TX1_Serial_Console
http://www.jetsonhacks.com/2015/12/01/serial-console-nvidia-jetson-tx1/

Will this steps be able to install

Jetson TX1 DevKit L4T OS
Tools/SDKs
CUDA
TensorRT (GIE)
cuDNN
VisionWorks/Open CV
Samples/Documentation

Thanks

The steps above are just for flash. This implies the L4T o/s (which is Ubuntu 16.04 with NVIDIA-specific hardware acceleration files and configuration in place). None of the other packages are installed via the flash.sh program. JetPack can be run after manual flash to install those packages (just uncheck the flash part of the install and go to packages).