JetPack Installation Problem.

I have my host machine running Ubuntu Linux 14.04 and I downloaded the jetpack, set the CHMOD like in the instructions and then I ran the file. But it just runs and says 100% and success and then returns to the command line. It doesn’t pop up in graphical window like the instructions says. It did unpack a folder _installer and I went in there and tried to launch darn near every file in there. I’m sure I’m missing something super obvious but I just can’t for the life of me figure out how everyone else is getting the graphic window to pop up where you would click “next” through the steps that take you through unpacking and installing the jetpack and then putting it on the Tx1.

Thanks for any help,
M

Just to clarify when I run JetPack-L4T-2.0-linux-x64 it says “verifying archive integrity…All good” then “Uncmpressing Jetpack 100%” and then it just returns to command line. Can’t figure out how to get any further then that and the instructions say that at this point the installation window should automatically pop up. I’m guessing this is something easy but I just don’t get how to proceed.

  • JetPack runs on Ubuntu host systems only and can be run without a Jetson Developer Kit.

Note: JetPack does not support running directly on the L4T (Linux for Tegra) platform.

Hi +ArnoudBuzing
This is not the same issue being reported above. It appears as if you are trying to run JetPack on the Jetson board itself. You must run JetPack from a x86_64 Ubuntu 14.04 Linux machine.

yes i’m dfinitely running my jetpack on a host machine, NOT on the Tx1 and I can’t seem to get Jetpack to run.

When i run it with “–confirm” i get the following

avadonlinux@Avadonlinux:~$ ./JetPack-L4T-2.0-linux-x64.run --confirm
Creating directory _installer
Verifying archive integrity… All good.
About to extract 89316 KB in _installer … Proceed ? [Y/n] y
Uncompressing JetPack 100%
OK to execute: ./Launcher >/dev/null 2>&1 ? [Y/n] y
The program ‘./Launcher’ returned an error code (2)

I don’t know what this means?

OK, I tried to delete my comment but that doesn’t seem possible. I updated it in a way that hopefully minimizes any confusion I may have created.

No worries, it’s a pretty common issue. The next version of JetPack reportedly will check to make sure that it is not being run on the Jetson to minimize the confusion.

Anyone know of anyway to launch the jetpack launcher if it doesn’t open automatically from the command line?

Is the Ubuntu 14.04 LTS installation 64 bit? Is it running under a VM?
You can check if it is 64 bit:

$ arch

It should come back: x86_64

It’s JetPack-L4T-2.0-linux-x64.run it’s running on an older 32 bit machine is that a problem?

If i do :~$arch --version it says GNU 8.21

Do I have to run the 64 bit jetpack on a 64 bit machine in order to unpack it and install it on the TX1? Hmmm Didn’t say that in the install instructions.

Also can anyone explain to me the difference between the Jetpack and the the l4t_r23-1 production image? Is the production image in the jetpack or do I have to install both of these?

Does the board need to be attached and in force recovery mode already to run the Jetpack? Or doesn’t that come later after the jetpack install on the host?

The System Requirements for JetPack install: http://docs.nvidia.com/jetpack-l4t/index.html

Supported Host Platform Requirements:
Ubuntu Linux x64 (v14.04)
Note that a valid Internet connection and at least 10GB of disk space is needed for the complete installation of JetPack.

JetPack is an application which makes installation less painful when installing the system software on the Jetson. Under the covers, JetPack does several of things. First it prepares an image to flash on to the dev board (the sample rootfs). This is L4T 21.3 in this case. Then, using the supplied microUSB cable connecting the host to the Jetson, JetPack flashes the Jetson with the operating system. The Jetson needs to be in recovery mode before flashing can occur.

After the flash, the Jetson is functional, you should see the Jetson boot if it is connected to a monitor. At this point JetPack determines if any additional software has been selected to be installed, such as CUDA, OpenCV4Tegra, VisionWorks, GameWorks samples and so on. If there are additional programs to be installed, JetPack establishes a connection over ethernet with the Jetson (basically it SSHs to the device) and copies the appropriate packages and libraries.

Note that the Host computer must be able to ‘see’ the Jetson on the network for the latter transfers to take place.

If the option has been selected, JetPack compiles the sample programs. This is done before the installation is complete.

For what to expect during an install, you can visit: http://jetsonhacks.com/2015/11/18/jetpack-2-0-nvack-jetson-tx1/
which has an article and video on the installation.

You may wish to install without using JetPack, this is covered in: https://developer.nvidia.com/embedded/linux-tegra
The quick start guide: http://developer.download.nvidia.com/embedded/L4T/r23_Release_v1.0/l4t_quick_start_guide.txt describes how to install L4T 21.3 in this case. Note that you will have to install other packages/libraries separately.

Thank you Kangalow,

I’m not certain what the exact issue is but I think I found the culprit. The box I put linux on to do the jetpack is older i686 and is not a x64 system. I found out the version I had installed on it via thumb drive was a 32v of ubuntu. That may be why jetpack wasn’t firing up. I went to install the x64 version and it told me this isn’t x64 architecture. Frustrating!! So I have to find/build a linux box that can handle x64 to get this done.

I don’t suppose I can run jetpack off of a x64 PC can I? Or do I have to use a linux machine?

Thank you for all this help

Ubuntu 14.04 for JetPack is the only option

It isn’t “official” but I can confirm that you can run JetPack and install to the TX1 using Ubuntu on a VirtualBox VM on a 64 bit PC running Windows 10.

Make sure you have the Guest Additions installed on the VirtualBox. Also that the USB port support is correctly configured.

After that just follow the instructions. The only odd issue, which is similar to one discussed on other threads here, is that JetPack seems to hang after flashing the TX1. I think this is because the USB port resets at either the PC or TX1 end and the Linux - VirtualBox - Windows chain can’t handle it.

I resolved this by killing the install and restarting with a custom install that only had the steps after the flash enabled. (I think I rebooted the Jetson as well to get the IP address info).

I’ve done this twice (I had to RMA my first TX1 because of the WiFi connection issue). The second time was very smooth.

Well I went and built a really nice quad core i7 intel 2.93ghz Ubuntu machine. 1TB harddrive, nice video card, wireless PCI, 6 gigs of ram and it really flies. Loaded the Jetpack last night and finished at 4am. At one point it showed an install error but continued anyway so I’m guessing it wasn’t fatal. Everything boots fine on the Tx1 now with all software loaded.

But I have a question… can I install ubuntu updates without messing up any software? What about antivirus can I run antivirus on the Tx1 as well?

I wouldn’t run any kind of antivirus on a linux development machine, desktop or otherwise. Just keep the software updated and use strong passwords. However, if you really wanted to run antivirus, I suspect there is no antivirus which functions on ARMv7 or ARMv8a architecture…except perhaps specific to some specialized android variant. Something like “snort” intrusion detection would likely be a more useful choice, but even that is often overkill versus a maintained Linux install. Updates are not generally an issue.

Okay thanks. My concern is just that if the Tx-1 is out there surfing the web that it’s possible it could pick up spyware,spamware, or hijacks from websites. But maybe those aren’t as geared towards linux as they are to PC’s?

I guess my other concern was that if I ran all the linux updates on the Tx1 that the Nvidia software might not be forward compatible with the updates. But it sounds like your saying that’s not an issue?

Thanks for the help.

Package update on JTX1 will not be a compatibility issue when done through the package management system. The old OpenGL library issue was fixed long ago.

About maleware and antivirus: There are hacks out there geared towards flash, specific browsers, so on. Some of those might work on Linux, but making use of those hacks on Linux requires the malware to be altered for that specific purpose…which isn’t as widely available. After that, malware may (and often does) require a specific CPU architecture…for example, any program designed for windows won’t run on Linux without some special compatibility existing…this is true for malware as much as it is for legitimate programs. So if for example you hack an adobe flash plugin…then you’d require installing something on the system to make use of the hack…but if it is designed for windows, it won’t run on linux…if it is designed for linux, it’s probably required to use x86 architecture…which won’t work on ARMv7 or ARMv8a.

The biggest and worst of exploits under Linux is simply to take advantage of open ports. A big example of this is ssh…once this port opens to the public, you can look in security logs and see password cracking attempt a billion different passwords on hundreds of known standard user accounts all day and all night (this can even use enough bandwidth to slow down networking even if the hack is not successful). Once you can log in as administrator on Linux via ssh, the exploit can do anything it wants if SElinux isn’t there enforcing. So firewalls and strong passwords are something you very much need to worry about on a Jetson, but running an antivirus on this is not much of an issue. Even on x86 Linux host someone with updated software and strong passwords won’t have a lot for antivirus to do unless the system has lots of users which do things you can’t control.

Excellent, thank you for the great breakdown. Can you recommend a good firewall for the Tx1?