Can't finish installation Jetpack-s on Jetson TK1

Hi All,

I have a problem for some time.

When I try to install Jetpack on my computer it goes without a single problem until it finishes flashing OS. In the Xterm I have following output:
"…
*** The target ardbeg has been flashed successfully. ***
Reset the board to boot from internal eMMC.

1
Finished Flashing OS
Determining the IP address of target…
192.168.1.9

Waiting for 30 seconds to make sure target is fully up

Host 192.168.1.9 found: line 5

Host 192.168.1.9 found: line 6

/home/developer_1/.ssh/known_hosts updated.
Original content retained as /home/developer_1/.ssh/known_hosts.old
#192.168.1.9:22 SSH-2.0-OpenSSH_6.6.1p1 Ubuntu-2ubuntu2
#192.168.1.9:22 SSH-2.0-OpenSSH_6.6.1p1 Ubuntu-2ubuntu2
#192.168.1.9:22 SSH-2.0-OpenSSH_6.6.1p1 Ubuntu-2ubuntu2
/home/developer_1/
Identity added: /home/developer_1/.ssh/id_rsa (/home/developer_1/.ssh/id_rsa)
scp -F /dev/null -o PubkeyAuthentication=no -o ConnectionTimeout=30 -o StrictHostKeyChecking=no
/home/developer_1/.ssh/id_rsa.pub ubuntu@192.168.1.9:/home/ubuntu/tmp.pub
8.1.9
id_rsa.pub 100% 402 0.4KB/s 00:00
ubuntu@tegra-ubuntu:~ b /home/ubuntu/.ssh/authorrized_keys ubuntu@tegra-ubuntu:~ exit
logout
Connection to 192.168.1.9 closed.
"

And it does nothing after I got to this screen. I mean Xterm does not close and it does not return to the installer nor continue with following steps. Yet Ubuntu was flashed OK on the board and worked just perfect - so I was able to install and run various programs on the board. Yet I’d be glad to have proper dev environment with all nice features included.

I was trying to install:
JetPack-L4T-2.2.1-linux-x64.run
JetPack-L4T-2.3.1-linux-x64.run
JetPack-L4T-3.0-linux-x64.run

(and I had same problem with all those installations).

My Host computer is Ubuntu 16.04 LTS (64 bits) with all most recent updates.

I do use ~/JetPack-L4T/ as installation directory (I mean I copy and launch installers from that directory - does it make any difference?).

Thank you very much
Mikhail.

The 16.04 version may be the problem, it was intended for 14.04. I personally have a Fedora host so I can’t test JetPack, but be aware that you can run JetPack for extra packages on the Jetson at any later date…you just have to be sure you picked the TK1 and have deselected flash. Are you able to run JetPack without flash and do package installs to the Jetson by re-running? I wouldn’t expect installs of package to the 16.04 host to work, but packages specific to the TK1 might install.

I am not 100% sure what could be the reason that 16.04 is the issue, but probably your are correct.

And thanks for the idea - just to go step by step skipping steps already done. But … so far not good :( - it has same idea on following steps too. So I will try to do everything from scratch and do all steps on the board one per run. I will keep you updated.

I will keep the issue opened until I get some clear results (positive or negative).

Mikhail.

So far I have following results:

I tried to go through all the remaining (after the Host-Ubuntu installations) tasks one step at a time.

  1. I managed to finish the “Flash OS Image to Target” task. It showed me OK message and asked to press Enter key. XTerm window got closed and Installation was finished still it did not return to the Manager though (again I selected only one/that task). Image got flashed alright and it is working perfectly, but this task… is still “Pending install” (in the Manager).

  2. I tried to start “Install on Target -> CUDA Toolkit”. It starts alright, asks IP, username and password, opens Xterm window, asks couple times the password, does the installation, but never finish. The XTerm outputs are here:

a) First time installation on freshly flashed OS Image:
"
ubuntu@192.168.1.3’s password:
Copying cuda-repo-l4t-r21.5-6-5-local_6.5-53_armhf.deb file to target…
ubuntu@192.168.1.3’s password:
cuda-repo-l4t-r21.5-6-5-local_6.5-53_armhf.deb
520,107,586 100% 90.67MB/s 0:00:05 (xfr:#1, to-chk=0/1)

sent 520,234,683 bytes received 35 bytes 10,509,792.28 bytes/sec
total size is 520,107,586 speedup is 1.00
"

b) All followings installation attempts (after the first installation):
"
ubuntu@192.168.1.3’s password:
Copying cuda-repo-l4t-r21.5-6-5-local_6.5-53_armhf.deb file to target…
ubuntu@192.168.1.3’s password:
cuda-repo-l4t-r21.5-6-5-local_6.5-53_armhf.deb
520,107,586 100% 90.67MB/s 0:00:05 (xfr:#1, to-chk=0/1)

sent 91,373 bytes received 159,727 bytes 11,160.00 bytes/sec
total size is 520,107,586 speedup is 2,071.32
"

  1. Other tasks like: “Compile CUDA samples” can’t proceed because it requires “CUDA Toolkit” finished first (as a dependecy) and it freeze on that step.

  2. Task “Compile GameWorks Samples” finished alright though (it does not have “CUDA Toolkit” as a dependency), but it is still “Pending install” (in the Manager).

  3. Task with PerfKit installation freezes on some stage too, but this task is not that important now - it would be great to find a way to install “CUDA Toolkit” first.

I found a bunch of scripts in the installation directory, so I think I can try to use those scripts without the manager (probably). Does anyone know what scripts are responsible for what task? Sure I can try to do some investigation myself, but if someone already knows - it will save me a lot of time & efforts.

Also would it be more simple to install Ubuntu 14.x and install everything in there? Still it will be not that convenient to use multiple OS-s (even as VM-s). I’d prefer to have the dev environment on my host computer.

I can’t answer many of the post-install JetPack questions. Someone else will have to answer those. However, one thing does come to mind…if examples are being cross compiled from host then the host would need cross compile tools installed. Possibly compile of examples included the host, in which case the host would require CUDA (which in turn requires an NVIDIA video card with NVIDIA drivers).

I do have NVIDIA card am board of the host (also NVIDIA native drivers installed), but no CUDA though :( . Also - do you have any idea where can I read(/find info) about the installation of CUDA Toolkit on the target board? (it could be something else than Jetson TK1 though - hope I can manage with anything).
Also one more/last question - will it work (the entire environment along with the TK1) if I do the manual installation?

Mikhail.

Quite some time back CUDA was available as a separate install, but eventually required JetPack under arm/arm64. I think desktop is still available separately. JetPack should be able to install CUDA on the Jetson, it’s just a case of selecting the TK1 and then CUDA (you can deselect all else, e.g., deselect flash).

I install CUDA manually (and video driver) on both my host and Jetsons…I can’t use JetPack because I use a Fedora host. Manual install works for both host and Jetson. Here is the URL for desktop CUDA downloads:
https://developer.nvidia.com/cuda-downloads

I personally just use the “runfile” on my x86_64 host…this puts CUDA in “/usr/local/”, then I add required locations to my PATH environment variable.

Note that the last release for 32-bit is CUDA version 6.5 (there won’t be any newer versions for 32-bit). Assuming you are using the most recent L4T version on your JTK1 (R21.5), this is the URL for downloads, including JetPack for that version:
https://developer.nvidia.com/linux-tegra-r215

Normally what JetPack will do for CUDA is to install a “.deb” package which makes CUDA and other packages visible via a local repository in “/var” on the JTK1. This does not in itself install CUDA, but it makes it so apt (and apt-get) can search for and find CUDA. Once you install that “.deb” file it is an ordinary Ubuntu package install, e.g., “apt search cuda”, followed by the application “sudo apt-get install cuda…”.

If you can use JetPack, just let it install CUDA and ignore the details. If you cannot use JetPack, then you have to find out what the download URL is from JetPack and manually download and install the “.deb”, followed by search and install of CUDA via apt. To get JetPack to unpack some of its files on a non-Ubuntu 14.04LTS system (e.g., from Fedora) you would run this command:

bash ./JetPack-L4T-2.3.1-linux-x64.run --noexec
./Chooser
# You can exit Chooser now

After doing the above you will get file “repository.json”. This file contains the URLs for downloading various packages manually (be careful to note architecture…a JTK1 is arm/armhf…you can wget your desired package). For CUDA you’d search that file for the URL of cuda (6.5), download that cuda repo file, copy it to the Jetson, and install via dpkg. After that “apt update”, then any apt search will show CUDA packages which apt can install by standard Ubuntu apt-get methods.

Thanks a lot for the idea. I will try all these right away. I guess I have installed all the packages on my host, to right now - it is just Jetson should be installed. But I will double-check anyway. I will report my progress then.

Mikhail.