Jetpack flashing on TX1 fails

I ran the TX1 Jetpack installer 3 times. Each time it indicated that the flash was programmed and each time when I boot the TX1 there is only the initial image created when I first turned on the dev board. The log files seem to think that everything is OK.

I am using the latest Ubuntu 14.04.01 x64 Host as I didn’t need this OS before my Jetson TX1 purchase and had to download it. HELP

I had the same issue as you, see my thread here

Here’s what I did to fix it:

Reinstall ubuntu on your host machine, but make sure you’re using 14.04.03
Redownload the entire Jetpack package
Make sure your host and TX1 are connected to a router and that the router is connected to the internet
Lastly, and this is important, after you put the TX1 in recovery mode and connect the USB cable make sure the cable stays in the entire time. After flashing, the program should automatically start uploading and installing all the libraries onto the TX1. If it tells you to reboot the TX1 manually, something has gone wrong and you should reinstall everything again. Hope that helps!

AlexP312, thanks for the reply.

I read your thread.

  1. On my host the Ubuntu install image that I used to install the host OS says 14.04.3 but ‘uname -a’ says 14.04.1…

  2. Following your thread I tried de-selecting the OS install which makes the install ‘custom’ and requires specifying the target IP address. Everything on my network gets its IP address from a DHCP server but OK, I reserved an address for the Jetson TX1 board. This also requires booting the target before the install process starts as the target Ethernet needs to be up and running.

  3. Though the installer seems to ‘hang’ on the screen where I specified the target IP address, username and password I can see data being transferred on both the host and target, though at an average of 200 bytes/s. After 90 minutes I shut down the target and data stopped being sent
    by the host. I never did see anything change to the file system on the target board even though about 900 Mib was transferred.

  4. I tried doing a ‘full’ install again but this time using a direct Ethernet connection between the host and the target using a eht1 on the host. This ran fine and reported that the OS was flashed ( same as the previous 3 times ) and I waited until the target booted. Once that happened the Jetpack installer terminated in the terminal from which it was started (I’m back to a prompt…) but the GUI is stuck on the Post Installation Jetson TX1 screen… nothing much happening but a 60-80 bytes/s transfer on both host and target.

I’ve tried all of the possible configurations for install the cross-compiled software and have nothing to show for it. This is pretty frustrating.

Correction: It wasn’t the terminal that spawned the installer GUI but the terminal created by the installer that exited, after flashing the OS, and displaying a prompt. SO this is where the installer hangs… after the target has booted.

More details:

I started over. Re-installed Ubuntu 14.04.3 Host ( the ONLY version available from Ubuntu ). Re-installed the JetPack installer (3 hours). This time I didn’t update the Host OS. After flashing the OS image, and letting the installer boot the target nothing happens except that Ubuntu on the hsot throws up and error message telling me that bamfdaemon has failed and the host and target are sending/receiving data at a <300 byte/s rate. So is the post-OS flashing part of the install supposed to happen at an average 150 byte/s rate? Am I supposed to wait for 10 hours to see if the cross-compiled applications and samples are written to the target? Why hasn’t anyone from nVidia been interested in this? Is there a way to manually transfer the stuff from the host to the target?

Given the variety of states that all of the customer host OS could be in it seems that nVidia needs to do one of the following:

  1. create a better data transfer mechanism between the host and target for application code ( preferred )
  2. perform a better dependency check ( I had the installer resolve depencies… ) and control over the host system environment and processes and be responsible for security issues.

Did you make sure to leave the USB cable in? Try reinstalling and redownloading everything again, but this time update ubuntu before trying to flash. Everything should be automatic after you start flashing. You’ll know things are going right when you see a terminal window with SSH commands on the screen.

Technically, everything that gets pushed and installed to the TX1 is in the folder you download the .run file to, but it also configures everything to work nice with each other so the Jetpack is really the only way. As for Nvidia, they’re really not supporting this platform as well as they should.


  1. DO create the /home/.ssh directory before running the install script! The the install script is broken and you will never get past the OS flashing part of the process.

  2. DO NOT run the Jetpack install script as superuser. For those of us familiar with non-Debian Linux distros and unfamiliar with Ubuntu this might be a habit hard to break. I had to reinstall the host OS 3 times as well as download the source ( 3 hours each time ). I’m really not fond of Ubuntu and HATE the Unity Desktop passionately

  3. For anyone confused by the poor documentation provided and errors within DO start with the Jetpack install before downloading anything else. After the installer flashes the OS it will tell you this in the xterm window that pops up: ‘reset the board to boot from the internal eMMC’. DO NOT take this as an instruction and hit the target reset button! The installer is telling you that it has booted the target… it will take a minute or so to see this on the target HDMI output. It you don’t start seeing a lot of lines flying by in the xterm window a few minutes after the target has displayed the desktop then something is very wrong… installation should proceed at normal data rates for your network

  4. After everything was installed on my target and the installer instructed me to ‘hit the return key to continue’ nothing happened but the cursor moving in the xterm window… I assume that the installation was complete… at least I was able to run the CUDA samples on the target and everything appeared to be present.

This right here. So many times I rebooted the TX1 thinking it was an instruction. Glad you got it working. Be sure to edit the title of the thread.

Final Update:

The post OS install did install the CUDA samples but NOT everything else. I was able to install the desired packages individually however over multiple runs of the installer…

There could be a problem with the Jetson, but if the flash is interrupted the most likely fix is to do a complete flash. Is there an error preventing the completion of a new attempt at flash?

You could flash without JetPack (driver package plus sample rootfs…this is what JetPack does under the covers), then you’d know that no special packaging or configuration issue is in the way. If you have the sample rootfs unpacked and the step done, then with the Jetson in recovery mode the flash would be this:

sudo ./ -S 14580MiB jetson-tx1 mmcblk0p1

If that does not succeed there may be a hardware issue. If that does succeed, then JetPack can still be used to install packages without flashing.