Jetson TK1: JetPack Install Aborts

Hi,

I’m new to this forum, the world of Jetson TK1, and I REALLY need help resolving this issue. I’ve tried installing the Jetson TK1 Jetpack so many times I’ve literally lost count, and I always run into the same issue. Basically, I follow the steps outlined in the following link:

http://docs.nvidia.com/jetpack-tk1/index.html#developertools/mobile/jetpack_install.htm

once all of the software components are done downloading, i’m prompted to begin the install on the host computer. As soon as I select “Next” I get error messages (see messages below). Each and every time this happens, I go and review the folder, and edit the permissions (i.e. , sudo, root). I’ve tried changing the permissions on all directories and subdirectories using the “chmod -R 777 .run” file. I’ve tried running the *.run file in both root and non-root mode, and used the “sudo .run” command. Literally everything! And each time I re-run the *.run file, after changing the permissions, and assuming it would just utilize the previously downloaded files without having to spend hours again re-downloading them, the process aborts, and the files are locked again. Also, no *.log file is ever generated for me to send. Can someone PLEASE HELP ME!!! (also, I have images of previously mentioned issues but don’t know how to attach them in order to show the error messages).

ERROR MESSAGE #1:
“Installer aborted because of error. Please send ~/JetPackTK1-1.0/JetPackTK1-installLog.log to TegraDeveloperPack-Users@nvidia.com

ERROR MESSAGE #2:
“There has been an error. Error running xterm -T “Need root privilege to install” -e “sudo ~/JetPackTK1-1.0/_installer/sudo_daemon-installer=29689 -d=~/JetPackTK1-1.0/_installer/tmp”:/bin/sh: 1: xterm: not found. The application will exit now.”

Thank you in advance!

grad_stud

I don’t have Ubuntu on my development host so I can’t actually use Jetpack. However, did you run the Jetpack installer itself as root or sudo? Since xterm isn’t found it could either be missing or it could be denied because of permissions. Does xterm show via “which xterm”? If not you’ll need to install it (sudo apt-get install xterm).

You were right! I didn’t know that xterm needed to be installed before trying to install JetPack. Unfortunately, I have another issue: during the flashing process, I keep getting “cannot mkdir: input/output error” and “cannot open: no such file or directory”. So, now its not successfully flashing the Jetson.

Can you make sure that the Jetson is in recovery mode? You can do this by:

$ lsusb

on the host machine. One of the devices should read something like:

ID 0955:7140 NVidia Corp.

which indicates that the Jetson is hooked up and ready to be flashed

Can you please confirm your host OS version? JetPack is only supported on Ubuntu12.04 or Ubuntu 14.04. And using virtual machine as the host machine is NOT supported.

If your OS version is the supported version, can you please paste the ~/JetPackTK1-1.0/_installer/logs/flashos.log here?

Host Computer: Ubuntu 14.04 LTS
JetPack: R21.1

I did check the $lsusb, and it was connected in recovery mode. It turns out that ‘xterm’ needed to be installed prior to executing the installation process. Once I downloaded it with “sudo apt-get install xterm” I was able to finish the installation process and flash the Jetson.

Hi,

I had this error because of french accents in the parent directory name.

Hi.

You MUST have English as your native installation language, you could refer to below link for how to resolve it.

https://devtalk.nvidia.com/default/topic/930764/?comment=4857645

Thanks