Initial flashing of TX1 Failed

I bought a TX1 several years ago. It has sat unpowered and unused until today.

I powered it on and it seemed to work. The first thing I did is insert a microSD card and clone the boot OS to it, dd if=/dev/mmcblk0 of=/dev/mmcblk1. I did not connect ethernet or wifi so no updates were run and no time was set. I noticed it came with Ubuntu 14.04. So I powered it down and set it into recovery mode to flash new firmware. I connected the microUSB port to my host linux machine.

I am using Pop!OS 20.04 LTS on my host machine. The Nvidia SDK Manager refuses to install on my host machine. I refuse to install Ubuntu on my host machine.

I set up a virtual machine and installed Ubuntu 18.04 on it. I used USB passthrough to allow the guest vm to see the Jetson. After logging in to the Nvidia SDK Manager GUI and powering the Jetson into recovery mode, it’s able to see the Jetson. I began the installation.

The flashing process took several minutes of course. At the end, it failed. That’s disappointing that flashing fails from an effectively completely new state.

I repeated the install and it said it’s in a bad state. I looked around and learned that it needed to be reset again to restart the install. So I power cycled the device and put it back into recovery mode. Then I restarted the installation process. It continuously fails. The last log messages in the terminal says:

22:31:51 INFO: Flash Jetson TX1 - flash: [ 8.7058 ] Writing partition APP with system.img
22:31:52 INFO: Flash Jetson TX1 - flash: Command tegradevflash --pt flash.xml.bin --storageinfo storage_info.bin --create
22:31:52 INFO: Flash Jetson TX1 - flash: Failed flashing t210ref.
22:31:53 INFO: Flash Jetson TX1 - flash: [ Component Install Finished with Error ]
22:31:53 INFO: Flash Jetson TX1 - flash: [ NV_L4T_FLASH_TX1_WITH_OS_IMAGE_COMP Install took 1m33s ]
22:31:53 ERROR: Flash Jetson TX1 - flash: command terminated with error
22:31:53 SUMMARY: DateTime Target Setup - target: Depends on failed component

Any thoughts to help resolve?

hello user151202,

may I know which JetPack release version you’ve installed to this TX1 device?
you should use JetPack-3.3, which is the final JetPack to support Jetson TX1 Developer Kit.
BTW, here’s TX1 EOL notice for your reference.

I had selected 4.6 because it was the newest. I hadn’t noticed the “show all versions” and so only saw 4.6 and 4.4. SDK Manager does not show a warning that the device is EOL nor that the JetPack version is too new for the device. Please consider that feedback.

After selecting show all versions I selected JetPack 3.3.4 and tried to install that. I also tried to install JetPack 3.3.3 and it also failed. (121.2 KB) (113.9 KB)

I was able to successfully install JetPack 3.3.4 after installing Ubuntu 18.04 on a spare laptop. My Jetson TX1 is now up and running with Ubuntu 16.04.

Are there additional considerations for maximum versions? For example, I wonder whether there is a maximum version of the L4T container images which support TX1. I also wonder whether there is a maximum CUDA version.

Thank you for your time.

no, JetPack-3.3 is the final JetPack to support Jetson TX1 Developer Kit.
you may consider moving to Jetson Nano series if you need the latest release version support.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.