Jetson TX2 SDK Manager seems to have hosed my Host OS in the middle of flashing the Jetson

I couldn’t find a similar post before creating my own post, so please forgive me if this issue has been brought up before. I flashed JetPack 4.4 DP on my new Jetson TX2 through the SDK Manager the other day and it booted well - no problems (no problem with the flashing, although the SDKM did complain several times about a lack of storage space). At the time, I didn’t realize 4.4 was just a release candidate so I tried to reflash my Jetson again with JetPack v 4.3. Something happened in the middle of the process which caused it to error. So I tried restarting SDKM and it still wouldn’t work (for some reason, it wouldn’t accept my correctly entered admin password). So I tried rebooting the computer and the boot hung… with every repeated attempt. The boot hung at “Started waiting until snapd is fully seeded.” The only fix was to reinstall Ubuntu.

Has anybody else run into this issue? I think it may be related to trying to flash JetPack 4.3 on a system that already had 4.4 DP installed.

Hi sac.misc401,

Could you try flash JP-4.3 by manually?

  1. Put TX2 into recovery mode
  2. cd /home/[username]/nvidia/nvidia_sdk/JetPack_4.3_Linux_P3310/Linux_for_Tegra
  3. Flash:
    $ sudo ./ jetson-tx2 mmcblk0p1

It’s working at the moment, since I just rebuilt it from scratch. Here’s a newbie question, so please forgive me: If I follow your instructions and reflash the TX2 now, will I loose all the additional functionality I subsequently installed (i.e., ROS, Realsense, devtools, etc.)?

Hi sac.misc401,

Yes, If you follow my steps, it’s full flash.
All the data are remove, it’s clean image.

If you are concerned about the host PC and not the Jetson, then it is useful to know that JetPack/SDK Manager allows you to deselect installing anything to the host PC itself. The result of purely flashing the TX2 without modifying the host PC is the same as the command @WayneWWW gave. If the host PC had issues, then I suspect it was from changes to the graphics driver to add CUDA support to the host PC (which in turn would require an NVIDIA GPU on the host PC…perhaps you specified installation of GPU-dependent host PC components).

If it was just the host PC which was an issue, then you don’t need to flash the Jetson again. If you do need to flash the Jetson (and changing from JetPack4.4 DP to JetPack4.3 would require flashing again), then you will lose your changes on the Jetson. Normally, if there was some sort of valuable data on the Jetson, then I would suggest first cloning; however, ROS and operating system installation details would not be compatible across the two releases, and so you’d need to install ROS again (a clone would not help for that).