JetPack 2.0 on Jetson TK1 - Installation doesn' t finish

Hi, I have a problem to install the JetPack 2.0 on a Jetson TK1. After flashing the board, the console halt on “Finished Flashing the OS” and doesnt’ t go on. So on the Jetson there aren’t CUDA, Perkit ecc. ecc.

Are you able to restart your Jetson and boot up to the fresh OS iamge?
If so, you can try running JetPack again, but only select the post-install actions. Then JetPack will skip the flashing step and go on to installing CUDA, Perfkit, ect.

Thx. It’s works

It did not work for me. I have gone through the post-install procedure twice and while it displayed a long list of things it said it was writing to the TX1, after the TX1 restarted I have not been able to find anything that was supposed to be written to it from the installation process other than a fresh install of ubuntu. No other samples or development files or even the folders specified in the install docs.

Mine stops here:
/home/rick/JetPack_L4T//_installer/run_command -c=“cp /home/rick/JetPack_L4T/_installer/report_ip_to_host.sh.bak /home/rick/JetPack_L4T/Linux_for_Tegra_tx1/rootfs/home/ubuntu/report_ip_to_host.sh” -d=/home/rick/JetPack_L4T//_installer/tmp

Finished Flashing OS

and just hangs there. The target restarts but nothing happens after that.

Rick

Is your Jetson connected to the same Ethernet router/switch as your PC?

Yes it is.

If networking is an issue I’d also have to wonder if there is any kind of firewall is in need of opening up. I have a second NIC on my host and everything is wide open…but I had to configure the firewall to do this and that I “trust” everything on the private second NIC’s LAN. I’m running fedora, your case may be different running ubuntu, but I think the philosophy on most linux distributions is to default to not allowing some types of network traffic until told to allow it.

I have vanilla ubuntu 14.04 on a bt home hub. The only issue I encountered was a ssh key mismatch as i reflashed 21.3 and then the 21.4 jetpack version and a faulty usb cable.

Other issues where my fault, not implementing exactly the assumptions. If you are on the same router that doesn’t do unusual firewall rules and the jetson is plugged into a router that assigns reliable ip based on macs, it should work.

i run a simple i5 with 8 gig memory, a crappy ocz ssd with screwy read write counter, a 970 with cuda already on it on an asus h81-plus, connected with a TP-LINK TL-WDN4800 N900 Wireless Dual Band PCI over a Netgear wifi range extender that is in 2.4 5ghz fastlane modus to the bthome hub.

after the flash i disconnect the jetson. go down to the router plug in the jetson with a cat 5, directly into the router. the installer waits long enough to deal with that procedure.

Maybe one needs an actual disconnect and not just a restart? A full power down?

If wireless is involved (from the TX1 side) it is likely to fail until configured. Wired is really the only way to go from the TX1 side of flash or initial run…how the host connects to that network won’t be an issue. Do keep in mind that there is a wireless firmware issue on TX1 which is being resolved, so wireless on the TX1 should not be relied upon yet (it won’t hurt to try, but don’t depend on it).

rmsteele,
According to comment #4, device is flashed successfully but then JP hangs because it cannot get IP sent from target.
Can you please select all post-install components, then de-select “Flash OS”, and try again?
This way JetPack will popup a dialog box for entering IP/username/password of target, and you can go on installation with CUDA, etc.

Also, when you found JP hangs, can you please check if the target has already got an IP address assigned? The host is waiting for target to report its IP address, however, if target doesn’t got IP address assigned from router, host will keep waiting.

EdwardZhou
Great and accurate advice. That fixed the problem. I guess I never understood before your comment the post install of the remaining items were completed after the target booted into Linux and the host connected over SSH.

Thank you for that information. The installation docs could probably use a little clarification on this part. I read it several times and never gleaned that for some reason.

Again, thanks.
Rick

Hi,

I’m having a similar problem, but my TK-1 board has an address – I can log in from my Ubuntu 14.04 machine via ssh.

Flashing the OS works, but the succeeding steps fail. I can see that the jetpack scripts manage to get the ip address and even ssh into the tk-1, but there are some errors. I tried skipping the os flash as suggested above with the following result:

I run the november jetpack 2.0 download, I select the TK-1 install, I clear all selections from the component manager and select “custom” install, then I select only “Install visionworks on the tk-1” and accept the installation of the additional required cuda package. I click “Next”. I “accept all” licenses.

I get the “Host installation complete” window with:

The following components are installed:
For Jetson TK1
Post Install
VisionWorks on TK1 Target
+VisionWorks 1.0.25
+VisionWorks Plus(SFM) 0.80.8
+CUDA Toolkit for L4T 6.5.50

and click “OK”. I get the “Install finished, click next to proceed post installation” dialog, and click next.

I enter the ip address (verified, tested with ssh), and “ubuntu” “ubuntu” for user and password, and get the “Post installation click next etc” dialog. I click “next”.

an xterm then pops up and asks me for “ubuntu@192.168.0.95’s password:” which is a little puzzling because I entered it in the dialog before but ok, so I type “ubuntu” and hit enter, and am asked for the password again in the same xterm, ok, I type it. Everything just hangs. I let it sit overnight and found it still sitting there in the morning.

Help?

Using ssh when some sort of sudo or su is involved can cause the need for multiple password requirements, but I’m not familiar enough with JetPack to know if this is what it is doing. One thing which hangs a lot of people is that ssh remembers the ssh fingerprint the first time it succeeds…after that, flashing a Jetson causes this fingerprint to change, and so ssh from the host side will refuse to connect. The twist in the story: Apps which use ssh may need extra code to handle reporting a changed fingerprint/certificate error. Everyone seems to program correct handling and report of a wrong password error, but more rare errors can be overlooked in the application containing the ssh command.

In your host’s ~/.ssh/known_hosts file there is one very long line for each host it has memorized. On the left side will be a name and dotted-decimal IP address associated with that connection. Delete any line (remember, they are long single lines) which uses the current IP address. Then connect again via plain ssh on a command line to establish the identity certificate is ok…and then try your other steps and see if it still hangs.

Hi nzc,

Looks like JetPack wasn’t able to setup passwordless ssh connection. Because when everything works well, IP address/username/password only needs be provided once. Can you please check if the following files have write permission on your HOST machine?
~/.ssh/id_rsa
~/.ssh/known_hosts

Also ~/.ssh/id_rsa.pub file needs read permission.

If the above files have good read/write permission and you are still facing the same problem, can you please run following command in terminal and let me know the results?

<JetPack_dir>/_installer/PageAction jetpack_device_info set_info 192.168.0.95 ubuntu ubuntu

Hello, I seem to have a similar problem.
Th JetPack install is “Unable to determine IP Address of Jetson”
It gives me 2 options:

  1. Try again
  2. Enter it manually
    But I don’t know the IP Address of the Jetson.
    I have the same setup, where my board is connected to a router, that my PC is also connected to.

Most routers have a web interface for viewing settings. That interface would show an IP address.

hello ,
I tried both the configuration in order to perform post installation .
One by directly connecting Jetson to router .
Second is connecting the jetson with host pc via network card interface setting up ip manually.

It gives me 2 options:

  1. Try again
  2. Enter it manually

I entered the manual option(i have a monitor connected to jetson , i can see the ip address) . A window pops up asking the ip address,username and password. I provided with the correct values. Then the window freezes no further action.

Can someone help me solve the problem.

I lack an Ubuntu host (I use Fedora), so it is limited what I can suggest. It sounds like a very common ssh issue. See:
https://devtalk.nvidia.com/default/topic/898683/jetson-tk1/jetpack-2-0-on-jetson-tk1-installation-doesn-t-finish/post/4761890/#4761890

The gist is that each install generates a new ssh key…the key changes. Your system may remember an old key and object to the change as a security risk. When this problem occurs, try manual ssh to ubuntu@tegra-ubuntu on the command line…see if it allows ssh login. If not, follow that other link and remove the old key in known_hosts.

Can you manually ssh connect from host to Jetson device with the IP address, username and password value you entered in the popup window?

If yes, can you please check according to comment https://devtalk.nvidia.com/default/topic/898683/jetson-tk1/jetpack-2-0-on-jetson-tk1-installation-doesn-t-finish/post/4762312/#4762312 ? Please replace 192.168.0.95 with the actual IP of your Jetson device mentioned in this comment.