Install failure - unmet dependencies

Hello. I am working to install Jetpack on Ubuntu 16.04.4 (clean install as VirtualBox under Win10) and within JetPack L4T Components Manager, I can’t seem to get CUDA Toolkit to install. I get the below error message and have looked through comments from others who have had this issue, but I do not see clear instructions on how to resolve it. Can you offer a suggestion? Thank you in advance.


The following packages have unmet dependencies:
cuda-cross-aarch64-9-0 : Depends: g+±aarch64-linux-gnu but it is not installable
cuda-toolkit-9-0 : Depends: cuda-core-9-0 (>= 9.0.252) but it is not going to be installed
Depends: cuda-command-line-tools-9-0 (>= 9.0.252) but it is not going to be installed
Depends: cuda-samples-9-0 (>= 9.0.252) but it is not going to be installed
Depends: cuda-documentation-9-0 (>= 9.0.252) but it is not going to be installed
Depends: cuda-visual-tools-9-0 (>= 9.0.252) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

A VM usually fails, though most of the time it is something related to USB. If you want to attempt VM install see this:
https://devtalk.nvidia.com/default/topic/1002081/jetson-tx2/jetpack-3-0-install-with-a-vm/

In some cases you may need CUDA on the actual host which would imply a valid NVIDIA video card…not sure about this case though.

The topic mentioned is relevant in title, but does not address the issue. The issue here is that there are unmet dependencies. The install does not even get to the flashing process that uses usb. Other ideas are welcome.

You may reinstall the Ubuntu,
or try purge on broken packages, in my opinion.

Yes, i’ve tried both with no resolution.

Hi, I am facing the same issues! :(
have you managed to solve this?

No, I’m still trying to get through it. I’ve tried installing cuda outside of the Jetpack installer, uninstalling g++ standard, and others, but nothing has resolved it so far. It makes me miss the old days when there was support outside of forums. I’ll update this if I make progress and I certainly welcome your thoughts and experiences.

There isn’t enough log to be sure. Keep in mind that if you insert logs into the tags from the “</>” (“code”) icon in the upper right of the text entry widget for posting a reply, then it will preserve formatting and have scrollbars (you can insert more text this way without it being hard to read). Do keep in mind that a VM has problems in general…even if we are looking at a real problem which isn’t from the VM it may alter how we see the problem.

A message such as this:

cuda-cross-aarch64-9-0 : Depends: g++-aarch64-linux-gnu but it is not installable

…implies your host is not allowing a foreign architecture for cross-compile tools used for building samples and other CUDA code to deploy onto the Jetson. A VM host may differ in how it perceives foreign architecture additions (a VM may have a restriction a native host might not have).

Hi,

Recently, we received some failure issue for CUDA tool-kit on the host.
We are checking this problem internally.

If possible, could you also share the log information with us?
It is located at ‘[JetPack_Root]/_installer/logs/’.

Thanks.

Thank you. There were too many characters for the full log, but here is most of the log files, skipping the middle section of the install log. I can email the files to you if that is preferred.

JetPack.log:

04-17 18:37:13.7 E: fopen failed with file local.db, errno = 2
04-17 18:37:15.7 W: One invalid entry
04-17 18:39:33.8 N: Install com.nvidia.nvtools.battle 2.5; Install com.nvidia.nvtools.quadd 4.0; Install com.nvidia.docs.jetpack 3.2; Install com.nvidia.docs.devtools 3.2; Install com.nvidia.middleware.visionworks_docs 1.6; Install com.nvidia.l4t.driver4os_64_tx2 28.2; Install com.nvidia.l4t.filesystem_64_tx2 28.2; Install com.nvidia.l4t.flash_64_tx2 28.2; Install com.nvidia.cuda.l4t_64_tx2 9.0; Install com.nvidia.middleware.cudnn_64_tx2 7.0; Install com.nvidia.gie.l4t_64_tx2 3.0; Install org.opencv.middleware.ocv_l4t_64_tx2 3.3.1; Install com.nvidia.middleware.visionworks_target_64_tx2 1.6; Install com.nvidia.middleware.visionworks_target_sfm_64_tx2 0.90; Install com.nvidia.middleware.visionworks_target_tracking_64_tx2 0.88; Install com.nvidia.mmapi.l4t_64_tx2 28.2; 
04-17 18:42:13.9 E: Failure when receiving data from the peer
04-17 18:43:28.3 E: Failure when receiving data from the peer
04-17 18:59:48.3 N: Install com.nvidia.nvtools.battle 2.5; Install com.nvidia.nvtools.quadd 4.0; Install com.nvidia.docs.jetpack 3.2; Install com.nvidia.docs.devtools 3.2; Install com.nvidia.middleware.visionworks_docs 1.6; Install com.nvidia.cuda.host 9.0; Install com.nvidia.l4t.driver4os_64_tx2 28.2; Install com.nvidia.l4t.filesystem_64_tx2 28.2; Install com.nvidia.l4t.flash_64_tx2 28.2; Install com.nvidia.cuda.l4t_64_tx2 9.0; Install com.nvidia.middleware.cudnn_64_tx2 7.0; Install com.nvidia.gie.l4t_64_tx2 3.0; Install org.opencv.middleware.ocv_l4t_64_tx2 3.3.1; Install com.nvidia.middleware.visionworks_target_64_tx2 1.6; Install com.nvidia.middleware.visionworks_target_sfm_64_tx2 0.90; Install com.nvidia.middleware.visionworks_target_tracking_64_tx2 0.88; Install com.nvidia.mmapi.l4t_64_tx2 28.2; 
04-17 19:53:55.6 E: Failure when receiving data from the peer
04-17 19:55:58.8 E: Failure when receiving data from the peer
                                                                                                     04-20 11:04:39.0 E: fopen failed with file local.db, errno = 2
04-20 11:04:42.8 W: One invalid entry
04-20 11:04:51.2 N: Install com.nvidia.nvtools.battle 2.5; Install com.nvidia.nvtools.quadd 4.0; Install com.nvidia.docs.jetpack 3.2; Install com.nvidia.docs.devtools 3.2; Install com.nvidia.middleware.visionworks_docs 1.6; Install com.nvidia.cuda.host 9.0; Install org.opencv.middleware.ocv_64_host 3.3.1; Install com.nvidia.middleware.visionworks_host 1.6; Install com.nvidia.middleware.visionworks_host_sfm 0.90; Install com.nvidia.middleware.visionworks_host_tracking 0.88; Install com.nvidia.l4t.driver4os_64_tx2 28.2; Install com.nvidia.l4t.filesystem_64_tx2 28.2; Install com.nvidia.l4t.flash_64_tx2 28.2; Install com.nvidia.cuda.l4t_64_tx2 9.0; Install com.nvidia.cuda.compile_cuda_64_tx2 9.0; Install com.nvidia.middleware.cudnn_64_tx2 7.0; Install com.nvidia.gie.l4t_64_tx2 3.0; Install org.opencv.middleware.ocv_l4t_64_tx2 3.3.1; Install com.nvidia.middleware.visionworks_target_64_tx2 1.6; Install com.nvidia.middleware.visionworks_target_sfm_64_tx2 0.90; Install com.nvidia.middleware.visionworks_target_tracking_64_tx2 0.88; Install com.nvidia.mmapi.l4t_64_tx2 28.2; 
04-20 11:32:53.4 E: Failure when receiving data from the peer
04-20 11:46:48.0 N: Installing Tegra Graphics Debugger 2.5 succeeded.
04-20 11:46:55.0 N: Installing NVIDIA System Profiler 4.0 succeeded.
04-20 11:46:55.6 N: Installing JetPack Documentation 3.2 succeeded.
04-20 11:46:57.4 N: Installing DevTools Documentation 3.2 succeeded.
04-20 11:46:58.1 N: Installing VisionWorks References 1.6 succeeded.
04-20 11:48:14.6 E: Installing CUDA Toolkit 9.0 failed.

Return Code: 1
Error installing cuda-toolkit-9-0 cuda-cross-aarch64-9-0  to host, please check /home/jbob/jet/_installer/logs/cuda_host_9.0.log for more details

Terminal_Installer.log:

root      2003  0.2  0.0 330900  2960 ?        Ssl  11:04   0:05 /home/jbob/jet/_installer/sudo_daemon -installer=1834 -d=/home/jbob/jet/_installer/tmp
0
/home/jbob/jet//_installer/run_command  -c="/home/jbob/jet/jetpack_download/2017_11_28_1956-23204764-NVIDIA_Tegra_Graphics_Debugger_2.5.17332.1956_Release_External_tgd-l4t_linux-l4t.run --nox11 -- -noprompt" -d=/home/jbob/jet//_installer/tmp -l=/home/jbob/jet/_installer/logs//install_tegra_graphics_debugger.log
Verifying archive integrity... All good.
Uncompressing NVIDIA Tegra Graphics Debugger  100%  
'pkg/CrashReporter' -> '/usr/local/Tegra-Graphics-Debugger-2.5/CrashReporter'
'pkg/EULA.txt' -> '/usr/local/Tegra-Graphics-Debugger-2.5/EULA.txt'
'pkg/Plugins' -> '/usr/local/Tegra-Graphics-Debugger-2.5/Plugins'
'pkg/Plugins/platforms' -> '/usr/local/Tegra-Graphics-Debugger-2.5/Plugins/platforms'
'pkg/Plugins/platforms/libqxcb.so' -> '/usr/local/Tegra-Graphics-Debugger-2.5/Plugins/platforms/libqxcb.so'
'pkg/Plugins/CorePlugin' -> '/usr/local/Tegra-Graphics-Debugger-2.5/Plugins/CorePlugin'
'pkg/Plugins/CorePlugin/LightTheme.js' -> '/usr/local/Tegra-Graphics-Debugger-2
5/Plugins/CorePlugin/LightTheme.js'
'pkg/Plugins/CorePlugin/BlueTheme.js' -> '/usr/local/Tegra-Graphics-Debugger-2.5/Plugins/CorePlugin/BlueTheme.js'
'pkg/Plugins/CorePlugin/DarkTheme.js' -> '/usr/local/Tegra-Graphics-Debugger-2.5/Plugins/CorePlugin/DarkTheme.js'
'pkg/Plugins/CorePlugin/Manifest.js' -> '/usr/local/Tegra-Graphics-Debugger-2.5/Plugins/CorePlugin/Manifest.js'
'pkg/Plugins/CorePlugin/libCorePlugin.so' -> '/usr/local/Tegra-Graphics-Debugger-2.5/Plugins/CorePlugin/libCorePlugin.so'
'pkg/Plugins/BattlePlugin' -> '/usr/local/Tegra-Graphics-Debugger-2.5/Plugins/BattlePlugin'
'pkg/Plugins/BattlePlugin/EnableBlue.png' -> '/usr/local/Tegra-Graphics-Debugger-2.5/Plugins/BattlePlugin/EnableBlue.png'
'pkg/Plugins/BattlePlugin/Disconnect.png' -> '/usr/local/Tegra-Graphics-Debugger-2.5/Plugins/BattlePlugin/Disconnect.png'
'pkg/Plugins/BattlePlugin/DefaultPerfWorksSignals.js' -> '/usr/local/Tegra-Graphics-Debugger-2.5/Plugins/BattlePlugin/DefaultPerfWorksSignals.js'
'pkg/Plugins/BattlePlugin/Ubuntu-R.ttf' -> '/usr/local/Tegra-Graphics-Debugger-2.5/Plugins/BattlePlugin/Ubuntu-R.ttf'
'pkg/Plugins/BattlePlugin/DefaultNVPMAPISignals.js' -> '/usr/local/Tegra-Graphics-Debugger-2.5/Plugins/BattlePlugin/DefaultNVPMAPISignals.js'
'pkg/Plugins/BattlePlugin/Resume.png' -> '/usr/local/Tegra-Graphics-Debugger-2.5/Plugins/BattlePlugin/Resume.png'
'pkg/Plugins/BattlePlugin/ShaderEdit.png' -> '/usr/local/Tegra-Graphics-Debugger-2.5/Plugins/BattlePlugin/ShaderEdit.png'
'pkg/Plugins/BattlePlugin/EnableGreen.png' -> '/usr/local/Tegra-Graphics-Debugger-2.5/Plugins/BattlePlugin/EnableGreen.png'
'pkg/Plugins/BattlePlugin/Connect.png' -> '/usr/local/Tegra-Graphics-Debugger-2
5/Plugins/BattlePlugin/Connect.png'
'pkg/Plugins/BattlePlugin/EnableAlpha.png' -> '/usr/local/Tegra-Graphics-Debugger-2.5/Plugins/BattlePlugin/EnableAlpha.png'
'pkg/Plugins/BattlePlugin/ExpandAll.png' -> '/usr/local/Tegra-Graphics-Debugger-2.5/Plugins/BattlePlugin/ExpandAll.png'
'pkg/Plugins/BattlePlugin/SelectPerfMarkers.png' -> '/usr/local/Tegra-Graphics-Debugger-2.5/Plugins/BattlePlugin/SelectPerfMarkers.png'
'pkg/Plugins/BattlePlugin/LDPreload.png' -> '/usr/local/Tegra-Graphics-Debugger-2.5/Plugins/BattlePlugin/LDPreload.png'
'pkg/Plugins/BattlePlugin/ToggleWireframe.png' -> '/usr/local/Tegra-Graphics-Debugger-2.5/Plugins/BattlePlugin/ToggleWireframe.png'
'pkg/Plugins/BattlePlugin/ShaderPromote.png' -> '/usr/local/Tegra-Graphics-Debugger-2.5/Plugins/BattlePlugin/ShaderPromote.png'
'pkg/Plugins/BattlePlugin/Manifest.js' -> '/usr/local/Tegra-Graphics-Debugger-2
5/Plugins/BattlePlugin/Manifest.js'
'pkg/Plugins/BattlePlugin/ActivateEditedShaders.png' -> '/usr/local/Tegra-Graphics-Debugger-2.5/Plugins/BattlePlugin/ActivateEditedShaders.png'
'pkg/Plugins/BattlePlugin/Save.png' -> '/usr/local/Tegra-Graphics-Debugger-2.5/Plugins/BattlePlugin/Save.png'
'pkg/Plugins/BattlePlugin/LockWindow.png' -> '/usr/local/Tegra-Graphics-Debugger-2.5/Plugins/BattlePlugin/LockWindow.png'
'pkg/Plugins/BattlePlugin/CollapseAll.png' -> '/usr/local/Tegra-Graphics-Debugger-2.5/Plugins/BattlePlugin/CollapseAll.png'
'pkg/Plugins/BattlePlugin/libBattlePlugin.so' -> '/usr/local/Tegra-Graphics-Debugger-2.5/Plugins/BattlePlugin/libBattlePlugin.so'
'pkg/Plugins/BattlePlugin/EditStateBuckets.png' -> '/usr/local/Tegra-Graphics-Debugger-2.5/Plugins/BattlePlugin/EditStateBuckets.png'
'pkg/Plugins/BattlePlugin/ActivateOriginalShaders.png' -> '/usr/local/Tegra-Graphics-Debugger-2.5/Plugins/BattlePlugin/ActivateOriginalShaders.png'
'pkg/Plugins/BattlePlugin/Configure.png' -> '/usr/local/Tegra-Graphics-Debugger-2.5/Plugins/BattlePlugin/Configure.png'
'pkg/Plugins/BattlePlugin/ShaderCompile.png' -> '/usr/local/Tegra-Graphics-Debugger-2.5/Plugins/BattlePlugin/ShaderCompile.png'
'pkg/Plugins/BattlePlugin/CaptureFrame.png' -> '/usr/local/Tegra-Graphics-Debugger-2.5/Plugins/BattlePlugin/CaptureFrame.png'
'pkg/Plugins/BattlePlugin/FlipImageVertical.png' -> '/usr/local/Tegra-Graphics-Debugger-2.5/Plugins/BattlePlugin/FlipImageVertical.png'
'pkg/Plugins/BattlePlugin/CloneWindow.png' -> '/usr/local/Tegra-Graphics-Debugger-2.5/Plugins/BattlePlugin/CloneWindow.png'
'pkg/Plugins/BattlePlugin/ShowShaderUsages.png' -> '/usr/local/Tegra-Graphics-Debugger-2.5/Plugins/BattlePlugin/ShowShaderUsages.png'
'pkg/Plugins/BattlePlugin/Refresh.png' -> '/usr/local/Tegra-Graphics-Debugger-2
5/Plugins/BattlePlugin/Refresh.png'
'pkg/Plugins/BattlePlugin/Injector.png' -> '/usr/local/Tegra-Graphics-Debugger-2.5/Plugins/BattlePlugin/Injector.png'
'pkg/Plugins/BattlePlugin/CaptureNextFrame.png' -> '/usr/local/Tegra-Graphics-Debugger-2.5/Plugins/BattlePlugin/CaptureNextFrame.png'
'pkg/Plugins/BattlePlugin/EnableRed.png' -> '/usr/local/Tegra-Graphics-Debugger-2.5/Plugins/BattlePlugin/EnableRed.png'
'pkg/Plugins/xcbglintegrations' -> '/usr/local/Tegra-Graphics-Debugger-2.5/Plugins/xcbglintegrations'
'pkg/Plugins/xcbglintegrations/libqxcb-glx-integration.so' -> '/usr/local/Tegra-Graphics-Debugger-2.5/Plugins/xcbglintegrations/libqxcb-glx-integration.so'
'pkg/Plugins/imageformats' -> '/usr/local/Tegra-Graphics-Debugger-2.5/Plugins/imageformats'
'pkg/Plugins/imageformats/libqgif.so' -> '/usr/local/Tegra-Graphics-Debugger-2.5/Plugins/imageformats/libqgif.so'

........

Ign:36 http://us.archive.ubuntu.com/ubuntu xenial/main Translation-en
Get:37 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 DEP-11 Metadata [733 kB]
Ign:38 http://us.archive.ubuntu.com/ubuntu xenial/main DEP-11 64x64 Icons
Get:39 http://us.archive.ubuntu.com/ubuntu xenial/restricted amd64 Packages [8,344 B]
Ign:40 http://us.archive.ubuntu.com/ubuntu xenial/restricted i386 Packages
Get:41 http://us.archive.ubuntu.com/ubuntu xenial/restricted Translation-en [2,908 B]
Ign:42 http://us.archive.ubuntu.com/ubuntu xenial/restricted amd64 DEP-11 Metadata
Get:43 http://us.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages [7,532 kB]
Ign:44 http://us.archive.ubuntu.com/ubuntu xenial/universe i386 Packages
Get:45 http://us.archive.ubuntu.com/ubuntu xenial/universe Translation-en [4,354 kB]
Ign:46 http://us.archive.ubuntu.com/ubuntu xenial/universe amd64 DEP-11 Metadata
Get:47 http://us.archive.ubuntu.com/ubuntu xenial/universe DEP-11 64x64 Icons [7,448 kB]
Ign:48 http://us.archive.ubuntu.com/ubuntu xenial/multiverse amd64 Packages
Get:49 http://us.archive.ubuntu.com/ubuntu xenial/multiverse i386 Packages [140 kB]
Ign:50 http://us.archive.ubuntu.com/ubuntu xenial/multiverse Translation-en
Get:51 http://us.archive.ubuntu.com/ubuntu xenial/multiverse amd64 DEP-11 Metadata [63.8 kB]
Ign:52 http://us.archive.ubuntu.com/ubuntu xenial/multiverse DEP-11 64x64 Icons
Get:15 http://us.archive.ubuntu.com/ubuntu xenial-updates/main Translation-en [314 kB]
Ign:17 http://us.archive.ubuntu.com/ubuntu xenial-updates/main DEP-11 64x64 Icons
Get:19 http://us.archive.ubuntu.com/ubuntu xenial-updates/restricted i386 Packages [7,524 B]
Ign:21 http://us.archive.ubuntu.com/ubuntu xenial-updates/restricted amd64 DEP-11 Metadata
Get:23 http://us.archive.ubuntu.com/ubuntu xenial-updates/universe i386 Packages [574 kB]
Ign:25 http://us.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 DEP-11 Metadata
Get:27 http://us.archive.ubuntu.com/ubuntu xenial-updates/multiverse amd64 Packages [16.2 kB]
Ign:29 http://us.archive.ubuntu.com/ubuntu xenial-updates/multiverse Translation-en
Get:31 http://us.archive.ubuntu.com/ubuntu xenial-updates/multiverse DEP-11 64x64 Icons [14.3 kB]
Ign:33 http://us.archive.ubuntu.com/ubuntu xenial-backports/universe amd64 DEP-11 Metadata
Get:34 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 Packages [1,201 kB]
Ign:36 http://us.archive.ubuntu.com/ubuntu xenial/main Translation-en
Get:38 http://us.archive.ubuntu.com/ubuntu xenial/main DEP-11 64x64 Icons [409 kB]
Ign:40 http://us.archive.ubuntu.com/ubuntu xenial/restricted i386 Packages
Get:42 http://us.archive.ubuntu.com/ubuntu xenial/restricted amd64 DEP-11 Metadata [186 B]
Ign:44 http://us.archive.ubuntu.com/ubuntu xenial/universe i386 Packages
Get:46 http://us.archive.ubuntu.com/ubuntu xenial/universe amd64 DEP-11 Metadata [3,410 kB]
Ign:48 http://us.archive.ubuntu.com/ubuntu xenial/multiverse amd64 Packages
Get:50 http://us.archive.ubuntu.com/ubuntu xenial/multiverse Translation-en [106 kB]
Ign:52 http://us.archive.ubuntu.com/ubuntu xenial/multiverse DEP-11 64x64 Icons
Err:17 http://us.archive.ubuntu.com/ubuntu xenial-updates/main DEP-11 64x64 Icons
  400  Bad Request [IP: 91.189.91.26 80]
Ign:21 http://us.archive.ubuntu.com/ubuntu xenial-updates/restricted amd64 DEP-11 Metadata
Get:25 http://us.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 DEP-11 Metadata [332 kB]
Get:29 http://us.archive.ubuntu.com/ubuntu xenial-updates/multiverse Translation-en [8,565 B]
Get:33 http://us.archive.ubuntu.com/ubuntu xenial-backports/universe amd64 DEP-11 Metadata [5,357 B]
Get:36 http://us.archive.ubuntu.com/ubuntu xenial/main Translation-en [799 kB]
Get:40 http://us.archive.ubuntu.com/ubuntu xenial/restricted i386 Packages [14.5 kB]
Get:44 http://us.archive.ubuntu.com/ubuntu xenial/universe i386 Packages [9,804 kB]
Get:48 http://us.archive.ubuntu.com/ubuntu xenial/multiverse amd64 Packages [176 kB]
Err:52 http://us.archive.ubuntu.com/ubuntu xenial/multiverse DEP-11 64x64 Icons
  400  Bad Request [IP: 91.189.91.26 80]
Fetched 4,952 kB in 28s (173 kB/s)
Reading package lists...
E: Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/xenial-updates/main/dep11/icons-64x64.tar  400  Bad Request [IP: 91.189.91.26 80]
E: Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/xenial/multiverse/dep11/icons-64x64.tar  400  Bad Request [IP: 91.189.91.26 80]
E: Some index files failed to download. They have been ignored, or old ones used instead.
Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 cuda-toolkit-9-0 : Depends: cuda-samples-9-0 (>= 9.0.252) but it is not going to be installed
                    Depends: cuda-documentation-9-0 (>= 9.0.252) but it is not going to be installed
                    Depends: cuda-visual-tools-9-0 (>= 9.0.252) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Get:1 file:/var/cuda-repo-9-0-local  InRelease
Ign:1 file:/var/cuda-repo-9-0-local  InRelease
Get:2 file:/var/cuda-repo-9-0-local  Release [574 B]
Get:2 file:/var/cuda-repo-9-0-local  Release [574 B]
Hit:6 http://security.ubuntu.com/ubuntu xenial-security InRelease
Hit:7 http://us.archive.ubuntu.com/ubuntu xenial-backports InRelease
Get:4 http://us.archive.ubuntu.com/ubuntu xenial InRelease [247 kB]
Ign:8 http://security.ubuntu.com/ubuntu xenial-security/main arm64 Packages
Ign:9 http://security.ubuntu.com/ubuntu xenial-security/universe arm64 Packages
Ign:10 http://security.ubuntu.com/ubuntu xenial-security/multiverse arm64 Packages
Ign:8 http://security.ubuntu.com/ubuntu xenial-security/main arm64 Packages
Ign:9 http://security.ubuntu.com/ubuntu xenial-security/universe arm64 Packages
Get:5 http://us.archive.ubuntu.com/ubuntu xenial-updates InRelease [102 kB]
Ign:10 http://security.ubuntu.com/ubuntu xenial-security/multiverse arm64 Packages
Ign:8 http://security.ubuntu.com/ubuntu xenial-security/main arm64 Packages
Ign:11 http://us.archive.ubuntu.com/ubuntu xenial-backports/main arm64 Packages
Ign:12 http://us.archive.ubuntu.com/ubuntu xenial-backports/universe arm64 Packages
Ign:9 http://security.ubuntu.com/ubuntu xenial-security/universe arm64 Packages
Ign:10 http://security.ubuntu.com/ubuntu xenial-security/multiverse arm64 Packages
Ign:13 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
Err:8 http://security.ubuntu.com/ubuntu xenial-security/main arm64 Packages
  404  Not Found [IP: 91.189.88.162 80]
Ign:9 http://security.ubuntu.com/ubuntu xenial-security/universe arm64 Packages
Get:14 http://us.archive.ubuntu.com/ubuntu xenial/main i386 Packages [1,196 kB]
Ign:10 http://security.ubuntu.com/ubuntu xenial-security/multiverse arm64 Packages
Ign:15 http://us.archive.ubuntu.com/ubuntu xenial/main arm64 Packages
Get:16 http://us.archive.ubuntu.com/ubuntu xenial/main Translation-en [568 kB]
Ign:17 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 DEP-11 Metadata
Get:18 http://us.archive.ubuntu.com/ubuntu xenial/main DEP-11 64x64 Icons [409 kB]
Ign:19 http://us.archive.ubuntu.com/ubuntu xenial/restricted amd64 Packages
Get:20 http://us.archive.ubuntu.com/ubuntu xenial/restricted i386 Packages [8,684 B]
Ign:21 http://us.archive.ubuntu.com/ubuntu xenial/restricted Translation-en
Get:22 http://us.archive.ubuntu.com/ubuntu xenial/restricted amd64 DEP-11 Metadata [186 B]
Ign:23 http://us.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
Get:24 http://us.archive.ubuntu.com/ubuntu xenial/universe i386 Packages [7,512 kB]
Ign:25 http://us.archive.ubuntu.com/ubuntu xenial/universe arm64 Packages
Get:26 http://us.archive.ubuntu.com/ubuntu xenial/universe Translation-en [4,354 kB]
Ign:27 http://us.archive.ubuntu.com/ubuntu xenial/universe amd64 DEP-11 Metadata
Get:28 http://us.archive.ubuntu.com/ubuntu xenial/universe DEP-11 64x64 Icons [7,448 kB]
Ign:29 http://us.archive.ubuntu.com/ubuntu xenial/multiverse amd64 Packages
Get:30 http://us.archive.ubuntu.com/ubuntu xenial/multiverse i386 Packages [140 kB]
Ign:31 http://us.archive.ubuntu.com/ubuntu xenial/multiverse arm64 Packages
Get:32 http://us.archive.ubuntu.com/ubuntu xenial/multiverse Translation-en [106 kB]
Ign:33 http://us.archive.ubuntu.com/ubuntu xenial/multiverse amd64 DEP-11 Metadata
Get:34 http://us.archive.ubuntu.com/ubuntu xenial/multiverse DEP-11 64x64 Icons [230 kB]
Ign:11 http://us.archive.ubuntu.com/ubuntu xenial-backports/main arm64 Packages
Ign:12 http://us.archive.ubuntu.com/ubuntu xenial-backports/universe arm64 Packages
Ign:35 http://us.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
Get:36 http://us.archive.ubuntu.com/ubuntu xenial-updates/main i386 Packages [701 kB]
Ign:37 http://us.archive.ubuntu.com/ubuntu xenial-updates/main arm64 Packages
Get:38 http://us.archive.ubuntu.com/ubuntu xenial-updates/main Translation-en [314 kB]
Ign:39 http://us.archive.ubuntu.com/ubuntu xenial-updates/main amd64 DEP-11 Metadata
Get:40 http://us.archive.ubuntu.com/ubuntu xenial-updates/main DEP-11 64x64 Icons [232 kB]
Ign:41 http://us.archive.ubuntu.com/ubuntu xenial-updates/restricted amd64 Packages
Get:42 http://us.archive.ubuntu.com/ubuntu xenial-updates/restricted i386 Packages [7,524 B]
Ign:43 http://us.archive.ubuntu.com/ubuntu xenial-updates/restricted Translation-en
Get:44 http://us.archive.ubuntu.com/ubuntu xenial-updates/restricted amd64 DEP-11 Metadata [157 B]
Ign:45 http://us.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 Packages
Get:46 http://us.archive.ubuntu.com/ubuntu xenial-updates/universe i386 Packages [574 kB]
Ign:47 http://us.archive.ubuntu.com/ubuntu xenial-updates/universe arm64 Packages
Get:48 http://us.archive.ubuntu.com/ubuntu xenial-updates/universe Translation-en [250 kB]
Ign:49 http://us.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 DEP-11 Metadata
Get:50 http://us.archive.ubuntu.com/ubuntu xenial-updates/universe DEP-11 64x64 Icons [322 kB]
Ign:51 http://us.archive.ubuntu.com/ubuntu xenial-updates/multiverse amd64 Packages
Get:52 http://us.archive.ubuntu.com/ubuntu xenial-updates/multiverse i386 Packages [15.3 kB]
Ign:53 http://us.archive.ubuntu.com/ubuntu xenial-updates/multiverse arm64 Packages
Get:54 http://us.archive.ubuntu.com/ubuntu xenial-updates/multiverse Translation-en [8,076 B]
Ign:55 http://us.archive.ubuntu.com/ubuntu xenial-updates/multiverse amd64 DEP-11 Metadata
Get:56 http://us.archive.ubuntu.com/ubuntu xenial-updates/multiverse DEP-11 64x64 Icons [14.3 kB]
Ign:13 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
Ign:15 http://us.archive.ubuntu.com/ubuntu xenial/main arm64 Packages
Ign:17 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 DEP-11 Metadata
Get:19 http://us.archive.ubuntu.com/ubuntu xenial/restricted amd64 Packages [8,344 B]
Ign:21 http://us.archive.ubuntu.com/ubuntu xenial/restricted Translation-en
Get:23 http://us.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages [7,532 kB]
Ign:25 http://us.archive.ubuntu.com/ubuntu xenial/universe arm64 Packages
Get:27 http://us.archive.ubuntu.com/ubuntu xenial/universe amd64 DEP-11 Metadata [3,410 kB]
Ign:29 http://us.archive.ubuntu.com/ubuntu xenial/multiverse amd64 Packages
Ign:31 http://us.archive.ubuntu.com/ubuntu xenial/multiverse arm64 Packages
Ign:33 http://us.archive.ubuntu.com/ubuntu xenial/multiverse amd64 DEP-11 Metadata
Ign:11 http://us.archive.ubuntu.com/ubuntu xenial-backports/main arm64 Packages
Ign:12 http://us.archive.ubuntu.com/ubuntu xenial-backports/universe arm64 Packages
Get:35 http://us.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages [757 kB]
Ign:37 http://us.archive.ubuntu.com/ubuntu xenial-updates/main arm64 Packages
Get:39 http://us.archive.ubuntu.com/ubuntu xenial-updates/main amd64 DEP-11 Metadata [319 kB]
Ign:41 http://us.archive.ubuntu.com/ubuntu xenial-updates/restricted amd64 Packages
Get:43 http://us.archive.ubuntu.com/ubuntu xenial-updates/restricted Translation-en [2,272 B]
Ign:45 http://us.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 Packages
Ign:47 http://us.archive.ubuntu.com/ubuntu xenial-updates/universe arm64 Packages
Ign:49 http://us.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 DEP-11 Metadata
Get:51 http://us.archive.ubuntu.com/ubuntu xenial-updates/multiverse amd64 Packages [16.2 kB]
Ign:53 http://us.archive.ubuntu.com/ubuntu xenial-updates/multiverse arm64 Packages
Get:55 http://us.archive.ubuntu.com/ubuntu xenial-updates/multiverse amd64 DEP-11 Metadata [5,972 B]
Ign:13 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
Ign:15 http://us.archive.ubuntu.com/ubuntu xenial/main arm64 Packages
Err:17 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 DEP-11 Metadata
  400  Bad Request [IP: 91.189.91.23 80]
Get:21 http://us.archive.ubuntu.com/ubuntu xenial/restricted Translation-en [3,019 B]
Ign:25 http://us.archive.ubuntu.com/ubuntu xenial/universe arm64 Packages
Get:29 http://us.archive.ubuntu.com/ubuntu xenial/multiverse amd64 Packages [176 kB]
Ign:31 http://us.archive.ubuntu.com/ubuntu xenial/multiverse arm64 Packages
Ign:33 http://us.archive.ubuntu.com/ubuntu xenial/multiverse amd64 DEP-11 Metadata
Err:11 http://us.archive.ubuntu.com/ubuntu xenial-backports/main arm64 Packages
  404  Not Found [IP: 91.189.91.23 80]
Ign:12 http://us.archive.ubuntu.com/ubuntu xenial-backports/universe arm64 Packages
Ign:37 http://us.archive.ubuntu.com/ubuntu xenial-updates/main arm64 Packages
Get:41 http://us.archive.ubuntu.com/ubuntu xenial-updates/restricted amd64 Packages [13.1 kB]
Get:45 http://us.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 Packages [800 kB]
Ign:47 http://us.archive.ubuntu.com/ubuntu xenial-updates/universe arm64 Packages
Get:49 http://us.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 DEP-11 Metadata [332 kB]
Ign:53 http://us.archive.ubuntu.com/ubuntu xenial-updates/multiverse arm64 Packages
Err:37 http://us.archive.ubuntu.com/ubuntu xenial-updates/main arm64 Packages
  400  Bad Request [IP: 91.189.91.23 80]
Ign:47 http://us.archive.ubuntu.com/ubuntu xenial-updates/universe arm64 Packages
Ign:53 http://us.archive.ubuntu.com/ubuntu xenial-updates/multiverse arm64 Packages
Fetched 2,420 kB in 39s (61.7 kB/s)
Reading package lists...
E: Failed to fetch http://security.ubuntu.com/ubuntu/dists/xenial-security/main/binary-arm64/Packages  404  Not Found [IP: 91.189.88.162 80]
E: Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/xenial-backports/main/binary-arm64/Packages  404  Not Found [IP: 91.189.91.23 80]
E: Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/xenial/main/dep11/Components-amd64.yml  400  Bad Request [IP: 91.189.91.23 80]
E: Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/xenial-updates/main/binary-arm64/Packages  400  Bad Request [IP: 91.189.91.23 80]
E: Some index files failed to download. They have been ignored, or old ones used instead.
Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 cuda-cross-aarch64-9-0 : Depends: g++-aarch64-linux-gnu but it is not installable
 cuda-toolkit-9-0 : Depends: cuda-samples-9-0 (>= 9.0.252) but it is not going to be installed
                    Depends: cuda-documentation-9-0 (>= 9.0.252) but it is not going to be installed
                    Depends: cuda-visual-tools-9-0 (>= 9.0.252) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Hi,

Guess that there is some issue of installation on your host.
Could you try to install g+±aarch64-linux-gnu on your pc first?

If your are using VM, please check this topic for information:
https://devtalk.nvidia.com/default/topic/1032499

Thanks.

You may also want to see if there is some sort of firewall or router issue. At one place I see an IP address failure to port 80. It would be good to test if your host can see these web pages related to that error:
http://us.archive.ubuntu.com/ubuntu/
http://us.archive.ubuntu.com/ubuntu/dists/xenial-updates/main/dep11/

g+±aarch64-linux-gnu can’t seem to be installed as it ‘has no installation candidate’. Calling out the version in an install leads to a continuous stream of conflicts and unmet dependencies. I’ve tried disabling virus protection\firewalls. As you mentioned, errors like this show up prior to the g++ error:

Err:8 http://security.ubuntu.com/ubuntu xenial-security/main arm64 Packages
  404  Not Found [IP: 91.189.88.162 80]

but I am able to browse locations that throw the 404 errors, example:
http://us.archive.ubuntu.com/ubuntu/
http://us.archive.ubuntu.com/ubuntu/dists/xenial-updates/main/dep11/

Good thoughts, but I’m still stuck. When I get a few more hours, I’ll try a clean install of native ubuntu. Other ideas are more than welcome.

Being able to web browse does imply that port and address work, but there are still specifics as to packages and architectures the 404 might be related to. I assume these are running on your PC. Would you post your “/etc/apt/sources.list from the PC”? I still suspect it is a VM issue, but if not, then this file will probably show something.

Hi,

It’s recommended to run JetPack on a physical machine rather than VM.
We didn’t test the installation from VM and it may have some unsolved issues.

Thanks.

This was my first time using a VM as I’ve always been suspicious of them. I see using a native Ubuntu is the only way to do it, as you recommended. Thank you!

Moreover, you may use other distributions of linux, but they wont support the Jetpack GUI and there will be a need to use terminal flash command instead.

Hello,
I have similar problems with running JetPack on a physical machine
I have downloaded the jetpack 3.3(b39) on a ubuntu 16.04.4 LTS(Xenial Xerus).
The pc has nvidia GeForce GTX cards.

I started the installation on the ubuntu but could not install the cuda-tools. This is the content of the cuda_host_9.0.log file, after the installation error:

(Reading database ... 217574 files and directories currently installed.)
Preparing to unpack .../cuda-repo-ubuntu1604-9-0-local_9.0.252-1_amd64.deb ...
Unpacking cuda-repo-ubuntu1604-9-0-local (9.0.252-1) over (9.0.252-1) ...
Setting up cuda-repo-ubuntu1604-9-0-local (9.0.252-1) ...
OK
Get:1 file:/var/cuda-repo-9-0-local  InRelease
Ign:1 file:/var/cuda-repo-9-0-local  InRelease
Get:2 file:/var/cuda-repo-9-0-local  Release [574 B]
Get:2 file:/var/cuda-repo-9-0-local  Release [574 B]
Hit:3 http://jp.archive.ubuntu.com/ubuntu xenial InRelease
Ign:5 http://jp.archive.ubuntu.com/ubuntu xenial/main arm64 Packages
Ign:6 http://jp.archive.ubuntu.com/ubuntu xenial/universe arm64 Packages
Ign:7 http://jp.archive.ubuntu.com/ubuntu xenial/multiverse arm64 Packages
Hit:8 https://download.docker.com/linux/ubuntu xenial InRelease
Ign:5 http://jp.archive.ubuntu.com/ubuntu xenial/main arm64 Packages
Ign:6 http://jp.archive.ubuntu.com/ubuntu xenial/universe arm64 Packages
Ign:7 http://jp.archive.ubuntu.com/ubuntu xenial/multiverse arm64 Packages
Ign:5 http://jp.archive.ubuntu.com/ubuntu xenial/main arm64 Packages
Ign:9 https://developer.download.nvidia.com/compute/cuda/repos/ubuntu1604/x86_64  InRelease
Hit:10 https://developer.download.nvidia.com/compute/cuda/repos/ubuntu1604/x86_64  Release
Ign:6 http://jp.archive.ubuntu.com/ubuntu xenial/universe arm64 Packages
Ign:7 http://jp.archive.ubuntu.com/ubuntu xenial/multiverse arm64 Packages
Err:5 http://jp.archive.ubuntu.com/ubuntu xenial/main arm64 Packages
  404  Not Found
Ign:6 http://jp.archive.ubuntu.com/ubuntu xenial/universe arm64 Packages
Ign:7 http://jp.archive.ubuntu.com/ubuntu xenial/multiverse arm64 Packages
Hit:12 http://ppa.launchpad.net/webupd8team/atom/ubuntu xenial InRelease
Reading package lists...
E: Failed to fetch http://jp.archive.ubuntu.com/ubuntu/dists/xenial/main/binary-arm64/Packages  404  Not Found
E: Some index files failed to download. They have been ignored, or old ones used instead.
Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 cuda-toolkit-9-0 : Depends: cuda-samples-9-0 (>= 9.0.176) but it is not going to be installed
                    Depends: cuda-documentation-9-0 (>= 9.0.176) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Get:1 file:/var/cuda-repo-9-0-local  InRelease
Ign:1 file:/var/cuda-repo-9-0-local  InRelease
Get:2 file:/var/cuda-repo-9-0-local  Release [574 B]
Get:2 file:/var/cuda-repo-9-0-local  Release [574 B]
Hit:4 http://jp.archive.ubuntu.com/ubuntu xenial InRelease
Ign:5 http://jp.archive.ubuntu.com/ubuntu xenial/main arm64 Packages
Ign:6 http://jp.archive.ubuntu.com/ubuntu xenial/universe arm64 Packages
Ign:7 http://jp.archive.ubuntu.com/ubuntu xenial/multiverse arm64 Packages
Hit:8 https://download.docker.com/linux/ubuntu xenial InRelease
Ign:5 http://jp.archive.ubuntu.com/ubuntu xenial/main arm64 Packages
Ign:6 http://jp.archive.ubuntu.com/ubuntu xenial/universe arm64 Packages
Ign:7 http://jp.archive.ubuntu.com/ubuntu xenial/multiverse arm64 Packages
Ign:5 http://jp.archive.ubuntu.com/ubuntu xenial/main arm64 Packages
Ign:9 https://developer.download.nvidia.com/compute/cuda/repos/ubuntu1604/x86_64  InRelease
Hit:10 https://developer.download.nvidia.com/compute/cuda/repos/ubuntu1604/x86_64  Release
Ign:6 http://jp.archive.ubuntu.com/ubuntu xenial/universe arm64 Packages
Ign:7 http://jp.archive.ubuntu.com/ubuntu xenial/multiverse arm64 Packages
Err:5 http://jp.archive.ubuntu.com/ubuntu xenial/main arm64 Packages
  404  Not Found
Ign:6 http://jp.archive.ubuntu.com/ubuntu xenial/universe arm64 Packages
Ign:7 http://jp.archive.ubuntu.com/ubuntu xenial/multiverse arm64 Packages
Hit:12 http://ppa.launchpad.net/webupd8team/atom/ubuntu xenial InRelease
Reading package lists...
E: Failed to fetch http://jp.archive.ubuntu.com/ubuntu/dists/xenial/main/binary-arm64/Packages  404  Not Found
E: Some index files failed to download. They have been ignored, or old ones used instead.
Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 cuda-cross-aarch64-9-0 : Depends: g++-aarch64-linux-gnu but it is not going to be installed
 cuda-toolkit-9-0 : Depends: cuda-samples-9-0 (>= 9.0.176) but it is not going to be installed
                    Depends: cuda-documentation-9-0 (>= 9.0.176) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I edited the sources.list following the common suggestions in the forum:

deb http://old-releases.ubuntu.com/ubuntu/ xenial main restricted

It improved some of “404 Not Found” error, but eventually unmet dependencies showed up.

Could you offer a suggestion? Thank you in advance.

Hi,

Thanks for your report.
We have feedback this issue to our corresponding team.
Will update information with you later.

Hi,

This issue is caused by some libraries from the repository cannot be installed.
We are trying to fix this issue and here is a workaround:

  1. apt-get purge cuda-license-
  2. apt-get purge cuda-repo-*
  3. dpkg --remove-architecture arm64
  4. apt-get update
  5. apt-get install g++-aarch64-linux-gnu
  6. reinstall CUDA with JetPack

Thanks.