Jetpack 2.3.1 installation issue

I tried flashing the Jetpack 2.3.1 installation today, which only flashes from certain Ubuntu installs as hosts and seems to get problems from anything that’s not exactly as specified. After dealing with the 16.04 problem and downgrading to 14.04 I got to the flashing OS step. At that point, I restarted the system exactly as the instructions said. The OS failed at 6.8021 and just stuck in place. After half an hour, I quit the program. I tried to restart the Jetson TX1 and now it won’t start AT ALL. I now have a hunk of crap metal.

I take it you’ve never dealt with hisilicon.

If it helps you can flash without JetPack (JetPack doesn’t flash, it’s a front end to flashing) on command line to bypass any Ubuntu dependencies from JetPack (flash would work from any x86_64 desktop Linux PC). The flash itself does in fact take a very long time, half an hour could mean the flash was still in progress. During a flash the entire root partition is built up on the host within an enormous loopback mounted file (typically about 15GB in size, this takes much time to create). This is then used to produce a sort of compressed version, and only then does the actual flash content get sent…even compressed this is still a couple of GB and the USB cable won’t send that instantly.

To flash on command line with minimal requirements not using JetPack you would download the driver package and the sample rootfs from here:

After unpacking the driver package you will have a directory “Linux_for_Tegra”. Within that is subdirectory “rootfs”. You’d unpack the sample rootfs there with root permissions (sudo), then

sudo tar xjf /where/ever/it/is/Tegra_Linux_Sample-Root-Filesystem_R24.2.1_aarch64.tbz2
cd ..
sudo ./
# It's now ready to put the JTX1 in recovery mode with micro-USB and flash...
# first make sure you have about 25GB of space:
df -H .
# Then flash:
sudo ./ -S 14580MiB jetson-tx1 mmcblk0p1